Bug 189607 - KDE 4 menu (favorites tab) doesn't remember "Sort Alphabetically (A to Z)" option when set
Summary: KDE 4 menu (favorites tab) doesn't remember "Sort Alphabetically (A to Z)" op...
Status: RESOLVED DUPLICATE of bug 185608
Alias: None
Product: plasma4
Classification: Plasma
Component: widget-kickoff (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-14 13:11 UTC by emikaadeo
Modified: 2009-05-29 16:59 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description emikaadeo 2009-04-14 13:11:58 UTC
Version:            (using KDE 4.2.2)
OS:                Linux
Installed from:    Debian testing/unstable Packages

Steps to reproduce:
Run KDE 4 menu, in Favorites tab, right click on some application
and set "Sort Alphabetically (A to Z)". Now applications are sort alphabetically from A to Z. Then logout and login.
Applications lost theirs alphabetically order.
Comment 1 Anselmo L. S. Melo (anselmolsm) 2009-04-15 22:42:49 UTC
I took a look in the source code and if I'm not wrong the sort method updates only a list with the names of applications, but it doesn't update the other list used to save in data .kde/share/config/kickoffrc .
Comment 2 Sujith H 2009-05-10 18:31:52 UTC
(In reply to comment #1)
> I took a look in the source code and if I'm not wrong the sort method updates
> only a list with the names of applications, but it doesn't update the other
> list used to save in data .kde/share/config/kickoffrc .

Yah you are correct. kickoffrc isn't updated. I would like to work on it. May I take this challenge :)
Comment 3 Dario Andres 2009-05-29 16:59:18 UTC
Marking as dupe of bug 185608 which is marked as FIXED, so it is indeed fixed on trunk. Thanks

*** This bug has been marked as a duplicate of bug 185608 ***