Bug 189583 - Ability to add submenu "like editors" to kicker panel from classic menu
Summary: Ability to add submenu "like editors" to kicker panel from classic menu
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Plasma
Component: widget-kickoff (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 196230 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-04-14 03:17 UTC by David Rankin
Modified: 2012-02-07 07:58 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Rankin 2009-04-14 03:17:13 UTC
Version:            (using KDE 4.2.2)
OS:                Linux
Installed from:    SuSE RPMs

In KDE4 this isn't a simple way to add an entire submenu to the kicker panel from the classic KDE menu any more. In kde3 it was done by right-clicking panel, add application to panel, navigate list, click "Add this menu". That doesn't seem possible in kde4 any longer. That feature should be included. Thanks.
Comment 1 David Rankin 2009-06-07 06:59:41 UTC
Any progress on this? I'm on kde4.3beta and I still can't add my personal "Utilities" menu to the kicker panel. In the menu it is under:

Applications -> Utilities -> dcrUtilities

and that folder has all my commonly used apps. In kde3 I just add that folder to the kicker panel. I want to do that in kde4. My dcrUtilities meny has 3 subfolders and approximately 20 apps in total, plus all of the .desktop references for my rdesktop and XDMCP connections. There is no way to go right to them any more.

The closest thing I can find in 4.3Beta1 is the windows XP like "Quick Launch" widget. That isn't a solution because it cannot contain submenus and having 20 little icons in it is just nuts.

Bottom Line is: we need the functionality of the old "Add this menu here" option to simply add a menu from the start menu to the kicker panel. Thanks.
Comment 2 David Rankin 2009-06-12 19:36:49 UTC
    The classic menu in kde4.3 beta2 looks good, but I have searched and there is still no ability to pick any of the menu folders and 'add' that 'folder' to the kicker 'plasmoid panel' or whatever the new buzz work for kicker is. This was simply accomplished in kde3 by: Right-click on the panel -> Unlock Panel -> Add Application to Panel (navigate to the folder you want) -> Add This Menu; its done! Simple and straight forward. In kde4, it doesn't work anymore. This regression needs to be fixed.

    This is the menu I want to add for example:

http://nirvana/download/openSUSE_bugs/kde4/screenshots/my-dcrTools-menu.jpeg

    Let me know if I can send anything else. Also, I'm ready to test it for you when you have it ready. Just let me know. Thanks.
Comment 3 Christoph Feck 2009-06-12 20:06:15 UTC
*** Bug 196230 has been marked as a duplicate of this bug. ***
Comment 4 Ivan Čukić 2009-06-12 20:13:19 UTC
It is true that there is no 'simple way', but by dragging an applications:/something folder to panel, you'll get the option to add it as a FolderView (which is in menu form when in panel) or by using Lancelot Part (almost the same as the folder view in panel)
Comment 5 Ivan Čukić 2009-06-12 20:19:43 UTC
See http://forum.kde.org/group-menu-widget-t-50294.html
Comment 6 David Rankin 2009-06-13 04:31:15 UTC
Sorry, I didn't mark the cloned report a crash, just a normal bug. It needs attention. That functionality does not work in kde4 and there is no substitute in any of the widgets in the widget list. (I have tried them all)

I added Lancelot Part and it just sucks. It is nothing more than a watered down menu, that doesn't respect the system color scheme and is more awkward to navigate than the normal menu. It doesn't provide anything close to the simple menu folder in the menu like shown in:

http://nirvana/download/openSUSE_bugs/kde4/screenshots/my-dcrTools-menu.jpeg

Why is it so difficult just to get the ability to add a menu folder to the panel fixed?

Ivan you wrote: 

<quote>

It is true that there is no 'simple way', but by dragging an applications:/something folder to panel, you'll get the option to add it as a
FolderView 

</quote>

That simply isn't true. I have opened the menu in both classic and in kick-off view and you cannot drag anything to the panel. If you drag something from the classic menu to the panel, you get nothing but "Find Files and Folders" added to the panel. In kickoff mode - you cannot drag anything to the panel.

This bug has been open for nearly a year, so let's just get the standard ability to add a folder from the menu to the panel fixed.

Since you closed the clone of this report with the elevated, please elevate the status of this report to reflect the fact that it addresses a regression and a loss of functionality compared to KDE3. In it current status is doesn't seem to be getting fixed. Thanks
Comment 7 David Rankin 2009-06-13 05:17:45 UTC
Ivan,

    After my last post, it occurred to me that maybe we are not communicating. So I took a screenshot and annotated it to show you exactly what I am trying to do. All I want to do is add my "dcrTools" menu (circled in a dotted red line) to the panel.

http://www.3111skyline.com/download/openSUSE_bugs/kde4/screenshots/my-dcrTools-menu-2.jpeg

    The arrow (also in red) shows where I want to put it. That way I can just click on the icon and get this:

http://www.3111skyline.com/download/openSUSE_bugs/kde4/screenshots/my-dcrTools-menu.jpeg

    This saves hundreds and hundreds of mouse clicks trying to navigate the normal menu and it allows you to easily group all your most used apps. I hope the pictures help us communicate and conveys just exactly what I'm talking about. Thanks.
Comment 8 David Rankin 2009-06-13 05:38:09 UTC
I am trying to find out how to elevate this bug from wishlist to bug as I've explained. Where do I do that? Bug 196230 should have been left open and this one should have been closed. Do I just need to close this bug and start over or should I reopen 196230 and close this one? Let me know. Thanks.
Comment 9 Ivan Čukić 2009-06-13 10:47:01 UTC
First of all, this *is* a wish, and not a bug. So /elevating/ it is out of the question. Honestly, do you really think that by /pinging/ the bugzilla with your problem will achieve anything?

As for the 'simply not true' part, I haven't told you to drag from the menus (at least not from Kickoff and the classic menu - it works from Lancelot), but to drag the folder.

That is, open dolphin, enter 'applications:/' and drag-n-drop the desired subcategory to the panel.

As for Lancelot Part not following the system theme, it follows the Plasma theme just like any other Plasma applet. And the same is true for the FolerView (in panel mode)

What you could add as a separate wishlist is to be able to drag and drop categories from the menus (kickoff and classic) just like you can drag the icons. (first check whether the wish already exists)

btw, your first link doesn't work.
Comment 10 David Rankin 2009-06-29 10:35:48 UTC
Wait just a minute here. This isn't a Wish. This functionality was present in KDE3, worked very well, and provided the most efficient access to a group of programs from a single button on the kicker bar with submenu capability.

If this isn't a bug, just point me to where I can open the menu editor create a normal menu folder (with sub-folders) and then add it to the panel and have it act like a classic menu just like I have done for the past 4 years. You show me that, I'll close this bug. But we all know you can't.

This has been a hot topic on the openSuSE list under the subject of "When Will  KDE4..." meet kde3 functionality in these areas. 

Putting back into KDE4 what worked in KDE3 isn't a wish, it's a missing feature or broken functionality. Regardless what you call it.

So what has been done to fix missing panel and menu capability described by this report? What part of the code has been worked on and what is the status. Should we expect to have this capability back by 4.3 or not? If not, why not? Does this just involve changes to the plasma-panel or are other components implicated?

I can already build menus that work just like they did in kde3 with kmenuedit, now we just need a way to add the desired branches of the menu to the panel. It should be as simple as changing the plasma-panel to allow the "Add This Folder" selection from the menu just like it works in kde3. So whats the hangup?
Comment 11 David Rankin 2009-06-29 10:41:39 UTC
Oops, I apologize of one of the links above didn't work. I have checked all permissions and they should. Here they are again in case something was lost in the URL above:

http://www.3111skyline.com/download/openSUSE_bugs/kde4/screenshots/my-dcrTools-menu-2.jpeg

http://www.3111skyline.com/download/openSUSE_bugs/kde4/screenshots/my-dcrTools-menu.jpeg

http://www.3111skyline.com/download/openSUSE_bugs/kde4/screenshots/my-dcrTools-menu-kde3.jpg
Comment 12 Ivan Čukić 2009-06-29 11:02:52 UTC
This is a wish to reimplement the feature that was in the previous series.

I'm not saying that this is invalid report or anything. The link I gave you shows that you can create FolderView or Lancelot Part to show you the specified category of the menu, so to achieve almost the same effect you had in KDE3.x.

It doesn't use QMenu as the class for displaying the contents, but rather something that visually fits Plasma.

You don't need to create any folder in order to show it in FV or LP, applications:/ KIO provides /folders/ for you.
Comment 13 James Richard Tyrer 2009-06-29 11:28:41 UTC
Re: Comment #10

> So whats the hangup?

It appear that the hangup is that politics has taken over the KDE project to the detriment of software _engineering_.
Comment 14 Ivan Čukić 2009-06-29 12:31:34 UTC
The reason for the hangup is that nobody has written it.

James, instead of making totally useless comments here, why don't you implement this request?

Sorry if I sound a bit (or more than a bit) rude, it is not my intention. The problem is that bugzilla is meant to help developers to collect user's opinions/problems to help solve them.

It is not meant to express personal opinions, unless those are relate to the reported issue itself. And it is not meant to be used as a place for /waving hands/ or /look at my problem/ type of behaviour.

My involvement in this report was induced by pure wish to help David to achieve the desired thing with the currently available tools. If I were to claim that this report is invalid, I would have closed it.

Unfortunately, my intentions were received in a totally different manner.
Comment 15 Aaron J. Seigo 2009-06-29 18:54:08 UTC
@David: "Putting back into KDE4 what worked in KDE3 isn't a wish"

bugzilla calls "feature requests" "wishes". it's an unfortunate choice of words because it rankles some people, such are yourself. but, and i hope you'll agree, bugs.k.o is a tool to enable us to get our work done, not play semantic games with each other. so just replace "wish" with "missing feature" in your head when you read it here :)

that said, yes, folderview gives you a single level view in your panel, but not a multi-level menu. that ought to be implemented in the form of a simple widget.

"Should we expect to have this capability back by 4.3 or not?"

it is not in 4.3, no.

"If not, why not?"

because no one has implemented it yet or had someone implement it on their behalf. that would include you.

if this is a big issue to the OpenSuse community as you suggest, then i'd suggest in return that the OpenSuse community elect/pay/whatever a developer from your community to spend the time creating it. that's how f/oss works: if someone else doesn't do it for you, you do it yourself or else wait patiently.

"Does this just involve changes to the plasma-panel or are other components
implicated?"

it doesn't involve any changes to the panel, it just needs a new widget written that does just that. it would be a separate component / plugin.
Comment 16 James Richard Tyrer 2009-06-30 01:32:45 UTC
(In reply to comment #15)
> @David: "Putting back into KDE4 what worked in KDE3 isn't a wish"
> 
> bugzilla calls "feature requests" "wishes". it's an unfortunate choice of words
> because it rankles some people, such are yourself. but, and i hope you'll
> agree, bugs.k.o is a tool to enable us to get our work done, not play semantic
> games with each other. so just replace "wish" with "missing feature" in your
> head when you read it here :)
> 
You miss David's point which is that he does not regard this as "feature request".  He, I, and (I would guess) most users regard this as a "regression".

As someone else said, the purpose of BugZilla is to collect information on and discuss the best resolution of bugs.  However, it is for the users, not for the developers.

But why do you waste your time insisting on calling such bugs "feature requests, and why do you do rude things like removing all of the CCs from the bug?  Software engineering is about fixing bugs not about politicizing them.  We are coming up on 4.3.0 and some basic desktop features from 3.5 are still missing (a regression); you should not be surprised that users are not happy about this.
Comment 17 Aaron J. Seigo 2009-06-30 05:29:40 UTC
@James: "why do you do rude things like removing all of the CCs from the
bug?"

because, through the years of demonstration of how you deal with others with rudeness and inappropriate behaviour, you are no longer welcome in my community. your first comment here in this bug report and one i deal with the other day with you just show the same attitude.

i don't care to deal with you james. you provide nothing of value here.

"Software engineering is about fixing bugs not about politicizing them."

well, yes. and in plasma alone we dealt with over 2300 reports in the last 6 months. saying "this is a feature request" is not politicizing it: it's categorizing the request. putting any sort of additional meaning to "feature request" other than "it's a feature that has been requested and has not yet been implemented" is politicizing it.

please, we're losing the whole point of this bug entry, which is: "i'd like an easy way to view a certain branch of the applications menu from a button my panel".

if you have nothing to add to that in terms of additional description of the feature or a patch to implement it, there is nothing more to be said about it.

what a waste of my time this is!
Comment 18 David Rankin 2009-07-01 18:18:51 UTC
Ivan,

    Thank you for looking into this request. It is by far the most useful feature that allows you to go through the 100s of applications in KDE and distill from that the 30 or so you use everyday and to collect your apps in a simple menu with submenu capability and then get to each of your favorite apps with the push of a single button.

    I agree that it doesn't matter to me if we call it a "wish" or a "bug". As long as somebody with the necessary programming skills is willing to work on it and restore this ability, we could call it "swiss cheese" and it wouldn't matter.

    Let me thank you again for taking the time to help with it.
Comment 19 James Richard Tyrer 2009-07-03 12:37:15 UTC
(In reply to comment #18)

> I agree that it doesn't matter to me if we call it a "wish" or a "bug". As
> long as somebody with the necessary programming skills is willing to work on 
> it and restore this ability, we could call it "swiss cheese" and it wouldn't
> matter.
> 
Yes indeed, we humans could call it "Swiss Cheese" and it wouldn't matter.  That being the case, then why is is so important to the developers to change what is obviously a bug to a "wish list" ("feature request") item.  If it doesn't matter then it doesn't matter.  But it does matter to them and, therefore, it should matter to you.  The reason is that it is titled "Severity".  BugZilla stores a numerical rating for the severity of bugs but only the words show for the users.  So, what is being done by changing it from "bug" to "wish list" is that the the severity of the bug has been reduced to the lowest possible value -- the least importance possible.  From what you have said, you certainly do not agree with that.  We both feel that it is important that the features missing from KDE-4 -- features which are in KDE-3.5 -- should be ported ASAP (if not sooner).  I do not understand why the developers simply do not understand that missing features are an important issue.
Comment 20 Will Stephenson 2009-08-24 14:25:43 UTC
SVN commit 1015064 by wstephens:

Allow adding submenus of the application launcher to the panel or the
desktop by right clicking on them in the main menu.

This works by storing the relative path and icon name of KServiceGroups
(== submenus) in the application model used by the menu

When an 'Add to Panel/Desktop' context menu action is triggered, add a
simplelauncher applet (instead of an Icon).

This receives the relative path of the submenu and the icon name in its
args, and when it builds its menu, it walks the applications model and
locates the submenu, rooting the menu at that index rather than the real
root, and setting the icon for the launcher to that of the submenu.

When the applet is showing a submenu, the view types and number of
recent applications to show are not shown in the config UI.

TODO: set tooltip to title of submenu instead of 'Application Launcher
Menu'.

BUG: 189583



 M  +7 -0      core/applicationmodel.cpp  
 M  +4 -1      core/models.h  
 M  +35 -5     simpleapplet/menuview.cpp  
 M  +1 -1      simpleapplet/menuview.h  
 M  +101 -54   simpleapplet/simpleapplet.cpp  
 M  +27 -15    ui/contextmenufactory.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1015064
Comment 21 James Richard Tyrer 2009-08-24 17:10:37 UTC
(In reply to comment #20)
> SVN commit 1015064 by wstephens:
> 
Thank you very much.  Your work is greatly appreciated.
Comment 22 Harland Coles 2012-02-07 07:47:28 UTC
I don't want to dig up old bones, but I think I have a regression of the solution provided by Will Stephenson, back in 2009.  
I too am a recent convert to the KDE4 experience, and so far so good; however, I was fully 'stuck' in KDE3 for work and pleasure and picked up some entrenched habits =).
On OpenSuSE 12.1, KDE 4.7.4, I am not able to 'Add to Panel' a multi-level submenu (like a launcher re-based to a submenu directory)
Comment 23 Harland Coles 2012-02-07 07:58:41 UTC
bugger! Enter key fumble, To continue...
I can 'Add to Panel', but the icon is not a menu widget, but just opens a dolphin instance of "applications:/"
Seems this may be something seen by others, http://www.fedoraforum.org/forum/showthread.php?p=1551997 .

Don't know if I should promote to new 'bug', but may not get any love posting to a 'resolved' posting ;).