Bug 189292 - Minimize task bar entry is not working properly with compositing enabled
Summary: Minimize task bar entry is not working properly with compositing enabled
Status: RESOLVED DUPLICATE of bug 189435
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 188987 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-04-10 17:45 UTC by Alec Moskvin
Modified: 2009-04-13 12:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alec Moskvin 2009-04-10 17:45:32 UTC
Version:            (using KDE 4.2.1)
Compiler:          gcc (Gentoo 4.3.3-r2 p1.1, pie-10.1.5) 4.3.3 
OS:                Linux
Installed from:    Gentoo Packages

This is probably the cause of Bug 188987:

To Reproduce:
1. With compositing enabled, minimize a window.
2. Right-click on the taskbar entry (notice that "Minimize" is not checked)
3. Click on minimize (should restore but nothing happens)

If compositing is disabled, everything works as expected.
Comment 1 Martin Flöser 2009-04-10 18:19:10 UTC
I cannot reproduce. In step 2 "Minimize" is checked.

What is your setting in systemsettings -> desktop -> desktop effects -> advanced for thumbnails? Never, for shown windows or always?
Comment 2 Carl 2009-04-10 18:28:43 UTC
Yes, I filed bug 188987, and Alec has hit the nail on the head. I checked and have the same issue, with 'Keep windows thumbnails' set to 'Always'

Setting it to 'Only for shown windows' solves the 'minimize' issue, and (therefore) also the krdc issue (bug 188987). 

Big thanks for some splendid investigation!
Comment 3 Alec Moskvin 2009-04-10 21:40:12 UTC
Martin,

Yes, I have "Keep window thumbnails" set to "Always." So is it a known bug, then?
Comment 4 Martin Flöser 2009-04-10 22:33:20 UTC
Well there is another bug caused by this: #181848

I'm not sure if this bug is a duplicate of it.
Comment 5 Martin Flöser 2009-04-12 23:23:09 UTC
*** Bug 188987 has been marked as a duplicate of this bug. ***
Comment 6 Martin Flöser 2009-04-13 12:17:37 UTC

*** This bug has been marked as a duplicate of bug 189435 ***