Bug 187757 - KMix settings dialog need some (visual) cleaning up [mockup included]
Summary: KMix settings dialog need some (visual) cleaning up [mockup included]
Status: RESOLVED DUPLICATE of bug 328599
Alias: None
Product: kmix
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: VLO wishlist (vote)
Target Milestone: ---
Assignee: Christian Esken
URL:
Keywords: junior-jobs
Depends on:
Blocks:
 
Reported: 2009-03-21 02:34 UTC by Panagiotis Papadopoulos
Modified: 2013-12-18 12:57 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
The mentioned mockup (29.80 KB, image/png)
2009-03-21 02:41 UTC, Panagiotis Papadopoulos
Details
A screenshot of the current KMix dialog (KDE 4.2.1) (26.98 KB, image/png)
2009-03-21 02:48 UTC, Panagiotis Papadopoulos
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Panagiotis Papadopoulos 2009-03-21 02:34:47 UTC
Version:            (using KDE 4.2.1)
OS:                Linux
Installed from:    Unlisted Binary Package

Hi,

I noticed, that the KMix settings ui currently does not look really nice imho.
So I created a simple mockup, which shows how the settings UI ideally could look like.

btw: I can't seem to find any *.ui file for KMix settings dialog in KDEs svn, is there any?^^

thank you
Comment 1 Panagiotis Papadopoulos 2009-03-21 02:41:05 UTC
Created attachment 32303 [details]
The mentioned mockup
Comment 2 Panagiotis Papadopoulos 2009-03-21 02:48:49 UTC
Created attachment 32304 [details]
A screenshot of the current KMix dialog (KDE 4.2.1)
Comment 3 Christian Esken 2009-03-21 12:31:08 UTC
I am not sure whether your design confomrs to the KDE  Human Interface Guidelines (http://techbase.kde.org/Projects/Usability/HIG), and usablity guidelines.
Also, due to time constraaints it is very unlikely that I will rouch that dialog.
Comment 4 Christian Esken 2009-03-21 12:32:00 UTC
Sorry, typo: Shold have read "touch that dialog"  instead of "rouch that dialog"
Comment 5 Panagiotis Papadopoulos 2009-03-21 13:11:59 UTC
ok I got your point :)
But I think that at least the alignment of the second checkbox should be fixed ;)
Comment 6 Kevin Funk 2013-10-30 21:44:40 UTC
Interesting that this got already posted (4 years ago). The dialog still looks like a mess.

The problem is still the same as shown in comment 1. The proposed mockup should be implemented.

I'm reopening this issue, since this is ...
a) trivial to fix
b) a perfect fit for a junior job
Comment 7 Kevin Funk 2013-10-30 21:51:27 UTC
By the way: I'm also proposing to use a Qt Designer UI file for this dialog.
Comment 8 Christian Esken 2013-12-18 12:57:32 UTC
Closing. I did not remember there was a ticket for this, I have created a new one, bug 328599. For a sneak preview, please see http://kmix5.wordpress.com/2013/11/26/secret-view-in-the-new-configuration-dialog/

*** This bug has been marked as a duplicate of bug 328599 ***