Bug 328599 - Feature: Rework Configuration Dialog
Summary: Feature: Rework Configuration Dialog
Status: CLOSED FIXED
Alias: None
Product: kmix
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Christian Esken
URL:
Keywords:
: 187757 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-12-09 20:41 UTC by Christian Esken
Modified: 2013-12-20 13:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.13


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Esken 2013-12-09 20:41:31 UTC
Configuration dialog has some problems:
- Too many options on one page
- Does not look very much like KDE
- Some useful and frequently requested options (e.g. Volume Overdrive) nor shown
- Sometimes options are not flushed

Reproducible: Always

Steps to Reproduce:
This is an internal refactoring.
Comment 1 Christian Esken 2013-12-09 20:43:09 UTC
I am changing all configuration to KConfigDialog and KConfigSkeleton.

Initial new design shown on http://kmix5.wordpress.com/2013/11/26/secret-view-in-the-new-configuration-dialog/
Comment 2 Christian Esken 2013-12-16 15:03:57 UTC
Done. Will commit after final KDE 4.12 Tag.
Comment 3 Christian Esken 2013-12-18 12:57:32 UTC
*** Bug 187757 has been marked as a duplicate of this bug. ***
Comment 4 Christian Esken 2013-12-20 10:43:26 UTC
Done, and commited to trunk, for KDE4.13.
Comment 5 Christian Esken 2013-12-20 12:12:40 UTC
Git commit 4369fda4ea2d6400f648a418bc55f2e9c14a2c6f by Christian Esken.
Committed on 20/12/2013 at 12:12.
Pushed by esken into branch 'master'.

Implement configuration of backends in SoundMenu

M  +10   -3    apps/kmix.cpp
M  +15   -1    core/mixer.cpp
M  +2    -1    core/mixer.h
M  +16   -34   gui/dialogchoosebackends.cpp
M  +6    -7    gui/dialogchoosebackends.h
M  +4    -12   gui/dialogselectmaster.cpp
M  +13   -5    gui/kmixprefdlg.cpp
M  +1    -1    gui/kmixprefdlg.h

http://commits.kde.org/kmix/4369fda4ea2d6400f648a418bc55f2e9c14a2c6f
Comment 6 Christian Esken 2013-12-20 12:15:44 UTC
(In reply to comment #5)
> Git commit 4369fda4ea2d6400f648a418bc55f2e9c14a2c6f by Christian Esken.
> Committed on 20/12/2013 at 12:12.
> Pushed by esken into branch 'master'.
> 
> Implement configuration of backends in SoundMenu
> 
> M  +10   -3    apps/kmix.cpp
> M  +15   -1    core/mixer.cpp
> M  +2    -1    core/mixer.h
> M  +16   -34   gui/dialogchoosebackends.cpp
> M  +6    -7    gui/dialogchoosebackends.h
> M  +4    -12   gui/dialogselectmaster.cpp
> M  +13   -5    gui/kmixprefdlg.cpp
> M  +1    -1    gui/kmixprefdlg.h
> 
> http://commits.kde.org/kmix/4369fda4ea2d6400f648a418bc55f2e9c14a2c6f

All other changes for this ticket are contained in http://commits.kde.org/kmix/0f7a603e1d327f76dbd6a62d08315b1956794d42
Comment 7 Christian Esken 2013-12-20 13:17:01 UTC
Git commit ac06083d13d3c492a80afd7d2c91b9d4e80f6b5a by Christian Esken.
Committed on 20/12/2013 at 13:16.
Pushed by esken into branch 'master'.

Add enabling/disablign of configuration dialog "apply" button

M  +1    -1    core/mixer.cpp
M  +24   -1    gui/dialogchoosebackends.cpp
M  +26   -17   gui/dialogchoosebackends.h
M  +27   -23   gui/kmixprefdlg.cpp
M  +1    -3    gui/kmixprefdlg.h
M  +6    -6    gui/viewdockareapopup.cpp

http://commits.kde.org/kmix/ac06083d13d3c492a80afd7d2c91b9d4e80f6b5a