Bug 187542 - Cannot make new shortcut action in Configure Shortcuts menu
Summary: Cannot make new shortcut action in Configure Shortcuts menu
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.1.1
Platform: Ubuntu Packages Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
: 206740 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-03-18 19:08 UTC by megawebmaster
Modified: 2009-10-02 01:24 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description megawebmaster 2009-03-18 19:08:37 UTC
Version:           2.0.1.1 (using KDE 4.2.1)
OS:                Linux
Installed from:    Ubuntu Packages

I wanted to make a keyboard shortcut for "Add to playback queue" (like I had in Amarok 1.4.x) but I can't make new action in "Settings/Configure Shortcuts" menu. There is no button, no information about it, I checked also making new scheme and I can't make new shortcut at all.

I'm using version 2.0.1.1 from 'Kubuntu Developers'. No other plugins, just clean install.
Comment 1 Myriam Schweingruber 2009-08-02 20:01:34 UTC
This is not yet implemented AFAICT. Can somebody confirm this?
Comment 2 Myriam Schweingruber 2009-08-11 10:26:47 UTC
Could you test this again with the latest KDE 4.3 (released a week ago and available in the backports PPA) and Amarok 2.1.1 (it is in the jaunty-backports repository since quite some time?
Comment 3 megawebmaster 2009-08-11 13:38:07 UTC
Of course I can try this, but now not on Ubuntu. I've decided to change to Arch Linux. There is KDE 4.3, so it shouldn't be any problem. I'll report what I did.
Comment 4 megawebmaster 2009-08-14 22:24:52 UTC
I'm afraid but I still can't make new shortcuts nor in Amarok neither in KDE  settings. There is just no "New" button or "New shortcut" position under Right Click Mouse menu. If there is something like this - please tell me.
Comment 5 Myriam Schweingruber 2009-08-21 00:31:26 UTC
Changing status
Comment 6 Mark Ziegler 2009-09-08 14:47:45 UTC
Shortcuts are really missed!
e.g. I wanna have F2 to edit meta data (id3)
Compared to 1.4 it is circular to get meta info dialog.

Regards
Comment 7 Myriam Schweingruber 2009-09-08 23:48:09 UTC
*** Bug 206740 has been marked as a duplicate of this bug. ***
Comment 8 Myriam Schweingruber 2009-09-08 23:48:54 UTC
Changing status
Comment 9 Kevin Funk 2009-10-02 01:24:29 UTC
commit b48c604b7ffa3043eb2a949ea61aaade30855120
Author: Kevin Funk <krf@electrostorm.net>
Date:   Fri Oct 2 01:03:12 2009 +0200

    Add enqueue/dequeue shortcuts.
    BUG: 187542