Bug 185618 - Ctrl+A in location bar and forms selects text in webpage not field
Summary: Ctrl+A in location bar and forms selects text in webpage not field
Status: RESOLVED DUPLICATE of bug 181180
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: 4.2.0
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-26 16:44 UTC by Jan-Willem van de Meent
Modified: 2009-02-26 16:45 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan-Willem van de Meent 2009-02-26 16:44:02 UTC
Version:            (using KDE 4.2.0)
OS:                Linux
Installed from:    Unlisted Binary Package

When using the keystroke Ctrl+A in the location bar, or a field in a webform, konqueror selects all text in the window, instead of all text in the field. This can be quite annoying when trying to clear the location bar or a search field.

A workaround is to change the shortcut `KHTML -> Select All' from `Ctrl+A' to something else (e.g. `Ctrl+Shift+A'). All form fields now behave as normal, suggesting the bug is related to an erronous shortcut key hierarchy.

See also: bug 176098, where this behaviour is mentioned in one of the comments.
Comment 1 David Faure 2009-02-26 16:45:42 UTC
Yep, already reported and fixed for 4.2.1

*** This bug has been marked as a duplicate of bug 181180 ***