Bug 181180 - CTRL+A in text input selects the page's content
Summary: CTRL+A in text input selects the page's content
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Applications
Component: khtml (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 181600 182158 182207 182654 182682 183811 184816 185244 185618 185646 187367 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-01-18 15:35 UTC by Rémy Sanchez
Modified: 2009-03-17 12:01 UTC (History)
13 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rémy Sanchez 2009-01-18 15:35:29 UTC
Version:           4.1.96 (KDE 4.2 RC1) (using Devel)
OS:                Linux
Installed from:    Compiled sources

When I'm typing in a text field (I tested either a input or a textarea) and that I want to select the whole text in the text field, I do a CTRL+A. Until yesterday's kde42.debian.net update it was working fine, but now when I'm doing this I get the whole page selected (excepted the text field...)
Comment 1 Frank Reininghaus 2009-01-25 22:10:47 UTC
Thanks for the bug report. I can confirm this in trunk rev. 916621. Bug 181600 looks related.
Comment 2 Frank Reininghaus 2009-01-25 22:40:23 UTC
I think I have identified the commit that caused this regression:
http://websvn.kde.org/?view=rev&revision=907392
Reverting that one fixes it for me. I'll CC David because he committed this change.
Comment 3 Frank Reininghaus 2009-01-25 22:41:29 UTC
*** Bug 181600 has been marked as a duplicate of this bug. ***
Comment 4 Tommi Tervo 2009-01-28 13:49:28 UTC
*** Bug 182158 has been marked as a duplicate of this bug. ***
Comment 5 Frank Reininghaus 2009-01-28 23:28:01 UTC
*** Bug 182207 has been marked as a duplicate of this bug. ***
Comment 6 David Faure 2009-01-28 23:43:30 UTC
SVN commit 917995 by dfaure:

Fix Ctrl+A not going to the lineedit or textedit that has focus, when a Ctrl+A action exists in the window
 (and the same for Ctrl+E and Ctrl+U in lineedits, on X11).
The "real fix" would be in QLineEdit and QTextControl, email sent to qt-bugs.
This fix will be in KDE 4.2.1.
BUG: 181180


 M  +10 -0     klineedit.cpp  
 M  +2 -0      ktextedit.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=917995
Comment 7 Tommi Tervo 2009-02-01 09:54:58 UTC
*** Bug 182654 has been marked as a duplicate of this bug. ***
Comment 8 Tommi Tervo 2009-02-01 11:07:02 UTC
*** Bug 182682 has been marked as a duplicate of this bug. ***
Comment 9 Maksim Orlovich 2009-02-09 19:14:03 UTC
*** Bug 183811 has been marked as a duplicate of this bug. ***
Comment 10 David Faure 2009-02-18 17:45:43 UTC
*** Bug 184816 has been marked as a duplicate of this bug. ***
Comment 11 Maksim Orlovich 2009-02-22 17:18:17 UTC
*** Bug 185244 has been marked as a duplicate of this bug. ***
Comment 12 David Faure 2009-02-26 16:45:42 UTC
*** Bug 185618 has been marked as a duplicate of this bug. ***
Comment 13 David Faure 2009-02-26 21:38:51 UTC
*** Bug 185646 has been marked as a duplicate of this bug. ***
Comment 14 Pino Toscano 2009-03-17 12:01:52 UTC
*** Bug 187367 has been marked as a duplicate of this bug. ***