Bug 184339 - Change the way users interact with tabs in Krdc
Summary: Change the way users interact with tabs in Krdc
Status: RESOLVED FIXED
Alias: None
Product: krdc
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Urs Wolfer
URL:
Keywords:
: 184172 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-02-14 21:15 UTC by Dhaval Patel
Modified: 2009-02-16 14:07 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dhaval Patel 2009-02-14 21:15:04 UTC
Version:           4.2.00 (KDE 4.2.0) (using 4.2.00 (KDE 4.2.0), Kubuntu packages)
Compiler:          cc
OS:                Linux (i686) release 2.6.27-11-generic

I use tabs in all apps (Firefox, Konsole, Kopete) and they seem to work a certain way. You first create a new tab (double click on extra space next to tab or shortcut), then you do things to it like go to a new URL (Firefox) or SSH to a server (Konsole).

To me, this behaviour seems intuitive.

Middle clicking on a tab to close it (or right click and select close tab) would also be better than having the close icon there. Or atleast the option of doing this for people like me (I cannot be the only one to want this).

Double clicking on a tab to edit its properties would be a quick way to make changes (title, connection quality).

Right click -> Add to bookmark can bring up the bookmark window.

These changes would make this application work more consistently with other modern apps. It also allows the user to hide some of the interface elements (menu bar, address bar) and use keyboard shortcuts to do most of their work.
Comment 1 Dhaval Patel 2009-02-14 21:16:30 UTC
*** Bug 184172 has been marked as a duplicate of this bug. ***
Comment 2 Urs Wolfer 2009-02-16 14:07:11 UTC
SVN commit 926947 by uwolfer:

Improve tab behavior:
* Close tabs with mouse middle-click (option)
* Option to disable close buttons on tabs
* Option to set position of tab bar (top, bottom, left, right)
* Context menu on tabs (Close and bookmark action)
* Option options dialog on tab double click for current connection

FEATURE:167432
FEATURE:184339

 M  +7 -1      bookmarkmanager.cpp  
 M  +1 -0      bookmarkmanager.h  
 M  +93 -29    config/general.ui  
 M  +10 -0     core/hostpreferences.cpp  
 M  +4 -0      core/hostpreferences.h  
 M  +9 -0      core/krdc.kcfg  
 M  +79 -4     mainwindow.cpp  
 M  +3 -1      mainwindow.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=926947