Bug 183996 - Add a rule to select the screen
Summary: Add a rule to select the screen
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Unclassified
Component: rules (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist (vote)
Target Milestone: 4.10
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-11 06:28 UTC by Rich
Modified: 2012-10-24 19:45 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 4.10
thomas.luebking: ReviewRequest+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rich 2009-02-11 06:28:52 UTC
Version:            (using Devel)
OS:                Linux
Installed from:    Compiled sources

It would be nice if windows remembered there last open position. 

I use dual monitors and this would be quite helpful. I have set this up manually in each window but this is a pain and would be nice if this would be kwins default. 

For instance I will open yast and it will open in my primary monitor and then click install software and that will open in my 2nd monitor. 

Sometimes programs will randomly pick a monitor to open in. Its quite annoying.
Comment 1 Thomas Lübking 2012-03-14 22:42:20 UTC
This is not the window managers task.Reading as the altered summary.
Otherwise it's a dupe of bug #15329
Comment 2 Thomas Lübking 2012-08-24 16:53:31 UTC
https://git.reviewboard.kde.org/r/106167/
Comment 3 Martin Flöser 2012-10-24 19:45:03 UTC
Commit was missing: http://commits.kde.org/kde-workspace/d24e9054916312e45ccf82c35f7c57a302528b04

commit d24e9054916312e45ccf82c35f7c57a302528b04
Author: Thomas Lübking <thomas.luebking@gmail.com>
Date:   Fri Aug 24 18:48:50 2012 +0200

    add screen rule