Bug 183137 - laptop starts with screen brightness to minimum
Summary: laptop starts with screen brightness to minimum
Status: RESOLVED NOT A BUG
Alias: None
Product: solid
Classification: Frameworks and Libraries
Component: powermanagement-daemon (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal with 30 votes (vote)
Target Milestone: ---
Assignee: Dario Freddi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-04 10:53 UTC by Costin Grigoras
Modified: 2010-11-09 17:02 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Costin Grigoras 2009-02-04 10:53:09 UTC
Version:            (using KDE 4.2.0)
OS:                Linux
Installed from:    Ubuntu Packages

When starting KDE from either cold boot or resuming from suspend to ram, the screen brightness is reduced to minimum. Going to the brightness control panel, the setting is to maximum, and moving it a bit back and forth makes it bright again. The keys also work, but they start from that minimum and go slowly up.

This happens on two laptops, Asus G50v/Nvidia and Dell Inspiron 640e/Intel video card.

This only showed up after upgrading to KDE 4.2.0, from Ubuntu packages: http://www.kubuntu.org/news/kde-4.2
Comment 1 Farit 2009-02-12 22:51:20 UTC
This problem also with my laptop. When kdm is loaded brighness reduced to minimum. Asus M51kr/ati
System. ArchLinux, KDE4.2.0
Comment 2 Xwang 2009-03-03 20:10:54 UTC
I've the same problem with my Asus n50vn. I've seen that till the loading of kde the brightness is ok (I'm using kubuntu 8.10 amd64 with kde 4.2 from the backports repository). Then it goes to the minimum when the settings are loaded after the login. Moreover, if I manually increase the brightness and then unplug the AC cord, the brightness goes to the values for the battery mode (brighter than minimum) and if I plug the AC cord again, brightness goes again to minimum.
So perhaps the standard value for the AC power plugged is wrong.
Is it possible, meantime, to modify the brightness with a script to add to the Autostart one?
Thank you,
Xwang
Comment 3 Andreas Fackler 2009-08-28 00:01:58 UTC
*** This bug has been confirmed by popular vote. ***
Comment 4 andrew 2009-10-01 04:55:37 UTC
this bug seems to be related to bug 181718
Comment 5 Beat Wolf 2009-12-09 20:04:10 UTC
*** Bug 196232 has been marked as a duplicate of this bug. ***
Comment 6 Dario Freddi 2010-11-09 17:02:31 UTC
This bug should be fixed indeed. It is a duplicate of some other lingering bugs, hence marking as invalid.