Bug 181718 - screen brightness knob has no effect at all
Summary: screen brightness knob has no effect at all
Status: RESOLVED DUPLICATE of bug 196232
Alias: None
Product: solid
Classification: Frameworks and Libraries
Component: powermanagement-kcm (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal with 10 votes (vote)
Target Milestone: ---
Assignee: Dario Freddi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-24 04:06 UTC by Shawn Starr
Modified: 2010-11-09 17:01 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shawn Starr 2009-01-24 04:06:31 UTC
Version:           Version 4.2.60 (KDE 4.2.60 (KDE 4.3 >= 20090116)) (using Devel)
Compiler:          gcc version 4.3.2 20081105 (Red Hat 4.3.2-7) (GCC) 
OS:                Linux
Installed from:    Compiled sources

I have a IBM ThinkPad T42 the 'Screen Brightness' knob doesnt change the screen brightness at all.

Don't have much to provide for debug ;/
Comment 1 David Heidelberg 2009-01-24 22:46:14 UTC
Hi! I have same problem with 4.1.96. MSI GX620X-061CZ. Changing brightness with Fn key working fine, but results are not reflected in powerdevil applet. Confirming this bug.
Comment 2 Dominik Tritscher 2009-01-29 16:00:19 UTC
On a friends notebook (Dell Studio 1537) the same behaviour occurs, additionally, the screen brightness is correctly set on profile changes.Everything works fine on my own Fujitsu-Siemens Lifebook T4210.

BTW: This is assigned to powerdevil-kcm, shouldn't it be powerdevil-daemon instead?
Comment 3 Mark Greenwood 2009-02-12 00:32:24 UTC
Same here on a Sony VAIO GR-315MP. Using KDE 4.2RC1
Comment 4 Vladislav Blanton 2009-05-23 15:07:02 UTC
same here on a System76 Serval Professional. Generation 1.  I do not know the specific model information of the stuff inside, but i know that the screen is a Compal HEL80 LCD Screen and the graphics card is a PCI Express Nvidia Geforce Go 7600 (G70). OEM vendor is also Compal Electronics for the graphics card.

Hope that helps.  Fn keys work fine, just not the slider in powedevil applet
Comment 5 Georg Grabler 2009-06-27 03:21:49 UTC
Hi,

I experience(d) quite similar problems, but I'd like to describe it a little bit more in detail instead of writing a "here too" post.

System specification:
Arch Linux (core, no testing), x86_64
KDEMOD testing (chakra-project.org)
KDE Version: 4.2.92
Qt Version: 4.5.1
Compiler version: gcc 4.4.0

1.) I started KDE, with a second screen attached. It seems as if powerdevil believes that my 2nd monitor screen is the laptop screen afterwards for some reasons. It can not control the brightness of this monitor though (what's very likely to be intended :p)

2.) This behaviour never changed. Powerdevil never (not even after a reboot) could change the brightness of my laptop screen anymore.

3.) I deleted all my ~/.kde* directories, unplugged my 2nd monitor and booted kde "clean". Powerdevil properly set the brightness, and I was able to choose a brightness with the given slider.

4.) After plugging in my 2nd screen, restarting X / KDE, KDE seems to remember which of those two was my notebook screen and which not (?). I can still choose a brightness, and powerdevil "works fine"


I think the default behaviour should be, that powerdevil either chooses the right display, or at least provide a possibility to manage it.
Comment 6 andrew 2009-10-01 04:52:11 UTC
I'm experiencing problems with screen brightness on two separate laptops.  Both have intel graphics (Acer Aspire 5315 with x3100/GM965 and a Medion Akoya 2211 with x4500).  Both are running arch linux with Version 4.3.1 (KDE 4.3.1) (KDEmod).

Right now on the Acer I can set the screen brightness using the keyboard (Fn+left/right) but as soon as I click on the battery monitor plasmoid the screen brightness drops to a minimum (reflected in the position of the brightness slider of the plasmoid) and trying to increase it using the slider on the plasmoid does nothing.  If I leave the plasmoid open and adjust the brightness via the keyboard I see no change in the brightness slider of the plasmoid.

On the Medion the problem has most often presented itself differently: at KDE startup, screen brightness is set to a minimum and the battery monitor plasmoid slider is powerless to change it.  If I remove the battery monitor and restart KDE the screen brightness is reset to full.  I can then restart the battery monitor and have it work correctly.  However it is too much of a bother and I've take to running without the battery monitor at all lately.

This seems like a simple initialisation but and I was hoping (expecting) it would be fixed pretty quickly :-(
Comment 7 andrew 2009-10-01 04:57:26 UTC
This bug could be related to bug 183137
Comment 8 Nate Weibley 2009-12-13 07:39:34 UTC
Duplicate of bug 196232. Fix suggested there.
Comment 9 William Melgaard 2010-05-01 18:42:51 UTC
New Ubuntu release (5/1/2010) results in screen brightness minimized, not adjustable.
Linux (i686) release 2.6.32-21-generic
IBM Thinkpad X41
Comment 10 Dario Freddi 2010-11-09 17:01:44 UTC
This bug has actually not been closed...

*** This bug has been marked as a duplicate of bug 196232 ***