Bug 182838 - Facebook tool does not work any more
Summary: Facebook tool does not work any more
Alias: None
Product: digikam
Classification: Applications
Component: Plugin-WebService-Facebook (show other bugs)
Version: 6.4.0
Platform: Appimage Linux
: NOR normal
Target Milestone: ---
Assignee: Digikam Developers
: 395203 396976 (view as bug list)
Depends on:
Reported: 2009-02-02 09:41 UTC by anoosh
Modified: 2020-09-14 07:52 UTC (History)
14 users (show)

See Also:
Latest Commit:
Version Fixed In:

Facebook Developer Board (89.43 KB, image/png)
2019-02-21 09:22 UTC, Maik Qualmann

Note You need to log in before you can comment on or make changes to this bug.
Description anoosh 2009-02-02 09:41:43 UTC
Version:           0.10.0-beta8 (using 4.2.00 (KDE 4.2.0) "release 83.1", KDE:KDE4:Factory:Desktop / openSUSE_11.0)
Compiler:          gcc
OS:                Linux (i686) release

I have used Export to facebook for some time, but now it does not work. when i select an image and click export, it opens Konqueror and i log in successfully to facebook. when i return to the application, the bar goes up to 67% but after that i get an error:

Facebook Call Failed: Unknown method

and it fails.
Comment 1 caulier.gilles 2009-02-02 09:56:47 UTC
I cannot confirm this. i use this plugin without any problem...

Gilles Caulier
Comment 2 Andi Clemens 2009-02-02 10:26:54 UTC
I can confirm it with another error message:

"Facebook Call Failed: Unknown signature"

Comment 3 Luka Renko 2009-02-02 11:33:34 UTC
Can you run it with debugs enabled (kdebugdialog, turn everything on, restart app) and send me the output in konsole over the e-mail?
Are you using rc1 or SVN version?
Comment 4 Luka Renko 2009-02-02 12:10:58 UTC
Nevermind: I can reproduce. It is due to the facet that I have change application type from Web to Desktop on Facebook. Will fix, but I have also turned back to Web type, so that it works for existing users.
Comment 5 Luka Renko 2009-02-02 12:29:43 UTC
Can you try that it works now for you?
Comment 6 Andi Clemens 2009-02-02 13:04:20 UTC
It is working for me again...
Comment 7 Luka Renko 2009-02-02 13:32:05 UTC
OK, will than chaneg this with RC2 release, so that it does not impact too many users. Sorry for troubles caused.
Comment 8 Luka Renko 2009-02-13 23:20:57 UTC
SVN commit 925700 by lure:

Facebook application type has changed to Desktop (was wrongly set as Web before).

This requires slightly different way of authenticating/signing API requests and
will therefore break Facebook import/export for all users that will not upgrade
to new code. Since Release Candidate 2 is this weekend, this should not be for 
too long. SVN users should just rebuild.

BUG: 182838

 M  +2 -1      NEWS  
 M  +22 -4     facebook/fbtalker.cpp  
 M  +21 -17    facebook/fbtalker.h  
 M  +6 -2      facebook/fbwindow.cpp  
 M  +1 -0      facebook/fbwindow.h  

WebSVN link: http://websvn.kde.org/?view=rev&revision=925700
Comment 9 pbhj 2018-04-11 18:47:55 UTC
It doesn't work _again_ but I'm not sure, despite recent activity here, if this is the right place to post about it?
Comment 10 Maik Qualmann 2018-04-11 19:23:42 UTC
The Facebook uploader still works with a little trick. The Facebook uploader will soon be ported to OAuth as part of the GSoC project. Use the Firefox browser. After login comes to the end the page with the security warning. Look in the history of browser an entry back, the page with the "access_token=". This is the address digiKam wants.

Comment 11 René 2018-05-24 15:54:46 UTC
I am not absolutely sure, if the following is the same bug, but at least it matches to the title.

When trying to set up an account for a export to Facebook, I get this on Facebook:
App not set up: This app is still in development mode, and you don't have access to it. Switch to a registered test user or ask an app admin for permissions.

I also just discovered that all albums, which were uploaded via Digikam export completely vanished from Facebook. Not sure if this is related to the app mode.

I am using the git build (Digikam and Kipi plugins), built just an hour ago.
Comment 12 Maik Qualmann 2018-05-24 16:22:25 UTC
Right, our API key is in developer mode. The Facebook uploader currently can not be used. A student works in the frame of the Google Summer of Code 2018 to port Facebook uploader to OAuth. Due to new guidelines, the Facebook uploader will be reviewed after the completion of Facebook and the key will go into productive mode. That will probably be sometime late in the summer. The disappeared albums related to the deactivation, I do not think so. Here in our account everything is still available.

Comment 13 René 2018-05-24 19:32:47 UTC
Thank you for the fast response.
If the uploader is not usable for a while, it might be a good idea to add this information either in the export window or on the website. Or even disable this option in the menu.

I was searching for a while, but could just not figure out why it was not working.
Comment 14 Maik Qualmann 2018-05-24 19:55:59 UTC
The current git/master version is basically a not yet released digikam-6.0.0-beta1. We will write a note on the website when we publish the beta1.

Comment 15 René 2018-05-24 20:24:53 UTC
It is not only about the git master. I tried version 5.9.0 just before trying with the git master. I got exactly the same message there. This was actually the reason why I tried the git branch.
So a hint on the website would probably be nice already.

But this solved my problem for now. Of course it is up to you when you will publish something on the website :-)

Many thanks
Comment 16 Maik Qualmann 2018-06-10 07:28:50 UTC
*** Bug 395203 has been marked as a duplicate of this bug. ***
Comment 17 caulier.gilles 2018-06-10 07:45:40 UTC

This new file will be certainly fixed with your new development branch, and later in 6.0.0 when code will be merged back to master. Please confirm


Comment 18 Thanh Trung Dinh 2018-06-10 08:29:24 UTC

Yes, I can confirm that. 


Comment 19 caulier.gilles 2018-06-10 10:11:15 UTC
So, you will be able to close this file for 6.0.0, and register the file title in NEWS file. 

Please do this when your branch will be merged to master, and only at this time, else you will see conflict in NEWS file while merging branches.

Comment 20 caulier.gilles 2018-06-10 10:12:00 UTC
And don't forget to set "Version Fixes In" to "6.0.0" when you will close this file as fixed.

Comment 21 Ben Reid 2018-06-12 21:03:04 UTC

As far as I can tell, while the API key is in development mode, all albums published by Digikam are no longer visible in Facebook except to specific test users (which would include yourself, I assume, so this may not be obvious to you). For some of us who have uploaded a lot of photos via Digikam this is a more significant issue than the inability to upload new albums directly. The latter problem can be worked around by exporting to file system and doing manual uploads for now until the OAuth2 version is ready.

Hopefully the albums will return to visible when the API key is restored to production mode. Is there any way to expedite this please?

Many thanks,

Ben Reid
Comment 22 Maik Qualmann 2018-06-13 06:03:52 UTC
New guideline on Facebook require each app to be submitted for a review. Presumably we had overlooked or not received the message, so Facebook had disabled the API key in May. As the app is currently being updated as part of the GSoC2018 and to use the key for testing, it is now in developer mode. We are planning to release a Beta1 soon and want to merge the new code of the GSoC2018 projects. However, only then must the review be made by Facebook.

Comment 23 David Kredba 2018-08-28 18:50:39 UTC
I do not see the Facebook export tool listed in the Export menu of Digikam version 6.0.0-beta1 compiled from source on Gentoo. Cmake was showing only two optional components missing during configure phase - libmediawiki and libqav.
Do I miss something or it is not added back yet please?
Comment 24 Maik Qualmann 2018-08-28 19:02:12 UTC
The Facebook export tool is still under review on Facebook. If Facebook does not object, our API key will be unlocked for use and we can activate the tool in digiKam.

Comment 25 Ben Reid 2018-10-29 22:24:30 UTC
Have you had any word from Facebook on the app review yet? I'd still like access to my previously uploaded albums, but that needs the API key to be in public mode again. 


Comment 26 Maik Qualmann 2018-10-30 07:46:17 UTC
At the moment we have lost some interest in Facebook. We still have to look through the wishes of Facebook and see how and if we can implement it. We should explain to the user what we need requested rights for (upload images to Facebook albums, what else?). Facebook would like a blue login button with the Facebook logo, etc. Further trademarks logos in digiKam source code will not be enjoyed by the KDE guys. The uploader would have to be submitted again after the changes with screencasts and so on all over again. I do not think the uploader is included in digiKam-6.0.0 in December.

Comment 27 Charlie Gorichanaz 2018-10-30 17:23:49 UTC
(In reply to Maik Qualmann from comment #26)
> At the moment we have lost some interest in Facebook.

This makes me sad, but I guess now I will not be waiting around for something that may never happen. I was very upset when the Adobe Photoshop Lightroom Facebook integration had a blip and I lost all my photos (https://votecharlie.com/blog/2017/05/years-of-photos-comments-gone-from-facebook.html), and was even more upset there was no way for me to simply use an app to help me upload photos that I would still retain full control over. Now that I switched to Linux, I thought I would give the open source tools a chance as well but found problems there, which are still not solved (this thread). That said, I am not solving them myself even though it is possible for anyone to help, so I therefore should also not complain. I at least wanted the record to show more than one person is interested in this. :-)
Comment 28 caulier.gilles 2018-10-30 19:02:43 UTC

The FB export tool is important as this SN still very used everywhere.

But FB deal as a crazy to impose desgin and rules over the tool that is out of what the team want do and must do. We have no enough free time to pass with FB to change a coma in source code (:=))). Seriously, FB want to be the god of Internet, where it's just a F... SN. The recent huge data leak from FB is just a demontration of the evil...

So, if you is interested to achieve the validation of this tool (technical ready for production), you is welcome. We will guide you for the stages to deal with FB stuff...

Gilles Caulier
Comment 29 Maik Qualmann 2018-11-18 08:30:35 UTC
Git commit 24a699a9982a6ca463700177919250618ce08615 by Maik Qualmann.
Committed on 18/11/2018 at 08:30.
Pushed by mqualmann into branch 'master'.

first step to bring back the Facebook tool as a standalone tool

M  +2    -2    core/utilities/assistants/webservices/common/manager/wsauthentication.cpp
M  +250  -181  core/utilities/assistants/webservices/facebook/fbtalker.cpp
M  +19   -16   core/utilities/assistants/webservices/facebook/fbtalker.h
M  +2    -4    core/utilities/assistants/webservices/facebook/fbwindow.cpp

Comment 30 Maik Qualmann 2018-12-09 16:43:04 UTC
A small status update. The uploader was submitted for review on 18.11.2018 including screencasts. So far no answer. According to the FAQ is currently an increased volume and it takes several weeks.
We need the "user_photos" permission to upload images. If I read the description of Facebook:
Provides access to the photos a person has uploaded or been tagged in. This is available through the photos edge on the User object. This permission is restricted to a limited set of partners and usage requires prior approval by Facebook.
Whether we will probably belong to the limited partners...???

Comment 31 Charlie Gorichanaz 2018-12-13 00:25:57 UTC
(In reply to Maik Qualmann from comment #30)

> Whether we will probably belong to the limited partners...???

Thank you very much Maik for the update. Please let me know if this is rejected for some reason and you need some contacts at Facebook.
Comment 32 jcdouglas 2019-02-20 02:55:35 UTC
Any updates on this?

It is confusing for users as it took several days to find this bug report as to why the 'publish to Facebook' option is not working.  Especially when a majority of documentation points to digiKam being able to perform this task and the previous Facebook issues found by google are over 3-7 years old.  In troubleshooting other software this at least explains why Shotwell's stopped working as well.
Comment 33 Maik Qualmann 2019-02-21 09:22:32 UTC
Created attachment 118246 [details]
Facebook Developer Board

Here is a screenshot of the Facebook Developer Board. I will now cancel the review and submit again to the review, perhaps the review request on Facebook "lost" gone. Of course, it can take even longer.

Comment 34 caulier.gilles 2019-05-20 04:00:42 UTC
*** Bug 396976 has been marked as a duplicate of this bug. ***
Comment 35 Maik Qualmann 2019-07-22 19:41:59 UTC
Git commit fcf4516240810e8f304725c6deb79799b3d0e979 by Maik Qualmann.
Committed on 22/07/2019 at 19:40.
Pushed by mqualmann into branch 'master'.

add a message to the Facebook plugin and disable compiling

M  +5    -5    core/dplugins/generic/webservices/facebook/CMakeLists.txt
M  +15   -11   core/dplugins/generic/webservices/facebook/fbplugin.cpp

Comment 36 Maik Qualmann 2019-07-22 19:52:08 UTC
We received this message from Facebook:

You will need to complete this step in addition to App Review before you can access live data.
Business verification: You'll need to connect your app to a Facebook Business
Manager account and upload an official document showing your business or
organization's name and physical address. You'll also need to sign 1 contract.


We are not ready to conclude this contract with Facebook. If an organization is ready to do so, they can contact us.

Comment 37 dantou 2020-02-20 17:31:01 UTC
Can't transfer to facebook and quit
Comment 38 kde 2020-09-14 07:44:50 UTC
I'm confused. Why does the plugin need to access live data? That seems the reason why it requires a business behind the API access.
Comment 39 Maik Qualmann 2020-09-14 07:52:28 UTC
We don't need any live data. But the right to access users' photos also requires extended rights.