Bug 182104 - Specific transition effect of the slideshow screensaver is extremely slow
Summary: Specific transition effect of the slideshow screensaver is extremely slow
Status: RESOLVED FIXED
Alias: None
Product: kscreensaver
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR normal with 363 votes (vote)
Target Milestone: ---
Assignee: kscreensaver bugs tracking
URL:
Keywords:
: 283284 288349 289459 290814 296731 310369 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-01-27 18:20 UTC by Marcelo Sales
Modified: 2013-09-12 01:02 UTC (History)
34 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.11.2


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcelo Sales 2009-01-27 18:20:16 UTC
Version:            (using KDE 4.1.4)
OS:                Linux
Installed from:    Fedora RPMs

One specific transition effect of the slideshow screensaver is EXTREMELY slow. It takes a lifetime to complete and, if one wants to stop the screensaver and get back to work on the computer when this transition ir running, it takes up to 10 seconds from the time a key is pressed or the mouse is moved until the screensaver stops and the desktop is available again.
The effect is the one in which dots of the new image appear over the old one until the new image is fully displayed. It seems there are two very similar effects, one with very small dots and other identical, but with slightly larger dots. The first is still slower than the second.
The transition with these effects is so slow and takes so much time to complete that it's no surprise that almost every time I sit at the computer, this transition is running and I have to wait 10 seconds until it stops after I press any key.

As a workaround while this is not fixed, I would suggest that theses transition effects are disabled. A patch for this was provided in comment #6 of bug 165156. It would be nice if the user could select what transition effects he wants to use in the screensaver configuration screen.

Please comment out this transition effect while this problem is not solved, this will make the slideshow screensaver perfectly usable again. The way it is now, it's not usable.

Thanks.
Comment 1 Netterfield 2009-09-08 05:11:25 UTC
The problem appears to be graphics card dependent:
I see the reported problem with an Intel 82945G/GZ Integrated
but not with a nVidia Corporation G70 [GeForce 7600 GT]
Comment 2 Marcin Gryszkalis 2011-02-07 08:46:31 UTC
I can confirm this and I have G84 (nvidia GeForce 8600 GT) with native driver (195.36.31). I have compisiting OFF and twinview (dual screen) enabled.

IMHO most of transition effects are slow while "dots" are slowest one, "horizontal lines" is also veeery slow.
Comment 3 japet 2011-10-12 11:24:34 UTC
I can confirm this and I have nVidia GeForce 3100M with native driver
(280.13). I have compisiting OFF and twinview enabled (but with twinview disabled all similar).

Ubuntu 11.10 beta2 with KDE 4.7.2
3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:56:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
Comment 4 Paul Lemmons 2011-10-26 02:55:59 UTC
This has become beyond incredible since upgrading to Kubuntu 11.10. I have seen some transitions take up to 30 minutes to complete. Touching a key or moving the mouse does not end the transition, either. It can take upwards of 20 seconds for it to decide to stop drawing dots and end the screensaver. This is the only screen saver that I find valuable. Please fix this!
Comment 5 Nick Coghlan 2011-11-15 02:24:35 UTC
*** This bug has been confirmed by popular vote. ***
Comment 6 Nick Coghlan 2011-11-15 02:29:28 UTC
I've hit this one after the upgrade to Fedora 16. With the transitions sometimes taking so long, hitting Ctrl-Alt-L is no longer an effective way to hide the screen before walking away from the computer.

The long lag before being waking up when one of the affected transitions is running is also annoying.

Intel graphics, dual screens here.

I agree with Marcelo that adding the ability to select which transitions were enabled would be a perfectly acceptable workaround.
Comment 7 Oswald Buddenhagen 2011-12-06 21:17:46 UTC
*** Bug 288349 has been marked as a duplicate of this bug. ***
Comment 8 Swâmi Petaramesh 2011-12-07 09:32:38 UTC
I have this bug both with Intel, ATI or NVidia graphics, the last one using proprietary drivers.

This bug has been there for a long time but I confirm that it has much worsened with Kubuntu 11.10 Oneiric than previously : it's slower than ever, and exiting the screensaver is very irresponsive - can take up to 20" just to go back to work !

(OTOH using the OpenGL slideshow from xscreensaver works good, but this one has a tendancy to crash my Intel graphics machine [kills X and KDE session] when exiting the screensaver, which is worse than being slow...)
Comment 9 Florian Höfer 2011-12-10 16:39:02 UTC
It appears here on Fedora 16 (KDE spin, default installation and upgrade) and ATI graphics, using the radeon driver. On Fedora 14 and 15 it was all OK. Now all transitions are slow, some transitions last a couple of minutes, making this screensaver unusable
Comment 10 Tom Helner 2011-12-16 19:35:17 UTC
I can confirm this is awful on Kubuntu 11.10 (KDE 4.7.4 from kubuntu-ppa, Dell Vostro 1400 w/ nVidia GeForce 8400M video). So bad that I have gone to the "blank screen" screen saver. Not only does it take way too long to present a workable desktop when stopped, my laptop get quite hot, and the fan starts running at full speed while the slide show screen saver is running. I wish I could simply disable all transition effects.
Comment 11 Paul Lemmons 2011-12-16 20:37:47 UTC
..."I wish I could simply disable all transition effects."...

Add the following line:

EffectsEnabled=false

to the end of the file:

~/.kde/share/config/kslideshow.kssrc

And your wish is granted
Comment 12 Nick Coghlan 2011-12-18 23:18:31 UTC
Thank you Paul, that workaround works beautifully!
Comment 13 Oswald Buddenhagen 2012-01-06 17:59:49 UTC
*** Bug 289459 has been marked as a duplicate of this bug. ***
Comment 14 Oswald Buddenhagen 2012-01-06 17:59:57 UTC
*** Bug 290814 has been marked as a duplicate of this bug. ***
Comment 15 seb 2012-01-06 18:05:48 UTC
Hi all and happy new year 2012.
The transitions between photos, especially fades, are infinitely slow.
The output of screensaver is extremely slow (it can take several seconds
between the movement of the mouse or a keystroke and the exit of the
screensaver)
Some transitions are particularly ugly and not very modern.


Reproducible: Always

Steps to Reproduce:
Use Kscreensaver (Slideshow)


Expected Results:  
I would only simple transitions like fades or fades black, faster, with fast
output screensaver.


Note that the slideshow gl xscreensaver works fine, but suffers from a lack of
integration in KDE in the field of energy management.
Thank you.
Comment 16 seb 2012-01-06 18:21:06 UTC
(In reply to comment #11)
Yeah ! Works fine !
Thx !
Comment 17 Tom Helner 2012-01-06 22:23:47 UTC
In reply to comment #11

Thanks Paul, that worked perfectly!
Not only does it cure the CPU load and the slowness but in general I prefer it without the transitions.
Comment 18 gene smith 2012-01-18 03:36:23 UTC
(In reply to comment #11)
> ..."I wish I could simply disable all transition effects."...
> 
> Add the following line:
> 
> EffectsEnabled=false

Should be made a documented feature and added to the gui!

Also, want to mention that k-slideshow transitions were good at fedora 14 and 15 but bad at 16. Graphics is some kind of radeon built on the motherboard. This happen also a while back (maybe kde 4.1) but somehow got fixed and was good for a few years. Now it's back.
Comment 19 Thomas Eschenbacher 2012-02-21 07:36:49 UTC
I can confirm the same, most transitions are painfully slow. The defect came after some update, but don't remember exactly which one. Desktop effects of the plasma desktop work all fine and with full speed.

I'm running Gentoo with KDE-4.8.0 and tried to build the kde-base/kdeartwork-kscreensaver without and with the "opengl" use flag set - both settings show the same miserable speed.

- nVidia GeForce 7100 GS
- x11-drivers/nvidia-drivers-290.10

"ltrace -C -r -T /usr/bin/kslideshow.kss"
shows me that most of the time is spent inside of QPainter::drawPixmap(...).
Does this mean that the Qt drawing engine is responsible for the bad performance?
Comment 20 Petr Kopecký 2012-02-23 19:41:08 UTC
The same problem on Arch linux, x86-64 and ATI Radeon HD 6300 graphics with open source driver.
Comment 21 Rex Dieter 2012-02-28 16:30:41 UTC
*** Bug 283284 has been marked as a duplicate of this bug. ***
Comment 22 Kyle 2012-02-28 16:41:47 UTC
(In reply to comment #11)
> ..."I wish I could simply disable all transition effects."...
> 
> Add the following line:
> 
> EffectsEnabled=false
> 
> to the end of the file:
> 
> ~/.kde/share/config/kslideshow.kssrc
> 
> And your wish is granted

AHH!! Fix it for me too.  Been looking for the cause.

My system: F16 x86_64, KDE-4.7.4, Intel Video
Comment 23 Christopher Heiny 2012-02-28 16:48:32 UTC
[copying my comment from bug 283284, with tweaks]

This is a pretty appalling bug.  With transitions enabled, when the slideshow
KDE screensaver is on X winds up using 75% to 80% of one CPU core, and
kslideshow winds up using another core 40% to 50%.  And this is after the LCD
itself has been blanked.  So basically it's using more than a core of
compute power to do nothing at all.  

On the other hand, the comment #11 hack worked for me.
Comment 24 Tom Helner 2012-02-28 17:02:40 UTC
I completely agree with Comment #18. There should be a simple check box in the GUI to disable transitions effects. Especially since the semi-documented Comment #11 hack is so easy. The configurability of KDE is one of the things I love about it.

Honestly, even after this bug is fixed I will not be turning the transitions effects back on. I much prefer it with them off. Just my $0.02.
Comment 25 Christoph Feck 2012-03-27 23:59:32 UTC
*** Bug 296731 has been marked as a duplicate of this bug. ***
Comment 26 Juan Luis Baptiste 2012-04-08 02:27:20 UTC
(In reply to comment #11)
> Add the following line:
> 
> EffectsEnabled=false
> 
> to the end of the file:
> 
> ~/.kde/share/config/kslideshow.kssrc
> 

How could I disable the effects globally so I can patch Mageia packages while this is fixed ?
Comment 27 Joseph Thayer 2012-04-29 01:28:23 UTC
It has not been possible to disable the transition effects on my Kubuntu 10.04 (i386,generic); the display card is nVidia but I use the nv driver, with no special effects enabled.  It would be nice to know why the suggested workaround doesn't work on this machine.  An old machine--GigaByte K8NSpro with Athlon 64 3000+.
Comment 28 Alexey 2012-06-20 08:06:18 UTC
After update from kde 4.7.x to 4.8.3 screensaver become very slow. Photos appears more than in minute.
Other desktop effects are works fine.

Gentoo 3.1.6 #2 SMP x86_64 Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz GenuineIntel GNU/Linux
Comment 29 Peter Maffter 2012-09-05 08:23:34 UTC
Same bug here.
OpenSuSE 12.1 x86_64, 3.1.9-1.4-desktop
KDE Version 4.8.3 (4.8.3) "release 504"
NVIDIA-Linux-x86_64-304.37 for ASUS ENGTX570 DCII nVidia graphic card.

Workaround from Comment 11 Paul Lemmons 2011-12-16 20:37:47 UTC 
works if inserted into
~/.kde4/share/config/kslideshow.kssrc

To be solved: insert a button into the slideshow dialog which enables switching
off of the transition effects and check why some of these effects are taking
too much resources.
Comment 30 Jekyll Wu 2012-12-23 06:58:57 UTC
*** Bug 310369 has been marked as a duplicate of this bug. ***
Comment 31 Mircea Kitsune 2012-12-23 09:59:27 UTC
I can confirm this bug in KDE 4.8.5, openSUSE 12.2. I use the Slideshow screen saver, but if transition effects are enabled it takes nearly 5 minutes to transition to an image, making the screen saver unusable.

[WORKAROUND] - If anyone else is having this issue and wishes to use this screen saver, you can disable transition effects by opening ~/.kde4/share/config/kslideshow.kssrc and adding the line EffectsEnabled=false somewhere.
Comment 32 Jan SMID 2013-01-12 18:38:01 UTC
i'm confirming this bug on:  4.9.4, sabayon X.
and i'm observe this since kde 4.0 (on kde 3.5.x this was not this bug).
Comment 33 Jan SMID 2013-01-12 20:13:54 UTC
(In reply to comment #32)
> i'm confirming this bug on:  kde-4.9.4, sabayon X.
> and i'm observe this since kde 4.0 (on kde 3.5.x this was not this bug).

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

xorg driver: x11-drivers/xf86-video-intel-2.20.16
Comment 34 José Juan 2013-01-16 23:00:25 UTC
Same bug once again. This time on:
openSUSE 12.2 (x86_64) Linux 3.4.11-2.16-desktop x86_64
KDE:  4.9.5 "release 3"
Screen information
   nVidia Corporation - Model:  GT200 [GeForce GT 220]
   2D Controller 2D:  nvidia 3D Controller:  NVIDIA 304.64
Comment 35 Christoph Feck 2013-02-04 22:38:57 UTC
*** Bug 310369 has been marked as a duplicate of this bug. ***
Comment 36 savedario 2013-06-20 09:14:19 UTC
It's now:
openSUSE 12.3 (x86_64) Linux 3.7.10-1.11-desktop
KDE: 4.10.3 "release 1"
with an old Radeon HD 3850
and this bug is still there.
Thanks @Mircea Kitsune for the workaround
Comment 37 Christoph Feck 2013-09-12 00:50:00 UTC
SVN commit 1364811 by cfeck:

Disable slow slideshow screensaver transition effects



 M  +5 -5      slideshow.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1364811
Comment 38 Christoph Feck 2013-09-12 01:02:19 UTC
SVN commit 1364814 by cfeck:

Backport of r1364811 and r1364813:
- Disable slow slideshow screensaver transition effects
- Fix blobs to also cover right and bottom edges

FIXED-IN: 4.11.2


 M  +8 -8      slideshow.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1364814