Bug 181846 - Filters in KMail 1.10.4 segfault
Summary: Filters in KMail 1.10.4 segfault
Status: RESOLVED DUPLICATE of bug 160238
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.10.4
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-25 10:32 UTC by Conrad Meyer
Modified: 2009-03-19 00:39 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Conrad Meyer 2009-01-25 10:32:46 UTC
Version:           1.10.4 (using KDE 4.1.4)
Compiler:          gcc 4.3.2 
OS:                Linux
Installed from:    Fedora RPMs

Backtrace:
Application: KMail (kmail), signal SIGSEGV
0x00007f7847e81f81 in nanosleep () from /lib64/libc.so.6
[Current thread is 1 (Thread 0x7f7843159800 (LWP 4167))]

Thread 2 (Thread 0x7f783c835950 (LWP 4168)):
#0  0x00007f7847eb8aa2 in select () from /lib64/libc.so.6
#1  0x0000000000727626 in ?? () from /usr/lib64/libQtCore.so.4
#2  0x000000000065e852 in ?? () from /usr/lib64/libQtCore.so.4
#3  0x0000000000a343da in start_thread () from /lib64/libpthread.so.0
#4  0x00007f7847ec02bd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f7843159800 (LWP 4167)):
[KCrash Handler]
#5  0x00007f785175f985 in KMMetaFilterActionCommand::start () from /usr/lib64/libkmailprivate.so.4
#6  0x00007f785175fa4d in KMMetaFilterActionCommand::qt_metacall () from /usr/lib64/libkmailprivate.so.4
#7  0x000000000075b764 in QMetaObject::activate () from /usr/lib64/libQtCore.so.4
#8  0x00007f784a041bf7 in QAction::triggered () from /usr/lib64/libQtGui.so.4
#9  0x00007f784a0423c0 in QAction::activate () from /usr/lib64/libQtGui.so.4
#10 0x00007f784a352d5a in ?? () from /usr/lib64/libQtGui.so.4
#11 0x00007f784a352ff5 in QAbstractButton::mouseReleaseEvent () from /usr/lib64/libQtGui.so.4
#12 0x00007f784a41a84a in QToolButton::mouseReleaseEvent () from /usr/lib64/libQtGui.so.4
#13 0x00007f784a099fd9 in QWidget::event () from /usr/lib64/libQtGui.so.4
#14 0x00007f784a0478dd in QApplicationPrivate::notify_helper () from /usr/lib64/libQtGui.so.4
#15 0x00007f784a04fefa in QApplication::notify () from /usr/lib64/libQtGui.so.4
#16 0x00007f784bfdd60b in KApplication::notify () from /usr/lib64/libkdeui.so.5
#17 0x0000000000747391 in QCoreApplication::notifyInternal () from /usr/lib64/libQtCore.so.4
#18 0x00007f784a04f298 in QApplicationPrivate::sendMouseEvent () from /usr/lib64/libQtGui.so.4
#19 0x00007f784a0b3919 in ?? () from /usr/lib64/libQtGui.so.4
#20 0x00007f784a0b2337 in QApplication::x11ProcessEvent () from /usr/lib64/libQtGui.so.4
#21 0x00007f784a0d8ae4 in ?? () from /usr/lib64/libQtGui.so.4
#22 0x00007f784772279b in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#23 0x00007f7847725f6d in ?? () from /lib64/libglib-2.0.so.0
#24 0x00007f784772612b in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#25 0x000000000076f79f in QEventDispatcherGlib::processEvents () from /usr/lib64/libQtCore.so.4
#26 0x00007f784a0d828f in ?? () from /usr/lib64/libQtGui.so.4
#27 0x0000000000745cb2 in QEventLoop::processEvents () from /usr/lib64/libQtCore.so.4
#28 0x0000000000745e3d in QEventLoop::exec () from /usr/lib64/libQtCore.so.4
#29 0x00000000007482ed in QCoreApplication::exec () from /usr/lib64/libQtCore.so.4
#30 0x0000000000402e6b in _start ()
Comment 1 Dario Andres 2009-01-25 13:47:20 UTC
If you can reproduce the crash at will, may you read http://techbase.kde.org/Development/Tutorials/Debugging/How_to_create_useful_crash_reports and post a complete backtrace here? Thanks :)
Comment 2 Conrad Meyer 2009-01-25 15:42:04 UTC
Well, I can't seem to reproduce it -- maybe it was a problem migrating from the kmail in Fedora 9 to 1.10.4. I had a filter set up that would classify a mail as spam and move it to my spam folder. The first time I ran this filter in kmail 1.10.4, it crashed and produced that backtrace. Subsequent applications of the filter don't crash kmail.
Comment 3 Christophe Giboudeaux 2009-01-26 11:24:47 UTC

*** This bug has been marked as a duplicate of bug 160238 ***