Bug 160238 - Crash when applying filter
Summary: Crash when applying filter
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail
Classification: Applications
Component: filtering (show other bugs)
Version: 1.9.50
Platform: Gentoo Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 181846 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-04-02 01:06 UTC by Cristi
Modified: 2009-01-26 11:24 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cristi 2008-04-02 01:06:12 UTC
Version:           0.50.50 (using 4.00.67 (KDE 4.0.67 >= 20080325), Gentoo)
Compiler:          x86_64-pc-linux-gnu-gcc
OS:                Linux (x86_64) release 2.6.24-gentoo-r3

I tried migrating to kmail, I imported my local mail folder, and tried to remark in kmail the spam messages. I used bogofilter, byt he way. Clicking "spam" on all the 34 messages( not exact number) crashed kmail. Backtrace: 
Application: KMail (kmail), signal SIGSEGV
[Thread debugging using libthread_db enabled]
[New Thread 0x2b03e5887500 (LWP 24816)]
[New Thread 0x40800950 (LWP 24830)]
[KCrash handler]
#5  0x00002b03d69578d5 in KMMetaFilterActionCommand::start (this=0xba53a0)
    at /var/tmp/paludis/kde-base/kdepim-9999.4/work/kdepim-9999.4/kmail/kmcommands.cpp:1773
#6  0x00002b03d69579a5 in KMMetaFilterActionCommand::qt_metacall (
    this=0xba53a0, _c=QMetaObject::InvokeMetaMethod, _id=6750305,
    _a=<value optimized out>)
    at /var/tmp/paludis/kde-base/kdepim-9999.4/work/kdepim_build/kmail/kmcommands.moc:1460
#7  0x00002b03d4f3d4b2 in QMetaObject::activate (sender=0xa728b0,
    from_signal_index=<value optimized out>, to_signal_index=6, argv=0x41)
    at kernel/qobject.cpp:2995
#8  0x00002b03df8c24c7 in QAction::triggered (this=0x8bdde0, _t1=false)
    at .moc/debug-shared/moc_qaction.cpp:216
#9  0x00002b03df8c3090 in QAction::activate (this=0xa728b0,
    event=<value optimized out>) at kernel/qaction.cpp:1129
#10 0x00002b03dfbf4104 in QAbstractButtonPrivate::click (this=0xba2550)
    at widgets/qabstractbutton.cpp:529
#11 0x00002b03dfbf4371 in QAbstractButton::mouseReleaseEvent (this=0xba2510,
    e=0x7fffd5edf430) at widgets/qabstractbutton.cpp:1116
#12 0x00002b03dfcc1d6a in QToolButton::mouseReleaseEvent (this=0x8bdde0,
    e=0x0) at widgets/qtoolbutton.cpp:675
#13 0x00002b03df91cb53 in QWidget::event (this=0xba2510, event=0x7fffd5edf430)
    at kernel/qwidget.cpp:6850
#14 0x00002b03dfbf2e30 in QAbstractButton::event (this=0xba2510, e=0x0)
    at widgets/qabstractbutton.cpp:1078
#15 0x00002b03dfcc1aa9 in QToolButton::event (this=0x8bdde0, e=0x0)
    at widgets/qtoolbutton.cpp:1105
#16 0x00002b03df8c8f6f in QApplicationPrivate::notify_helper (this=0x62f3e0,
    receiver=0xba2510, e=0x7fffd5edf430) at kernel/qapplication.cpp:3735
#17 0x00002b03df8cb915 in QApplication::notify (this=<value optimized out>,
    receiver=0xba2510, e=0x7fffd5edf430) at kernel/qapplication.cpp:3464
#18 0x00002b03d9e3229e in KApplication::notify (this=0x7fffd5edfed0,
    receiver=0xba2510, event=0x7fffd5edf430)
    at /var/tmp/paludis/kde-base/kdelibs-9999.4/work/kdelibs-9999.4/kdeui/kernel/kapplication.cpp:311
#19 0x00002b03d4f28338 in QCoreApplication::notifyInternal (this=)
    at kernel/qcoreapplication.cpp:586
Comment 1 Thomas McGuire 2008-04-03 19:10:59 UTC
Same backtrace as in bug 113730, but that one is claimed to be fixed, so I guess this one is a regression.
Comment 2 Thomas McGuire 2008-04-15 16:17:32 UTC
How can I reproduce the crash?

I tried it several times (also with the bogofilter "spam" button in the toolbar"), but it never crashes for me.

I tried this with maildir and IMAP.

Is this crash reliably reproducable by you? If so, what are the exact steps to make it crash?
Comment 3 Cristi 2008-04-15 16:44:09 UTC
Sorry I forgot to mark it resolved. You were wright it was a regression bug
Comment 4 Christophe Giboudeaux 2009-01-26 11:24:47 UTC
*** Bug 181846 has been marked as a duplicate of this bug. ***