Bug 181600 - Ctrl-A shortcut in location field selects web page content
Summary: Ctrl-A shortcut in location field selects web page content
Status: RESOLVED DUPLICATE of bug 181180
Alias: None
Product: konqueror
Classification: Applications
Component: khtml (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-22 15:47 UTC by Marcus Better
Modified: 2009-01-25 22:41 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcus Better 2009-01-22 15:47:56 UTC
Version:           4.1.96 (KDE 4.1.96 (KDE 4.2 RC1)) (using 4.1.96 (KDE 4.1.96 (KDE 4.2 RC1)), Debian packages)
Compiler:          cc
OS:                Linux (x86_64) release 2.6.28-melech

When the location field has keyboard focus, Ctrl+A used to select all the text in the field, allowing for easy replacement of the URL. This no longer works. Instead Ctrl+A selects the entire contents of the web page, just as if focus had remained in the content area.
Comment 1 Nadav Kavalerchik 2009-01-25 14:23:54 UTC
confirmed (same kde version and OS)
Comment 2 Frank Reininghaus 2009-01-25 22:13:18 UTC
Thanks for the bug report. I can confirm this in trunk rev. 916621. Most likely a duplicate of bug 181180. The issue is not reproducible in file management mode, so I suppose that the bug is in the KHTML part.
Comment 3 Frank Reininghaus 2009-01-25 22:41:29 UTC
I've verified that it really is a duplicate - it's caused by the same commit.

*** This bug has been marked as a duplicate of bug 181180 ***