Bug 180413 - reminders double each time at login
Summary: reminders double each time at login
Status: RESOLVED FIXED
Alias: None
Product: korgac
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-12 04:28 UTC by grashdur
Modified: 2012-12-05 23:21 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.10


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description grashdur 2009-01-12 04:28:06 UTC
Version:           4.1.0 (using KDE 4.1.3)
OS:                Linux
Installed from:    Ubuntu Packages

When a reminder pops up and I don't dismiss it, the next time I log in it shows TWO reminders of the same event. When I log in the time after that, it's four reminders of the same event -- then eight, then sixteen.....
Comment 1 Sergio Martins 2009-06-15 01:07:25 UTC
I can't reproduce with KDE-4.2.

Can you retest? If you can reproduce it, please attach the event.
Comment 2 grashdur 2009-07-31 03:39:15 UTC
Hi Sergio,

Sorry, I changed my email address and didn't receive notification of your message last month. This problem has been happening consistently, every time I log in, since the time I posted this bug in January. I'm not quite sure what to attach to show the problem. Would a window screenshot help? The reminder window just shows each event twice that wasn't dismissed during the previous session, and if copies are not dismissed it will keep doubling their quantity on each login.

My current software versions: 
Kontact 1.4.2
KDE 4.2.2
Linux 2.6.28-13-generic
Ubuntu Jaunty Jackalope (same problem was happening with previous installation, Intrepid Ibex)
Comment 3 Rainer Gassen 2010-01-07 19:23:33 UTC
I can confirm that this still happens w/ Kontact 4.3.2 running on Ubuntu 9.10 (Karmic Koala).

Each event shown in KOrganizers reminder module which is not acknowledged results in multiple entries of that same event after the next login. So if a reminder is listed once at the correct initial time and the option to move it for e.g. 10 min. is used but the computer is shut down before that time has run out the multiple entries show up.

It doesn't matter if the events where created via Kontact or Evolution.

Here's how a current korgacrc looks like:

###
[Alarms]
CalendarsLastChecked=2010,1,7,18,36,9

[General]
Autostart=true
Enabled=true
Position=200,303
Reminders=0

[Incidence-1]
RemindAt=2010,1,7,18,55,22
UID=20100107T141900Z-1872-1000-1-0@Avalon

[Incidence-2]
RemindAt=2010,1,7,18,38,20
UID=libkcal-324519786.189

[Incidence-3]
RemindAt=2010,1,7,18,55,22
UID=20100107T141900Z-1872-1000-1-0@Avalon

[Incidence-4]
RemindAt=2010,1,7,18,38,20
UID=libkcal-324519786.189
###

As you can see incidence 1 and 3 (entered via Evolution) show the exact same information as do incidence 2 and 4 (entered via Kontact).

Here are the relevant entries from the .ics file:

1 and 3:
###
BEGIN:VEVENT

DTSTAMP:20100107T173219Z

CREATED:20100107T142141Z

UID:20100107T141900Z-1872-1000-1-0@Avalon

SEQUENCE:2

LAST-MODIFIED:20100107T142141Z

SUMMARY:Testtermin geschr. in Evolution

DTSTART;TZID=Europe/Berlin:20100107T160000

DTEND;TZID=Europe/Berlin:20100107T163000

TRANSP:OPAQUE

BEGIN:VALARM

DESCRIPTION:Testtermin geschr. in Evolution

ACTION:DISPLAY

TRIGGER;VALUE=DURATION:-PT30M

X-EVOLUTION-ALARM-UID:20100107T142014Z-1948-1000-1-38@Avalon

END:VALARM

END:VEVENT
###

2 and 4:
###
BEGIN:VEVENT

DTSTAMP:20100107T173219Z

ORGANIZER;CN=Test:MAILTO:test@user.tld

ATTENDEE;CN=Test;RSVP=FALSE;PARTSTAT=ACCEPTED;ROLE=REQ-PARTICIPANT:

 mailto:test@user.tld

CREATED:20100107T173219Z

UID:libkcal-324519786.189

LAST-MODIFIED:20100107T173219Z

SUMMARY:Another reminder

DTSTART;TZID=Europe/Berlin:20100107T184500

DTEND;TZID=Europe/Berlin:20100107T204500

TRANSP:OPAQUE

BEGIN:VALARM

X-LIC-ERROR;X-LIC-ERRORTYPE=VALUE-PARSE-ERROR:No value for DESCRIPTION 

 property. Removing entire property:

ACTION:DISPLAY

TRIGGER;VALUE=DURATION:-PT10M

X-EVOLUTION-ALARM-UID:20100107T174451Z-1966-1000-1-0@Avalon

END:VALARM

END:VEVENT
###

I once renamed korgacrc to rule out an error in that file; as expected it was automatically recreated after the next boot but the problem still persists.

Any ideas?
Comment 4 Frank Roscher 2012-12-05 19:58:43 UTC
Git commit d1d99767eed455ee6f152ca9b7461f7a9a9acaa0 by Frank Roscher.
Committed on 05/12/2012 at 20:18.
Pushed by froscher into branch 'master'.

Fix saving and loading of suspended reminders in KOrganizer

We need to wait for all collections to be available when restoring
reminders at startup, or they won't get loaded properly. Additionally,
we must delete reminders one by one as they are dismissed instead of
just cleaning out the config file after each startup.
Related: bug 280321, bug 146336, bug 302865
FIXED-IN: 4.10
REVIEW: 107546

M  +2    -3    korganizer/korgac/alarmdialog.cpp
M  +50   -29   korganizer/korgac/koalarmclient.cpp
M  +2    -0    korganizer/korgac/koalarmclient.h

http://commits.kde.org/kdepim/d1d99767eed455ee6f152ca9b7461f7a9a9acaa0
Comment 5 Frank Roscher 2012-12-05 19:58:48 UTC
Git commit 98a09977726a1d293e2a5546217f81fc6648eceb by Frank Roscher.
Committed on 05/12/2012 at 20:36.
Pushed by froscher into branch 'master'.

Save KOrganizer reminders when they are first added to the alarm dialog

Previously, the list of already-triggered reminders only got saved to
the config file when the user actively dismissed or suspended one of
them. With this and the previous patches, saving and loading of
reminders should work correctly now.
Related: bug 146336
FIXED-IN: 4.10

M  +1    -0    korganizer/korgac/alarmdialog.cpp

http://commits.kde.org/kdepim/98a09977726a1d293e2a5546217f81fc6648eceb
Comment 6 grashdur 2012-12-05 23:21:09 UTC
Hi,



Would it be possible to remove me from this email list from your side?
I tried logging in to do so myself, but kde.org wouldn't let me log in,
nor recover my login information. I think my account must have expired
a few years ago.



Kind Regards,



Scott Ellsworth



--

<<<< Scott Ellsworth -- phone 415-621-6148 -- fax 415-663-4770 >>>>





----- Original message -----

From: Frank Roscher <[1]Frank-Roscher@gmx.net>

To: [2]scott@bestmail.us

Subject: [Bug 180413] reminders double each time at login

Date: Wed, 05 Dec 2012 19:58:48 +0000



[3]https://bugs.kde.org/show_bug.cgi?id=180413



Frank Roscher <[4]Frank-Roscher@gmx.net> changed:



          What    |Removed                     |Added

-----------------------------------------------------------------------
-----

            Status|UNCONFIRMED                 |RESOLVED

  Version Fixed In|                            |4.10

        Resolution|---                         |FIXED

      Latest Commit|

      |http://commits.kde.org/kdep

                  |

                  |im/98a09977726a1d293e2a5546

                  |                            |217f81fc6648eceb



--- Comment #4 from Frank Roscher <[5]Frank-Roscher@gmx.net> ---

Git commit d1d99767eed455ee6f152ca9b7461f7a9a9acaa0 by Frank Roscher.

Committed on 05/12/2012 at 20:18.

Pushed by froscher into branch 'master'.



Fix saving and loading of suspended reminders in KOrganizer



We need to wait for all collections to be available when restoring

reminders at startup, or they won't get loaded properly. Additionally,

we must delete reminders one by one as they are dismissed instead of

just cleaning out the config file after each startup.

Related: bug 280321, bug 146336, bug 302865

FIXED-IN: 4.10

REVIEW: 107546



M  +2    -3    korganizer/korgac/alarmdialog.cpp

M  +50   -29   korganizer/korgac/koalarmclient.cpp

M  +2    -0    korganizer/korgac/koalarmclient.h



[6]http://commits.kde.org/kdepim/d1d99767eed455ee6f152ca9b7461f7a9a9aca
a0



--- Comment #5 from Frank Roscher <[7]Frank-Roscher@gmx.net> ---

Git commit 98a09977726a1d293e2a5546217f81fc6648eceb by Frank Roscher.

Committed on 05/12/2012 at 20:36.

Pushed by froscher into branch 'master'.



Save KOrganizer reminders when they are first added to the alarm dialog



Previously, the list of already-triggered reminders only got saved to

the config file when the user actively dismissed or suspended one of

them. With this and the previous patches, saving and loading of

reminders should work correctly now.

Related: bug 146336

FIXED-IN: 4.10



M  +1    -0    korganizer/korgac/alarmdialog.cpp



[8]http://commits.kde.org/kdepim/98a09977726a1d293e2a5546217f81fc6648ec
eb



--

You are receiving this mail because:

You are on the CC list for the bug.

References

1. mailto:Frank-Roscher@gmx.net
2. mailto:scott@bestmail.us
3. https://bugs.kde.org/show_bug.cgi?id=180413
4. mailto:Frank-Roscher@gmx.net
5. mailto:Frank-Roscher@gmx.net
6. http://commits.kde.org/kdepim/d1d99767eed455ee6f152ca9b7461f7a9a9acaa0
7. mailto:Frank-Roscher@gmx.net
8. http://commits.kde.org/kdepim/98a09977726a1d293e2a5546217f81fc6648eceb