Bug 180208 - Entering full path to "Save File"/"Save as" only enters directory and does not save file.
Summary: Entering full path to "Save File"/"Save as" only enters directory and does no...
Status: RESOLVED FIXED
Alias: None
Product: kdelibs
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
: 183056 184896 190666 193343 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-01-10 03:45 UTC by Gavin Pryke
Modified: 2019-04-17 15:07 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Proposed patch (1.17 KB, patch)
2009-05-20 23:05 UTC, Dario Andres
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gavin Pryke 2009-01-10 03:45:05 UTC
Version:            (using Devel)
Compiler:          gcc-4.1.2 Gentoo
OS:                Linux
Installed from:    Compiled sources

kde svn revision 907972

When trying to save a file using an absolute path, for example /tmp/testfile in a kde file dialog, the file doesn't save, the file entry box is cleared and the location of the file view ends up at /tmp.

Trying to open a file in this way works as expected.

Tested with kwrite and kolourpaint.
Comment 1 Dario Andres 2009-01-10 03:49:30 UTC
Here using:

Qt: 4.4.3 + qt-copy-patches-889120
KDE: 4.2.60 (KDE 4.2.60 (KDE 4.3 >= 20090106))
kdelibs svn rev. 908156 / kdebase svn rev. 908156
on ArchLinux x86_64 - Kernel 2.6.27.10

I can confirm this bug.
Comment 2 Tommi Tervo 2009-02-19 08:54:02 UTC
*** Bug 183056 has been marked as a duplicate of this bug. ***
Comment 3 Daniel Hahler 2009-04-22 21:23:57 UTC
This appears to be a regression, as outlined in bug 183056.
Please also add "Save as" in the bug title, if possible (I have not found the bug until I tried filing a new one).
Comment 4 Dario Andres 2009-04-26 00:04:36 UTC
*** Bug 190666 has been marked as a duplicate of this bug. ***
Comment 5 Dario Andres 2009-05-20 19:58:24 UTC
*** Bug 184896 has been marked as a duplicate of this bug. ***
Comment 6 Dario Andres 2009-05-20 19:59:29 UTC
*** Bug 193343 has been marked as a duplicate of this bug. ***
Comment 7 Dario Andres 2009-05-20 23:05:19 UTC
Created attachment 33876 [details]
Proposed patch

The current code splits the absolute path, goes to the "folder" path and leave the "filename" part in the textline. However this is based on a KIO statjob result, and as if you enter a non-existant name (when creating a new file by saving it) it will fail, it wasn't accepting the file name properly.

This patch allows to check for the Saving mode and do the same even when the entered absolute path doesn't exist.
Comment 8 Dario Andres 2009-05-20 23:43:04 UTC
SVN commit 970821 by darioandres:

Backport to 4.2branch:

Allow the file dialog to save a file using the absolute path on the
location text edit. Review by dfaure

BUG: 180208


 M  +24 -9     kfilewidget.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=970821
Comment 9 Dario Andres 2009-05-20 23:45:40 UTC
Also fixed in 4.3trunk by http://websvn.kde.org/?view=rev&revision=970820