Bug 179932 - Pressing Ctrl+A while in-line editing a filename selects all files
Summary: Pressing Ctrl+A while in-line editing a filename selects all files
Status: RESOLVED WORKSFORME
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Compiled Sources Unspecified
: NOR normal (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-07 18:50 UTC by Georg Wittenburg
Modified: 2009-01-30 17:32 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Georg Wittenburg 2009-01-07 18:50:36 UTC
Version:            (using Devel)
Installed from:    Compiled sources

In Dolphin 4.1.86 (using unofficial Debian packages from kde42.debian.net at version 4:4.1.86+svn902162-0r1), pressing Ctrl+A while in-line editing a filename selects all files as opposed to selecting all characters in the filename.

This just _might_ be related to the QT issues pointed to in http://bugs.kde.org/show_bug.cgi?id=179806.
Comment 1 Dario Andres 2009-01-07 19:16:06 UTC
Here using:

Qt: 4.4.3 + qt-copy-patches-889120
KDE: 4.2.60 (KDE 4.2.60 (KDE 4.3 >= 20090106))
kdelibs svn rev. 907011 / kdebase svn rev. 907011
on ArchLinux x86_64 - Kernel 2.6.27.10

I can reproduce this.
Comment 2 Frank Reininghaus 2009-01-30 17:32:48 UTC
This works for me in current trunk (but 4.2.0 is indeed buggy). Probably fixed by David's fix for bug 181180. 

This should work fine in KDE 4.2.1 when it's out, please reopen the bug if I'm wrong. Thanks!