Bug 179340 - (wine) vex x86->IR: unhandled instruction bytes: 0x66 0x60 0x9C 0x58 (pusha)
Summary: (wine) vex x86->IR: unhandled instruction bytes: 0x66 0x60 0x9C 0x58 (pusha)
Status: RESOLVED DUPLICATE of bug 126245
Alias: None
Product: valgrind
Classification: Unclassified
Component: vex (show other bugs)
Version: 3.4 SVN
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Julian Seward
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-02 08:32 UTC by Jeff Zaroyko
Modified: 2010-11-11 20:08 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff Zaroyko 2009-01-02 08:32:12 UTC
Attempting to run valgrind --trace-children=yes ~/git/wine/wine winamp5541_full_emusic-7plus_en-us.exe

Produces "vex x86->IR: unhandled instruction bytes: 0x66 0x60 0x9C 0x58" after 20 seconds or so.

valgrind-3.4.0.RC1, Wine 1.1.11.
Comment 1 Jeff Zaroyko 2009-01-02 08:56:43 UTC
to reproduce:

1. wget http://download.nullsoft.com/winamp/client/winamp5541_full_emusic-7plus_en-us.exe
2. wine winamp5541_full_emusic-7plus_en-us.exe
3. Click through the installer, unchecking any addons that might be selected by default.
4. cd ~/.wine/drive_c/Program\ Files/Winamp
5. valgrind --trace-children=yes wine winamp.exe
Comment 2 Vince Weaver 2010-11-11 20:08:58 UTC

*** This bug has been marked as a duplicate of bug 126245 ***