Bug 126245 - vex x86->IR: unhandled instruction bytes: 0x66 0x60 0xB8 0x1
Summary: vex x86->IR: unhandled instruction bytes: 0x66 0x60 0xB8 0x1
Status: REPORTED
Alias: None
Product: valgrind
Classification: Unclassified
Component: vex (show other bugs)
Version: 3.2 SVN
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Julian Seward
URL:
Keywords:
: 179340 (view as bug list)
Depends on:
Blocks: 256630
  Show dependency treegraph
 
Reported: 2006-04-25 22:37 UTC by Thomas Kühne
Modified: 2016-04-09 11:43 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
PUSHAW/POPAW handling (4.19 KB, patch)
2011-01-08 21:43 UTC, Matteo Bruni
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Kühne 2006-04-25 22:37:55 UTC
43:   66 89 4d ec             mov    WORD PTR [ebp-20],cx
  47:   66 89 55 ee             mov    WORD PTR [ebp-18],dx
  4b:   66                      data16
  4c:   60                      pusha  
  4d:   b8 01 00 00 00          mov    eax,0x1
  52:   bb 02 00 00 00          mov    ebx,0x2

(http://dstress.kuehne.cn/run/a/asm_pusha_01.d)
Comment 1 Vince Weaver 2010-11-11 20:08:58 UTC
*** Bug 179340 has been marked as a duplicate of this bug. ***
Comment 2 Matteo Bruni 2011-01-08 21:43:16 UTC
Created attachment 55750 [details]
PUSHAW/POPAW handling

This issue also shows when trying to run Mass Effect 2 (demo or full version) through Wine.
I'm attaching a patch implementing the missing piece of code: it seems to let the program go on, but I'm not really sure of its correctness.
Comment 3 Austin English 2014-05-28 01:46:45 UTC
I don't see this in valgrind-3.9.0 and wine-1.7.19-70-gd6a59f7. Mass Effect 2 doesn't run under valgrind, however.

If I run MassEffect2.exe directly, wine fails to load umbra.dll (which is in the cwd). If I run MassEffect2Launcher.exe, the launcher displays and I can click play, but it fails shortly after with the same umbra.dll issue.