Bug 178691 - Won't put files from SMB into playlist
Summary: Won't put files from SMB into playlist
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.1.1
Platform: Ubuntu Packages Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
: 193855 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-12-24 20:55 UTC by David Gerard
Modified: 2010-01-12 20:49 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Gerard 2008-12-24 20:55:12 UTC
Version:           2.0-svn (using KDE 4.1.3)
OS:                Linux
Installed from:    Ubuntu Packages

I want to play tracks off an SMB share. It won't put them into the playlist, either drag'n'drop from Konqueror or going in through the Amarok->Play Media->Network->Samba Shares.

When I select and click the track, the file selector closes but nothing is added to the playlist. When I drag a file from an smb:// window in Konqueror, the same. I'm running amarok from the command line - the terminal in both cases shows:

amarok(22838) KFileItem::isDir: can't say -> false
Comment 1 David Gerard 2008-12-24 20:55:44 UTC
By the way, this is using 2.0 from today's svn.
Comment 2 Valerio Pilo 2009-04-08 01:14:45 UTC
I'm still getting the same behavior with 2.0.2 ran on KDE 4.2.68.

It won't load any file dropped or anyway loaded from a CIFS/SMB share which is opened in Dolphin via the "smb://" address or added to Places as "smb://hostname/sharename/".
The full file path when using KDE's Places or Dolphin is "smb://hostname/sharename/directory/file.mp3"

When I drop such a file on a running "amarok -d" instance reveals:
>>> Log >>>
amarok:  Drop from external source or file browser
amarok:  not a track no match
amarok: BEGIN: void Playlist::Controller::slotFinishDirectoryLoader(const Meta::TrackList&)
amarok: END__: void Playlist::Controller::slotFinishDirectoryLoader(const Meta::TrackList&) - Took 6.5e-05s
<<< Log <<<
And no file is added or played.

Adding (and of course, playing!) files works flawlessly when I mount the CIFS share and browse to it, then load files off it: the file will then have a "/media/share/directory/file.mp3" path. (but I can't do it anymore, because on network loss, the entire system blocks waiting for the stupid mount)

Apparent diagnosis: well Amarok seems unable to handle pseudo-URLs.
Steps to reproduce: Easy. You don't actually need a CIFS/Samba share. Just:
 1) add a Folder View Applet
 2) Open the Configuration for it
 3) Click on "Specify a folder" and set the "desktop:/" url.
 4) Put an .mp3 file on the Desktop and try to d&d it on Amarok.
It won't appear in the playlist nor be played.
Comment 3 Alexey Shildyakov 2009-06-25 14:11:05 UTC
*** Bug 193855 has been marked as a duplicate of this bug. ***
Comment 4 Myriam Schweingruber 2009-08-02 20:24:45 UTC
Any news on this? I can't test here
Comment 5 GGG 2009-08-07 06:27:01 UTC
I observe the same behaviour in Amarok 2.1.1 and KDE 4.3.0 - the URL are not handled.
Comment 6 Myriam Schweingruber 2009-08-07 11:40:08 UTC
Marked as confirmed then
Comment 7 Mark Kretschmann 2009-10-28 08:47:49 UTC
Fixed with commit c778f4f820ccb4260f99005086a1ccdc9dcc16e4
Comment 8 Hai Zaar 2010-01-12 19:19:06 UTC
Great! This fix helps indeed. However:
1. When I load smb://host/Music/1.mp3, in playlist it appears like "Stream (smb://....)". I do not see neither song name, nor artist, no any other meta data (although I can play a song).
2. Consequently, loading directories does not work as well - they also appear as a single "Stream (smb://....)" entry and obviously their contents are not played.

I'm using Amarok 2.2.1 from Kubuntu PPA.

Amarok 2.x is out for two years(!) already and SMB support never worked. While this is definitely a good step forward, its still lacks important features, especially with regards to not working directory load. In Amarok 1.x smb:// support was great.

What are the chances to fix issues 1 and 2?
Comment 9 Myriam Schweingruber 2010-01-12 20:49:07 UTC
Please do not comment on closed bugs.
The problem is not so much Amarok but Samba. We usually suggest people use NFS shares or an Ampache music server instead.