Bug 176049 - Gwenview wipes EXIF information when rotating JPEG images
Summary: Gwenview wipes EXIF information when rotating JPEG images
Status: RESOLVED UPSTREAM
Alias: None
Product: gwenview
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords:
: 179097 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-11-25 11:48 UTC by Hervé Fache
Modified: 2012-10-19 13:25 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hervé Fache 2008-11-25 11:48:20 UTC
Version:           2.1.3 (using KDE 4.1.3)
OS:                Linux
Installed from:    Ubuntu Packages

* start Gwenview
* open JPEG image with EXIF info
* rotate
* save
* close Gwenview

$ exif <image file>
Corrupt data (ExifLoader):
The data supplied does not seem to contain EXIF data.
Comment 1 Jesse L. Zamora 2008-11-26 00:12:05 UTC
I experimented with the latest Gwenview (4.2 SVN) and it saves all the exif metadata correctly! It seems that this bug was fixed in trunk, but can I have someone else double check as well?
Comment 2 Hervé Fache 2008-11-26 09:53:48 UTC
I shall install KDE 4.2 Beta 1 when it's out if it's not too difficult (I think someone plans on producing Kubuntu packages), then I'll double check all the bugs I reported against 4.1.3...
Comment 3 Hervé Fache 2008-12-25 21:12:41 UTC
Same issue with Kde 4.2 beta 2. Again this is an upgraded Kubuntu machine...
Comment 4 Hervé Fache 2009-01-04 18:10:02 UTC
The bug is in libexiv2 v0.17 that Kubuntu 8.10 uses. It is fixed in 0.17.1, which is in Kubuntu 9.04.

I am not changing the bug status, but surely it should be marked invalid?
Comment 5 Aurelien Gateau 2009-01-04 18:39:47 UTC
Good to hear. I close the bug as UPSTREAM, since the bug is in a library used by Gwenview.
Comment 6 Matt Blissett 2009-01-05 23:14:35 UTC
*** Bug 179097 has been marked as a duplicate of this bug. ***
Comment 7 Jonathan Thomas 2009-01-16 20:47:47 UTC
*** Bug 55777 has been marked as a duplicate of this bug. ***