Bug 173267 - JJ: Size of Covers on Ipod
Summary: JJ: Size of Covers on Ipod
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Collections/Local (show other bugs)
Version: 2.0-SVN
Platform: Compiled Sources Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords: junior-jobs
: 177100 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-10-22 01:32 UTC by Alejandro Wainzinger
Modified: 2009-12-09 11:29 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alejandro Wainzinger 2008-10-22 01:32:16 UTC
Version:            (using KDE 4.1.2)
Compiler:          g++ 
OS:                Linux
Installed from:    Compiled From Sources

Summary: Copying and reading covers from iPods are currently supported, but the sizes when sent and read are wrong, and so covers' quality is lowered when transferring tracks to iPod, and displayed far too large in collection browser when read from iPod.

Objective: Make covers copy to iPod in good quality, be displayed in collection browser in same size as covers from local collection.

Useful other knowledge: libgpod, gtkpixbuf
Comment 1 Dan Meltzer 2008-12-02 18:07:03 UTC
This is not going to happen for 2.0.  Retargetting to 2.1 as 2.0.1 is coming real soon after 2.0 and this is more than a bug fix.
Comment 2 Myriam Schweingruber 2008-12-08 09:55:49 UTC
*** Bug 177100 has been marked as a duplicate of this bug. ***
Comment 3 Alejandro Wainzinger 2008-12-16 19:20:36 UTC
SVN commit 897738 by awainzinger:

Disable copying of cover art until it's handled properly.
CCBUG:173267


 M  +5 -0      IpodHandler.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=897738
Comment 4 Jochen Bauer 2008-12-16 23:51:58 UTC
xevix:

I would feel better if the covers were shown as before. For me, it's much easier to find an album even if the picture has no good quality, at least it can be recognized. 

Greets

Comment 5 Alejandro Wainzinger 2009-01-24 21:54:41 UTC
SVN commit 916217 by awainzinger:

Fix displaying of covers from Ipod.  All that's left now is to make sure they copy at a reasonable size to maintain quality on both Ipod and Amarok equivalent.
CCBUG:173267


 M  +1 -1      IpodMeta.cpp  
 M  +3 -3      handler/IpodHandler.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=916217
Comment 6 Jochen Bauer 2009-02-10 09:29:25 UTC
Hey xevix, did you notice yet, that displaying still doesnt work? BTW is the Code of 1.4 so very different from the one of 2.0? If not, why dont you make your life easier by taking some parts of 1.4s code instead to write it completely new? Or are the 2 Apps to different to do sth like this?

Greets
Comment 7 Jochen Bauer 2009-11-23 00:18:59 UTC
I close that bug. It doesnt seem to be an issue anymore. My covers are shown correctly for months. If it is still valid for anyone, reopen please.
Comment 8 Jochen Bauer 2009-11-23 00:20:42 UTC
OK, i am not able to close it. Could anyone please handle this?
Comment 9 Lydia Pintscher 2009-11-23 00:23:13 UTC
Thanks for the update :)