Bug 173236 - allow custom trigger char(s) for calculator runner
Summary: allow custom trigger char(s) for calculator runner
Status: RESOLVED FIXED
Alias: None
Product: krunner
Classification: Plasma
Component: calculator (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist with 140 votes (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 200571 207897 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-10-21 15:37 UTC by Dan
Modified: 2013-12-31 03:31 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.11


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dan 2008-10-21 15:37:25 UTC
Version:            (using KDE 4.1.2)
Compiler:          gcc 4.3.2 
OS:                Linux
Installed from:    Compiled From Sources

When entering a simple formula like 4+5 in the Alt-F2 run command dialog nothing happens. You have to enter "=4+5" to see a result.

It would be nice if the behaviour of KDE 3 could be restored.
Comment 1 Aaron J. Seigo 2008-10-21 20:07:01 UTC
"=4+5" or "4+5=" ...

in any case, since we do as-you-type matching and support a huge number of plugins already in a limited thread pool but need to maintain responsiveness, it will stay as it is.

what we could do is allow you set a custom "trigger" word, and let you set it to "" which would cause it to evaluate at every keystroke.
Comment 2 FiNeX 2008-10-22 23:53:45 UTC
And why not evaluate the expression after pressing "enter" key?
Comment 3 Florent Guiliani 2008-11-08 11:11:39 UTC
Calculator could be triggered automatically as we type an operator sign (+, -, /, *).
Comment 4 Aaron J. Seigo 2008-11-08 21:39:53 UTC
@FiNeX: because that's not how the krunner user interaction works at all, making it an odd inconsistency. how is <enter> any better than =?

@Florent: making it trigger when you type in paths or any number of other things.

Comment 5 FiNeX 2008-11-08 22:57:00 UTC
@Aaron: because in my keyboard layout (it) the "=" char is done pressing two keys (SHIFT+0), so pressing enter is simply more quick. Anyway it was only a curiosity :-)
Comment 6 Marcelo Vivan Borro 2008-11-19 13:33:47 UTC
It's far more intuitive to press enter to obtain a result.  And it was the default behavior of previous versions.   It took me several months to discover that the new krunner also had a calc.  I only discovered it when I was searching for a bug entry here :)
Comment 7 Aaron J. Seigo 2008-11-19 17:31:26 UTC
@Marcelo: most kde3 users never knew the old dialog had a calculator; pressing enter puts the last results in the text edit box ready for further calculation, so it already has a purpose; and enter is "run this command" in krunner not "execute the results"
Comment 8 esigra 2009-03-05 20:40:29 UTC
I use KDE3 and often do quick calculations with Alt+F2. I really like that it can be done with as few keystrokes as possible. I would like it to work just as nice when I upgrade to KDE4. If I have to add the '='-sign it means that I have to press 2 extra keys (SHIFT+0) and I have to change my habit. Someone with permission, pleas make this block bug #186184 (I can not).
Comment 9 Patrick Stählin 2009-03-09 10:25:06 UTC
*** This bug has been confirmed by popular vote. ***
Comment 10 FiNeX 2009-07-18 00:24:23 UTC
*** Bug 200571 has been marked as a duplicate of this bug. ***
Comment 11 FiNeX 2009-09-20 15:40:09 UTC
*** Bug 207897 has been marked as a duplicate of this bug. ***
Comment 12 Artem S. Tashkinov 2009-09-20 16:58:28 UTC
I wholeheartedly support this feature request.

Entering Shift+'+' is absolutely inconvenient.

Working with the result of a calculation is impossible without using a mouse (and selecting the result).

Almost all KDE3 users who I know do use KRunner calculator and prefer the old behaviour.
Comment 13 Hans Chen 2012-02-23 21:18:32 UTC
How about adding a delay before the calculation is executed, say, half a second after the last keypress. That would delay the answer with half a second, but on the other hand the user doesn't have to type '=', and a new calculation is made at most every half second.

(The time here is just an example.)
Comment 14 Hans Chen 2012-02-23 21:22:00 UTC
I should also mention that I'm willing to give it a try (when I can find the time..) if people think it's an ok solution.
Comment 15 esigra 2012-02-24 06:10:12 UTC
Thank you Hans, I am looking forward to it!
Comment 16 Dennis Schridde 2013-01-15 14:46:04 UTC
Please also have a look at bug #313301, where I suggest generic trigger-word / prefix support for KRunner.
Comment 17 Christoph Feck 2013-12-31 03:31:00 UTC
Since KDE 4.11, you can omit the '=' sign, if you do not have letters (such as 'sin', 'log', etc.) in the expression, so I consider this fixed.