Bug 173067 - Selecting feed with no feed viewer tab crashes Akregator (or, said tab is closable)
Summary: Selecting feed with no feed viewer tab crashes Akregator (or, said tab is clo...
Status: RESOLVED FIXED
Alias: None
Product: akregator
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 161269 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-10-17 22:42 UTC by sheeettin
Modified: 2012-07-10 14:01 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Crash backtrace (3.09 KB, text/plain)
2008-10-17 22:44 UTC, sheeettin
Details
Disable close button on Article tab (489 bytes, patch)
2012-07-10 10:34 UTC, Lê Hoàng Phương
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sheeettin 2008-10-17 22:42:57 UTC
Version:           1.3.1 (using 4.1.2 (KDE 4.1.2), Kubuntu packages)
Compiler:          cc
OS:                Linux (i686) release 2.6.27-7-generic

If one opens another tab (e.g. via the "complete story" link), the "feed viewer" tab shows up and has a "close tab" button. If one clicks this button and proceeds to select a feed in the left pane, Akregator immediately crashes.

I'm not sure if the bug is that Akregator crashes, or that the "feed viewer" tab can be closed. :P
Comment 1 sheeettin 2008-10-17 22:44:30 UTC
Created attachment 27983 [details]
Crash backtrace

Backtrace, if necessary.
Comment 2 Frank Osterfeld 2008-10-19 18:03:28 UTC
Confirmed. This happens when the hover option is checked.
Comment 3 Frank Osterfeld 2008-10-19 18:16:51 UTC
SVN commit 873515 by osterfeld:

Don't allow the hover close button to close the main tab, which crashes
Would be better if we could remove the button alltogether for this tab
BUG:173067


 M  +2 -1      framemanager.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=873515
Comment 4 Frank Osterfeld 2008-10-19 18:17:58 UTC
SVN commit 873516 by osterfeld:

backport 173067: don't allow the user to close the main tab
CCBUG:173067


 M  +2 -1      framemanager.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=873516
Comment 5 Frank Osterfeld 2008-10-27 22:33:31 UTC
*** Bug 161269 has been marked as a duplicate of this bug. ***
Comment 6 Lê Hoàng Phương 2012-07-10 10:34:26 UTC
Created attachment 72425 [details]
Disable close button on Article tab

I want to propose a patch to disable the close button on the main tab. This will make akregator to not confuse user with this do-nothing close button.
Comment 7 Lê Hoàng Phương 2012-07-10 14:01:22 UTC
FYI: I have sent that patch to kde review board.