Bug 171085 - wasted space when buttons or things like that are involved
Summary: wasted space when buttons or things like that are involved
Status: RESOLVED DUPLICATE of bug 180852
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Unspecified
: NOR normal (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-09-15 02:46 UTC by Roland Leißa
Modified: 2009-01-31 05:59 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
tab bar wasted space problem (24.76 KB, image/jpeg)
2008-09-15 16:52 UTC, Roland Leißa
Details
konqueror with patch from bug 180852 (13.56 KB, image/jpeg)
2009-01-23 05:30 UTC, Roland Leißa
Details
improved gaps between menubars/toolbars, toolbars/toolbars and toolbars/UI (2.09 KB, patch)
2009-01-30 06:01 UTC, Roland Leißa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roland Leißa 2008-09-15 02:46:04 UTC
Version:            (using KDE 4.1.1)
Installed from:    Gentoo Packages

There are some places where space is wasted:

1. A tab bar with buttons on the side (like in kopete or konqueror, for closing or opening a new tab) wastes space. The tab bar could be closer to the tool bar/main menu. Have a look at Kate's tab bar. There isn't wasted space (though there are buttons...)

2. Because of the "K" in the upper right of konqueror I assume there is much more room between the main menu and the tool bar then necessary. 

Would be nice, if this gets fixed.

P.S.: If this entry looks fragmented somehow, it is messed up by konquereor. Is this a website or a konqueror bug?
Comment 1 Pino Toscano 2008-09-15 10:35:25 UTC
> 1. A tab bar with buttons on the side (like in kopete or konqueror, for closing
> or opening a new tab) wastes space. The tab bar could be closer to the tool
> bar/main menu. Have a look at Kate's tab bar. There isn't wasted space (though
> there are buttons...)

Screenshot, please.

> 2. Because of the "K" in the upper right of konqueror I assume there is much
> more room between the main menu and the tool bar then necessary.

This is bug #166593.
Comment 2 Roland Leißa 2008-09-15 16:52:15 UTC
Created attachment 27428 [details]
tab bar wasted space problem
Comment 3 Roland Leißa 2008-09-15 17:04:09 UTC
In the screenshot you can see Kopete, ksysguard and kate. The last two don't have the wasted space problem. Kopete and Konqueror have the same problem. I didn't include konqueror in the screenshot because the comparison would be unfair because of bug #166593
Comment 4 Roland Leißa 2009-01-23 05:30:34 UTC
Created attachment 30520 [details]
konqueror with patch from bug 180852

Today I played a bit with oxygen's code. Have a look at Bug #180852. The attachment shows, how konqui looks now for me. IMHO only the icon has to be made slightly smaller.
Comment 5 Roland Leißa 2009-01-30 06:01:19 UTC
Created attachment 30736 [details]
improved gaps between menubars/toolbars, toolbars/toolbars and toolbars/UI

Ok, fixed the issue with text under icons.

In the attachment is a patch, which makes some gaps a bit smaller. I really like this version. One thing that still annoys me is the gap which is caused by LineEdits in ToolBars. You can see that the bottom gap is larger than the top one if you drag systemsetting's toolbar away or Konqueror's location bar.
Comment 6 Roland Leißa 2009-01-31 05:59:58 UTC

*** This bug has been marked as a duplicate of bug 180852 ***