Bug 171070 - application crash upon closing
Summary: application crash upon closing
Status: RESOLVED DUPLICATE of bug 151453
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-09-14 19:33 UTC by Jeremy Cribb
Modified: 2008-10-05 19:57 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Cribb 2008-09-14 19:33:48 UTC
Version:            (using KDE 4.1.1)
OS:                Linux
Installed from:    Ubuntu Packages

if i'm not doing this right, PLEASE, someone point me in the right direction.  I'm in the middle of finishing dissertation and don't have time to research how to participate in reporting/handling bugs/crashes.  I DO WANT TO PARTICIPATE HOWEVER, so if there's a COMPREHENSIVE manual/howto somewhere on how to do this more effectively, PLEASE let me know via "jcribb <AT> email <dot> unc <dot> edu"..... 

Specifically, Konqueror seems to give me this crash report every time I close the app using the title bar's "X" The Konqueror backtrace follows:

Application: Konqueror (konqueror), signal SIGABRT
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0x7fc03f0fd7a0 (LWP 7468)]
[New Thread 0x416b6950 (LWP 3187)]
[KCrash handler]
#5  0x00007fc03e8f5095 in raise () from /lib/libc.so.6
#6  0x00007fc03e8f6af0 in abort () from /lib/libc.so.6
#7  0x00007fc03e8ee2df in __assert_fail () from /lib/libc.so.6
#8  0x00007fc02f719159 in KHTMLGlobal::finalCheck ()
    at /build/buildd/kde4libs-4.1.1+really4.1.1/khtml/khtml_global.cpp:247
#9  0x00007fc02fcf065a in ~KHTMLFactory (this=0xc7dba0)
    at /build/buildd/kde4libs-4.1.1+really4.1.1/khtml/khtml_factory.cpp:35
#10 0x00007fc03d533051 in qDeleteAll<QHash<QString, QPointer<KPluginFactory> >::const_iterator> (begin=<value optimized out>, end=<value optimized out>)
    at /usr/include/qt4/QtCore/qalgorithms.h:352
#11 0x00007fc03d5333d9 in ~FactoryHash (this=0x1d2c)
    at /build/buildd/kde4libs-4.1.1+really4.1.1/kdecore/util/klibrary.cpp:93
#12 0x00007fc03d532302 in destroy ()
    at /build/buildd/kde4libs-4.1.1+really4.1.1/kdecore/util/klibrary.cpp:97
#13 0x00007fc03e8f8110 in exit () from /lib/libc.so.6
#14 0x00007fc03e8e11cb in __libc_start_main () from /lib/libc.so.6
#15 0x0000000000400649 in _start ()
#0  0x00007fc03e960b81 in nanosleep () from /lib/libc.so.6
Comment 1 Frank Reininghaus 2008-09-15 21:21:18 UTC
Jeremy, thanks for the bug report and for your interest in bug reporting and bug handling! Help is always appreciated :-)

A nice guide how to write bug reports can be found at
http://www.chiark.greenend.org.uk/~sgtatham/bugs.html

If you want to get involved in bug handling for KDE, the Bugsqaud is an excellent starting point:
http://techbase.kde.org/Contribute/Bugsquad
A good way to get starting is to take part in one of the bug days, but you are always welcome to browse through the bug database and see if you can add useful information to any report.

About the crash you reported: There are bugs with similar backtraces (like bug 164126), but one cannot be sure if it's a duplicate before it can be reproduced by us (in this case, maybe only the developers can tell). It would be helpful if you could provide step-by-step instructions to crash Konqueror (e.g., go to some URL, do something, close Konqueror, crash) if the bug is reproducible for you. Thanks!

Comment 2 Maksim Orlovich 2008-10-05 19:57:06 UTC

*** This bug has been marked as a duplicate of bug 151453 ***