Bug 164126 - Konqueror crash when closing (backtrace)
Summary: Konqueror crash when closing (backtrace)
Status: RESOLVED WORKSFORME
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-15 11:38 UTC by Beat Wolf
Modified: 2009-08-31 14:23 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Beat Wolf 2008-06-15 11:38:04 UTC
Version:            (using Devel)
Installed from:    Compiled sources
OS:                Linux

Just closed konqoror after visiting maps.search.ch and he crashed. Here is the backtrace:

Application: Konqueror (konqueror), signal SIGABRT
[Thread debugging using libthread_db enabled]
[New Thread 0xb5f62720 (LWP 4555)]
[KCrash handler]
#6  0xb7ef2410 in __kernel_vsyscall ()
#7  0xb62bc085 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0xb62bda01 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0xb62b510e in __assert_fail () from /lib/tls/i686/cmov/libc.so.6
#10 0xb4268cd0 in KHTMLGlobal::finalCheck ()
    at /home/kde-devel/kde/src/kdelibs/khtml/khtml_global.cpp:247
#11 0xb4707471 in ~KHTMLFactory (this=0x82110a8)
    at /home/kde-devel/kde/src/kdelibs/khtml/khtml_factory.cpp:35
#12 0xb70a472f in QObjectCleanupHandler::clear (this=0x820a4e8)
    at kernel/qobjectcleanuphandler.cpp:142
#13 0xb70a47a0 in ~QObjectCleanupHandler (this=0x820a4e8)
    at kernel/qobjectcleanuphandler.cpp:88
#14 0xb7b242a8 in destroy ()
    at /home/kde-devel/kde/src/kdelibs/kdecore/util/kpluginfactory.cpp:29
#15 0xb7a010b9 in ~KCleanUpGlobalStatic (this=0xb7b61894)
    at /home/kde-devel/kde/src/kdelibs/kdecore/kernel/kglobal.h:67
#16 0xb7b24220 in __tcf_0 ()
    at /home/kde-devel/kde/src/kdelibs/kdecore/util/kpluginfactory.cpp:29
#17 0xb62bf084 in exit () from /lib/tls/i686/cmov/libc.so.6
#18 0xb62a7458 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#19 0x08048711 in _start ()
#0  0xb7ef2410 in __kernel_vsyscall ()
Comment 1 A. Spehr 2008-06-16 04:36:46 UTC
I'm dupping this, but actually, I couldn't reproduce it, so maybe it's finally fixed? Will have to try on some of the other sites.

*** This bug has been marked as a duplicate of 156172 ***
Comment 2 Maksim Orlovich 2008-08-01 19:19:15 UTC
Different underlying cause than most others, so undup'ing
Comment 3 Rui G. 2008-09-07 19:52:16 UTC
I tried to reproduce it and got a different backtrace. To reproduce all i did was start konqueror in konsole : konqueror maps.search.ch , and zoomed in and out a little, then closed it.

Application: Konqueror (konqueror), signal SIGABRT
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb60aa940 (LWP 5618)]
[KCrash handler]
#6  0xb7f80402 in __kernel_vsyscall ()
#7  0xb7d74085 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0xb7d75a01 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0xb7d6d10e in __assert_fail () from /lib/tls/i686/cmov/libc.so.6
#10 0xb2a80032 in KHTMLGlobal::finalCheck ()
    at /build/buildd/kde4libs-4.1.1+really4.1.1/khtml/khtml_global.cpp:247
#11 0xb2e951fc in ~KHTMLFactory (this=0x8356800)
    at /build/buildd/kde4libs-4.1.1+really4.1.1/khtml/khtml_factory.cpp:35
#12 0xb7746cc1 in qDeleteAll<QHash<QString, QPointer<KPluginFactory> >::const_iterator> (begin={i = 0x8354ae8}, end={i = 0x834e158})
    at /usr/include/qt4/QtCore/qalgorithms.h:352
#13 0xb7746d38 in qDeleteAll<FactoryHash> (c=@0x8354608)
    at /usr/include/qt4/QtCore/qalgorithms.h:360
#14 0xb77470e2 in ~FactoryHash (this=0x8354608)
    at /build/buildd/kde4libs-4.1.1+really4.1.1/kdecore/util/klibrary.cpp:93
#15 0xb7745c0d in destroy ()
    at /build/buildd/kde4libs-4.1.1+really4.1.1/kdecore/util/klibrary.cpp:97
#16 0xb7637d0b in ~KCleanUpGlobalStatic (this=0xb777f8f0)
    at /build/buildd/kde4libs-4.1.1+really4.1.1/kdecore/kernel/kglobal.h:67
#17 0xb7d77084 in exit () from /lib/tls/i686/cmov/libc.so.6
#18 0xb7d5f458 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#19 0x080484f1 in _start ()
#0  0xb7f80402 in __kernel_vsyscall ()
Comment 4 FiNeX 2009-08-31 14:10:26 UTC
Please, would you like to check the bug using a more recent KDE version like 4.3 or trunk?

Many thanks.
Comment 5 FiNeX 2009-08-31 14:10:51 UTC
Please, would you like to check the bug using a more recent KDE version like 4.3 or trunk?

Many thanks.
Comment 6 Beat Wolf 2009-08-31 14:23:58 UTC
I think it's fixed, i couldn't reproduce this crash with 4.3