Bug 170395 - Konqueror crashed when closing the application
Summary: Konqueror crashed when closing the application
Status: RESOLVED DUPLICATE of bug 151453
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-09-04 17:21 UTC by Joonas Koivunen
Modified: 2008-10-05 19:56 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
KCrash backtrace (1.39 KB, text/plain)
2008-09-04 17:23 UTC, Joonas Koivunen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joonas Koivunen 2008-09-04 17:21:51 UTC
Version:           4.1.1 (KDE 4.1.1) (using 4.1.1 (KDE 4.1.1), Kubuntu packages)
Compiler:          gcc
OS:                Linux (i686) release 2.6.24-19-generic

I just had about 10 tabs open, nothing special but I might had had a nspluginviewer showing flash on some tabs; not sure.

I just browsed for some time, maybe 30 minutes and closed konq from the x -button in the window.

I'll attach the backtrace.
Comment 1 Joonas Koivunen 2008-09-04 17:23:55 UTC
Created attachment 27239 [details]
KCrash backtrace

It seems that this could be related to khtml and not to konqueror.

Not 100% reproducable nor do I remember what url's I had open..
Comment 2 Frank Reininghaus 2008-09-04 18:02:16 UTC
Thanks for the bug report. Please do not attach backtraces, but paste them in the text (makes it easier for us to look for duplicates). I'm pasting the backtrace below. If you find a way to reproduce the crash, please post the URL of the problematic page here. There are a few bugs with similar backtraces (e.g., bug 147247, bug 164126), this might be a duplicate.


Application: Konqueror (konqueror), signal SIGABRT
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb60a1940 (LWP 6712)]
[KCrash handler]
#6  0xb7f81410 in __kernel_vsyscall ()
#7  0xb7d6b085 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0xb7d6ca01 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0xb7d6410e in __assert_fail () from /lib/tls/i686/cmov/libc.so.6
#10 0xb429e032 in KHTMLGlobal::finalCheck ()
    at /build/buildd/kde4libs-4.1.1+really4.1.1/khtml/khtml_global.cpp:247
#11 0xb467d1fc in ~KHTMLFactory (this=0x847d868)
    at /build/buildd/kde4libs-4.1.1+really4.1.1/khtml/khtml_factory.cpp:35
#12 0xb74c7e4f in QObjectCleanupHandler::clear (this=0x849f580)
    at kernel/qobjectcleanuphandler.cpp:142
#13 0xb74c7ec0 in ~QObjectCleanupHandler (this=0x849f580)
    at kernel/qobjectcleanuphandler.cpp:88
#14 0xb774095d in destroy ()
    at /build/buildd/kde4libs-4.1.1+really4.1.1/kdecore/util/kpluginfactory.cpp:29
#15 0xb762ed0b in ~KCleanUpGlobalStatic (this=0xb77768f4)
    at /build/buildd/kde4libs-4.1.1+really4.1.1/kdecore/kernel/kglobal.h:67
#16 0xb7d6e084 in exit () from /lib/tls/i686/cmov/libc.so.6
#17 0xb7d56458 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#18 0x080484f1 in _start ()
#0  0xb7f81410 in __kernel_vsyscall ()
Comment 3 Maksim Orlovich 2008-10-05 19:56:52 UTC

*** This bug has been marked as a duplicate of bug 151453 ***