Bug 170207 - JJ: Amarok 2 can't playback .asx playlist
Summary: JJ: Amarok 2 can't playback .asx playlist
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Playlists/Saved Playlists (show other bugs)
Version: 2.4-GIT
Platform: Compiled Sources macOS
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
: 283225 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-09-01 18:23 UTC by illogic-al
Modified: 2013-05-27 09:59 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.8


Attachments
mediaplayer (95 bytes, patch)
2010-10-31 18:39 UTC, louisfinan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description illogic-al 2008-09-01 18:23:08 UTC
Version:            (using KDE 4.1.1)
Compiler:          gcc version 4.2.1 (Apple Inc. build 5564) 
Installed from:    Compiled From Sources

OS X's phonon-qt engine has the ability to play .asx playlists. Whenever adding the http:// url of an asx playlist to the amarok playlist nothing gets added to the playlist.
Comment 1 illogic-al 2008-09-01 18:24:24 UTC
Tell me what I need to do to debug. Already tried downloading the file to disk and playing back in the phonon test app, which works. 
Comment 2 Mark Kretschmann 2008-09-01 20:19:26 UTC
As far as I remember Amarok has its own ASX playlist reader. I suppose it might be broken.
Comment 3 illogic-al 2008-09-01 23:38:03 UTC
http://www.thepath.fm/cyberradio/media/cdrlive.asx
test playlist
Comment 4 Olivier Delaune 2009-01-25 01:20:21 UTC
Problem exists also on Mandriva Linux with Amarok 2.0.1.1. I cannot read asx webradio.
Comment 5 Dan Meltzer 2009-01-26 17:43:37 UTC
We don't seem to have an asf playlist class at all any more... I know it existed at some point in 2.0 development, I have a feeling it got itself deleted in one of the zillion playlist managing code rewrites that we have gone through.
Comment 6 Myriam Schweingruber 2009-08-02 17:03:57 UTC
Any news on this?
Comment 7 Bart Cerneels 2009-08-30 17:43:10 UTC
Nope, we don't have ASF/ASX playlist support ATM. It requires a port of the 1.4 code to a new AsxPlaylist class.
Patches are welcome.
Comment 8 NForce 2010-03-16 16:43:44 UTC
In Amarok 2.2 asx playlists worked just fine. In 2.3 it's broken, I can't add asx streams to the playlist. Is it because asx is evil?
Comment 9 Myriam Schweingruber 2010-03-16 17:44:40 UTC
(In reply to comment #8)
> In Amarok 2.2 asx playlists worked just fine. In 2.3 it's broken, I can't add
> asx streams to the playlist. Is it because asx is evil?

No, this looks more like a regression.

*** This bug has been marked as a duplicate of bug 212445 ***
Comment 10 Myriam Schweingruber 2010-03-16 17:51:20 UTC
Oops, wrong duplicate, sorry, I just can't put the finger on the other one I had today, sorry for the noise
Comment 11 usr 2010-06-07 11:22:32 UTC
The problem persist at Amarok 2.3.1.
Comment 12 Timo Tambet 2010-08-18 13:11:12 UTC
Same problem, Amarok 2.3.1, KDE 4.5 and Linux.
Comment 13 louisfinan 2010-10-31 18:39:57 UTC
Created attachment 53020 [details]
mediaplayer

test pacth
Comment 14 Myriam Schweingruber 2010-10-31 22:08:09 UTC
Louis, please submit the patch to http://git.reviewboard.kde.org (you need to subscribe to http://identity.kde.org before that).
Comment 15 usr 2011-01-16 23:20:28 UTC
What about Amarok 2.4?
Comment 16 Myriam Schweingruber 2011-01-17 07:43:14 UTC
Louis, any news about that patch?
Comment 17 Bart Cerneels 2011-01-17 08:05:41 UTC
(In reply to comment #13)
> Created an attachment (id=53020) [details]
> mediaplayer
> 
> test pacth

This is not a patch but an ASX file. Just had it open with VLC while expecting a diff.

Patches adding ASX support are still welcome.
Making this a Junior Job. Difficulty: medium, C++ code skills required.
Comment 18 usr 2011-01-27 02:34:12 UTC
The same for Amarok 2.4, it can't play ASX files.
Comment 19 usr 2011-04-28 16:59:35 UTC
More than two years later the bug still here, and with "new" status?

Amarok, rediscover music with its exciting features:
Now you can't play audio!
Comment 20 Myriam Schweingruber 2011-04-28 23:54:20 UTC
NEW means it is confirmed, else it would be UNCONFIRMED. It also is marked as a Junior Job, so any helpers with Qt/C++ skills are welcome.
Comment 21 Matěj Laitl 2013-02-19 12:18:05 UTC
Tatjana Gornak is working on this, starting with a cleanup-existing-playlistfiles patch in https://git.reviewboard.kde.org/r/107473/
Comment 22 Matěj Laitl 2013-04-13 12:50:28 UTC
Git commit c91a2017116789ecb5c63c7e850cb69cfeb6b6f1 by Matěj Laitl, on behalf of Tatjana Gornak.
Committed on 05/04/2013 at 02:41.
Pushed by laitl into branch 'master'.

Asx playlist implementation

FEATURES:
 * Added support for .asx playlists; patch by Tatjana Gornak
FIXED-IN: 2.8
REVIEW: 109758
DIGEST: Amarok can now read & save .asx playlists

M  +1    -0    ChangeLog
M  +1    -0    src/CMakeLists.txt
M  +2    -0    src/MainWindow.cpp
M  +2    -0    src/core-impl/playlists/providers/user/UserPlaylistProvider.cpp
M  +7    -0    src/core-impl/playlists/types/file/PlaylistFileSupport.cpp
A  +191  -0    src/core-impl/playlists/types/file/asx/ASXPlaylist.cpp     [License: GPL (v2+)]
A  +48   -0    src/core-impl/playlists/types/file/asx/ASXPlaylist.h     [License: GPL (v2+)]
M  +1    -1    src/core/playlists/PlaylistFormat.cpp
M  +5    -1    src/playlistmanager/file/PlaylistFileProvider.cpp
M  +6    -0    tests/core-impl/playlists/types/file/CMakeLists.txt
A  +159  -0    tests/core-impl/playlists/types/file/asx/TestASXPlaylist.cpp     [License: GPL (v2+)]
A  +51   -0    tests/core-impl/playlists/types/file/asx/TestASXPlaylist.h     [License: GPL (v2+)]

http://commits.kde.org/amarok/c91a2017116789ecb5c63c7e850cb69cfeb6b6f1
Comment 23 Matěj Laitl 2013-04-13 12:59:51 UTC
(In reply to comment #22)
> Git commit c91a2017116789ecb5c63c7e850cb69cfeb6b6f1 by Matěj Laitl, on
> behalf of Tatjana Gornak.
> Committed on 05/04/2013 at 02:41.
> Pushed by laitl into branch 'master'.

No, not yet, this was pushed by error. The commit hooks fired, but the commits haven't reached Amarok master.
Comment 24 Matěj Laitl 2013-04-15 21:27:11 UTC
Git commit e1eddb4a00b0d5bece5b9ddddeb59e95b460c762 by Matěj Laitl, on behalf of Tatjana Gornak.
Committed on 05/04/2013 at 02:41.
Pushed by laitl into branch 'master'.

Asx playlist implementation

FEATURES:
 * Added support for .asx playlists; patch by Tatjana Gornak
FIXED-IN: 2.8
REVIEW: 109758
DIGEST: Amarok can now read & save .asx playlists

M  +1    -0    ChangeLog
M  +1    -0    src/CMakeLists.txt
M  +2    -0    src/MainWindow.cpp
M  +2    -0    src/core-impl/playlists/providers/user/UserPlaylistProvider.cpp
M  +9    -1    src/core-impl/playlists/types/file/PlaylistFile.cpp
M  +7    -0    src/core-impl/playlists/types/file/PlaylistFileSupport.cpp
A  +192  -0    src/core-impl/playlists/types/file/asx/ASXPlaylist.cpp     [License: GPL (v2+)]
A  +47   -0    src/core-impl/playlists/types/file/asx/ASXPlaylist.h     [License: GPL (v2+)]
M  +1    -1    src/core/playlists/PlaylistFormat.cpp
M  +5    -1    src/playlistmanager/file/PlaylistFileProvider.cpp
M  +6    -0    tests/core-impl/playlists/types/file/CMakeLists.txt
A  +159  -0    tests/core-impl/playlists/types/file/asx/TestASXPlaylist.cpp     [License: GPL (v2+)]
A  +51   -0    tests/core-impl/playlists/types/file/asx/TestASXPlaylist.h     [License: GPL (v2+)]

http://commits.kde.org/amarok/e1eddb4a00b0d5bece5b9ddddeb59e95b460c762
Comment 25 Matěj Laitl 2013-05-27 09:59:30 UTC
*** Bug 283225 has been marked as a duplicate of this bug. ***