Bug 168658 - kmix - master channel missing
Summary: kmix - master channel missing
Status: RESOLVED FIXED
Alias: None
Product: kmix
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Christian Esken
URL:
Keywords:
: 171933 172885 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-08-07 20:52 UTC by Alan Braslau
Modified: 2008-11-01 15:02 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
KMix channels (41.54 KB, image/jpeg)
2008-08-09 20:35 UTC, Dario Andres
Details
Alsamixer channels (66.25 KB, image/jpeg)
2008-08-09 20:35 UTC, Dario Andres
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alan Braslau 2008-08-07 20:52:13 UTC
Version:           3.0 (using 4.1.00 (KDE 4.1.0), Debian packages)
Compiler:          cc
OS:                Linux (i686) release 2.6.26

After KDE upgrade, my system became mute (using Intel ICH6 sound chip).
Finally, via alsamixer, I was able to unmute and raise the "master" volume and get sound. Note that this is distinct from the "master mono" item and also is not to be confused with the kmix so-called master channel. No corresponding channel appears to be available under kmix.
Comment 1 George Kiagiadakis 2008-08-08 09:28:38 UTC
On my systems (I have two PCs with Intel HDA-based sound chips), the "Master" channel from alsa is called "Front" in kmix (and thus, I have two "Front" channels in kmix). Is that the same with your case?
Comment 2 Dario Andres 2008-08-09 20:34:26 UTC
Version 3.0 Using KDE 4.1.1 (KDE 4.1.0 (4.1 >= 20080722)) (KDEmod) in ArchLinux i686:
I also experience the behaviour described in comment 1. My "Master" channel is named "Front"
Comment 3 Dario Andres 2008-08-09 20:35:01 UTC
Created attachment 26758 [details]
KMix channels
Comment 4 Dario Andres 2008-08-09 20:35:17 UTC
Created attachment 26759 [details]
Alsamixer channels
Comment 5 Alan Braslau 2008-08-11 23:14:53 UTC
On Friday 08 August 2008 09:28:39 George Kiagiadakis wrote:
[bugs.kde.org quoted mail]

Yes, indeed, there is a "front" channel. How should one guess that this is 
what used to be called "master"?
I see the logic of being able to assign the "master" channel in kmix, but the 
name change is less than obvious. I got stung as the channel was set to 0 (and 
muted) by the kmix upgrade.
Comment 6 Ambroz Bizjak 2008-08-22 18:00:07 UTC
I also have two "Front" channels in kmix because it renames the Master to Front, while my card has its own Front. I see no reason for renaming any channel, it only causes confusion, e.g. in "Select master channel". It also makes it impossible to assign keyboard shortcuts for the real Front channel as it uses the channel's name as an identifier. And there are really many cards with a Front channel. So, please remove the unnecessary renaming.
Comment 7 Christian Esken 2008-10-27 01:09:47 UTC
The reason for renaming is, because ALSA names the control wrong for many soundcards (The master is no master at all, because it controls only front). This has lead to several bug reports in the past. Now this solution (renaming) also leads to bug reports.

The best way is to roll this back. So by default you get "Master" and if you use a XML profile for your soundcard, you can also receive "Front" if you like.
Comment 8 Christian Esken 2008-10-27 01:11:24 UTC
SVN commit 876286 by esken:

The renaming from "Master" to "Front" confused too many people. Also it
looks like we only have a hit ratio of about 50%. => Removing the renaming
line from the XML profile.
BUGS:168658


 M  +6 -1      ALSA.default.xml  


WebSVN link: http://websvn.kde.org/?view=rev&revision=876286
Comment 9 Christian Esken 2008-10-27 01:33:28 UTC
*** Bug 171933 has been marked as a duplicate of this bug. ***
Comment 10 Christian Esken 2008-10-27 02:10:48 UTC
*** Bug 172885 has been marked as a duplicate of this bug. ***
Comment 11 Christian Esken 2008-11-01 15:02:59 UTC
SVN commit 878601 by esken:


Fix "master channel missing" (last pacth was incomplete)
CCBUGS:168658


 M  +1 -1      ALSA.default.xml  


WebSVN link: http://websvn.kde.org/?view=rev&revision=878601