Bug 168254 - regression : quick filter input box disappeared in 4.1
Summary: regression : quick filter input box disappeared in 4.1
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Unclassified
Component: dirfilterplugin (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Simon St James
URL:
Keywords:
: 173812 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-08-03 21:06 UTC by Romain GUINOT
Modified: 2011-11-21 23:05 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Romain GUINOT 2008-08-03 21:06:57 UTC
Version:            (using KDE 4.1.0)
Installed from:    Fedora RPMs
Compiler:          GCC 4.3 
OS:                Linux

Hi, 

The quick filter input box has disappeared from the dirfilter plugin in Konqueror 4.1.00 (svn path of the plugin is /trunk/extragear/base/konq-plugins/dirfilter)
I have tried with the latest kde-addons packaged,in Fedora, and directly by CMaking this extension from SVN Head against my 4.1 installation. 

Even though i can see the plugin in Konqueror's extensions config,only the "Mimetype filter" and "clear filter" appear. The toolbar_filter_field does not display even though it should be active according to the toolbar actions config showing what should and should not be displayed. 

I've looked at the source (dirfilterplugin.cpp:182) , it seems that the 2 actions that show up are QActions, the missing one is declared as a KAction. Could this be the source of the problem ? 

I really miss this extension :(

I've migrated straight from 3.5.9 so i have not checked if the filter is present in 4.0.x

Any ideas ? 
Thanks, 

Romain.
Comment 1 Simon St James 2008-08-09 10:13:30 UTC
Interesting timing :)

I've got this semi-working a few days ago, but I'll need some additional help from Peter to get it 100%.

You can follow the progress (and help test the patch! :)) here:

http://lists.kde.org/?l=kfm-devel&m=121821503218290&w=2
Comment 2 Romain GUINOT 2008-08-09 17:35:04 UTC
Cool !

I applied the patch and cmade the extension, it is working again on my
end thank you very much !



On 9 Aug 2008 08:13:30 -0000, SSJ <ssj195@hotmail.com> wrote:
[bugs.kde.org quoted mail]
Comment 3 Simon St James 2008-08-16 12:40:33 UTC
Just to keep people in the loop: there needs to be some discussion as to whether to add the required getters and setters to Dolphin, or whether to expose Dolphin's own file filter via a KPart, and use that instead of kdirfilterplugin.  Which approach is best has not been decided yet, and I'll probably blog about it if I get some more Konq regressions sorted out, to get some user feedback :)
Comment 4 Simon St James 2008-10-04 18:03:04 UTC
Cleaned-up patch committed to SVN:

http://websvn.kde.org/?view=rev&revision=867838

90% working is better than completely broken :) To get this fully working, some additions would need to be made to DolphinPart, but this will serve until we fully work out the details.

@Romain: I'll leave it up to you to decide whether to mark this as FIXED or not :)
Comment 5 Romain GUINOT 2008-10-04 18:30:51 UTC
Hi Simon, 

I've just svn up'ed the extension, and it still works :)
Thanks for your effort ! 

I'll gladly marked this as fixed, but i cannot find on this page where i can change the bug's status, maybe i'm not authorized to do so...
Comment 6 Simon St James 2008-10-04 18:37:44 UTC
Can't remember whether you need special priviledges to mark your own bugs as FIXED or not, but since you're happy with it, I'll do it for you :)
Comment 7 George Kiagiadakis 2008-11-01 00:38:11 UTC
*** Bug 173812 has been marked as a duplicate of this bug. ***