Bug 167268 - konqueror, stylesheets, accessibility, colors
Summary: konqueror, stylesheets, accessibility, colors
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 171964 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-07-23 00:53 UTC by Emanuel Helms
Modified: 2008-10-27 01:15 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Emanuel Helms 2008-07-23 00:53:30 UTC
Version:           4.00.98 (using KDE 4.0.98)
Installed from:    Ubuntu Packages
OS:                Linux

Hi,

when I activate the accessibility stylesheets in Konqueror and then change the colors to have a black bg and a white font it does not work. Alsa I can't change the link-color. This is a problem when I have a black bg. A darl blue link on black bg..

Its working in KDE3 but here I can't change the link color too.


Hope the problem will be fixed! :)
Comment 1 George Kiagiadakis 2008-07-23 01:00:50 UTC
I can confirm this, I set the accessibility stylesheet to have black font on white bg and tried to visit blackle.com, which, however, still appears as white font on black bg.
Comment 2 Maksim Orlovich 2008-10-01 15:42:30 UTC
*** Bug 171964 has been marked as a duplicate of this bug. ***
Comment 3 Maksim Orlovich 2008-10-01 15:42:48 UTC
Confirm breakage, testing fix now..
Comment 4 Maksim Orlovich 2008-10-01 15:48:42 UTC
To fix loading:
--- khtml_part.cpp	(revision 865951)
+++ khtml_part.cpp	(working copy)
@@ -128,6 +128,8 @@
 
 #include "ecma/debugger/debugwindow.h"
 
+#include <iostream>
+
 namespace khtml {
     class PartStyleSheetLoader : public CachedObjectClient
     {
@@ -144,7 +146,8 @@
         {
             if ( m_cachedSheet ) m_cachedSheet->deref(this);
         }
-        virtual void setStyleSheet(const DOM::DOMString&, const DOM::DOMString &sheet, const DOM::DOMString &)
+	
+	virtual void setStyleSheet(const DOM::DOMString&, const DOM::DOMString &sheet, const DOM::DOMString &, const DOM::DOMString &)
         {
           if ( m_part )
             m_part->setUserStyleSheet( sheet.string() );


.... But there seems to be an another bug in re-setting, also the kcm seems a bit buggy.
Comment 5 Maksim Orlovich 2008-10-27 01:13:05 UTC
SVN commit 876287 by orlovich:

Fix signature mis-match here, unbreaks loading of accessibility/user stylesheet, and also crash on exit 
when one is set.
BUG:167268
BUG:164796


 M  +1 -1      khtml_part.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=876287
Comment 6 Maksim Orlovich 2008-10-27 01:15:20 UTC
SVN commit 876288 by orlovich:

Merged revision 876287:
Fix signature mis-match here, unbreaks loading of accessibility/user stylesheet, and also crash on exit 
when one is set.
BUG:167268
BUG:164796

 M  +1 -1      khtml_part.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=876288