Bug 166985 - When selecting Leave and then Switch User in the kde menu there is no list of users but instead a run dialog is shown
Summary: When selecting Leave and then Switch User in the kde menu there is no list of...
Status: RESOLVED DUPLICATE of bug 186198
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 167024 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-07-19 11:50 UTC by Rik
Modified: 2010-10-27 18:58 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rik 2008-07-19 11:50:36 UTC
Version:            (using KDE 4.0.5)
Installed from:    Fedora RPMs
Compiler:          gcc version 4.3.0 20080428 (Red Hat 4.3.0-8) (GCC) x86_64-redhat-linux Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=http://bugzilla.redhat.com/bugzilla --enable-bootstrap --enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-languages=c,c++,objc,obj-c++,java,fortran,ada --enable-java-awt=gtk --disable-dssi --enable-plugin --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-1.5.0.0/jre --enable-libgcj-multifile --enable-java-maintainer-mode --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --disable-libjava-multilib --with-cpu=generic --build=x86_64-redhat-linux Thread model: posix
OS:                Linux

I was used to having more than one KDE sessions for several users open at one time with KDE / FC7. When I needed to login to another session I used 'Switch User' and after that I could witch between the open sessions by pressing [ctrl][alt][f7] or [ctrl][alt][f8] and so on...

With KDE / FC9 I cant even login to a second session because I do not get a login menu when selecting 'Leave' and then 'Switch User' in the KDE menu. Instead I get a run dialog with the title 'Switch User' but no other suggestion as how to select another session or user.
Comment 1 Christophe Giboudeaux 2008-07-20 14:57:57 UTC
*** Bug 167024 has been marked as a duplicate of this bug. ***
Comment 2 Rik 2008-07-20 19:10:56 UTC
Can someone please explain what the consequences of changing Severity from 'normal' to 'wishlist' are ??? 

Or maybe even better... send me a link to information on the subject of bug classification that is used here.

Thank you.
Comment 3 Chani 2008-07-20 23:39:11 UTC
I don't think there are any consequences, per se. it just helps developers to sort the reports. I think wishlist items are unlikely to be worked on during a feature freeze (which we won't have for a few months)... but even that isn't always the case ;)
Comment 4 Martin Köbele 2008-08-05 05:54:07 UTC
with fc9 and KDE 4.1.0 "switch user" simply locks the current user out, exactly like "lock".

I can confirm, that "switch user" does not provide a dialog with which you can start a new session how it used to work in kde 3.5.

I really miss this feature.
Comment 5 Aaron J. Seigo 2008-08-05 05:56:49 UTC
and yet i use this feature at least weekly, sometimes several times a week.

i know this works in trunk due to that; please report this upstream.
Comment 6 Martin Köbele 2008-08-11 02:11:33 UTC
I opened a bug for fedora 9

https://bugzilla.redhat.com/show_bug.cgi?id=458616
Comment 7 Rex Dieter 2008-08-11 06:41:44 UTC
works fine here too (... I cannot reproduce the problem anyway)
Comment 8 Martin Köbele 2008-08-11 19:50:08 UTC
problem solved

Solution: make sure you use kdm and NOT gdm ;)
Comment 9 Rik 2008-08-11 22:11:55 UTC
I see,

This seems to solve the problem and thus indeed WORKSFORME as well.

Rik 
Comment 10 Rik 2008-08-11 23:06:12 UTC
Forgot to say thanks to Martin, 

For I now also (think I) understand now what reporting upstream means... |-)  
Comment 11 Kevin Kofler 2010-10-27 18:58:56 UTC
This got implemented for GDM in kdebase-workspace trunk (for 4.6) now, see bug 186198.

*** This bug has been marked as a duplicate of bug 186198 ***