Bug 166190 - KSnapshot Infinite fork bug (PrintScrn key shortcut)
Summary: KSnapshot Infinite fork bug (PrintScrn key shortcut)
Status: RESOLVED FIXED
Alias: None
Product: ksnapshot
Classification: Unclassified
Component: general (show other bugs)
Version: 0.7
Platform: Slackware Packages Linux
: NOR normal with 40 votes (vote)
Target Milestone: ---
Assignee: Richard Moore
URL:
Keywords:
: 162846 179314 189148 199794 204728 250843 250947 252977 262809 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-07-10 01:15 UTC by Shane Sanders
Modified: 2020-07-15 12:40 UTC (History)
20 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shane Sanders 2008-07-10 01:15:33 UTC
Version:           0.7 (using KDE 3.5.9)
Installed from:    Slackware Packages
Compiler:          gcc 4.2.3 
OS:                Linux

With Ksnapshot bound to PrintScreen press it five times, then five more.

Ksnapshot dialogs start instantiating infinitely. 

Although this is reported as resolved how exactly was it resolved if it can fork numerous processes without stopping in 3.5.9 which is the latest stable.
Comment 1 Rui G. 2008-07-11 21:00:23 UTC
Happened to me before. Took all my memory before i could kill it.
Comment 2 Richard Moore 2008-07-14 00:24:47 UTC
Is your bug simply that there's a new ksnapshot launched for each press of the key? or something more complicated?

Comment 3 Rui G. 2008-07-14 02:30:57 UTC
Richard, press printscreen 20 times in a row very fast, then sit back and watch the show, they will keep spawning way over 20. Of course, please save any work you might have, in my case it stopped a file system repair which caused a lot of data loss. 

The bug is very simple, it might not even be ksnapshot's . It could be just kde thinking we keep pushing printscreen, maybe it's Xorg.

This only happened to me in Arch with kde 3.5.9 . 
Comment 4 boulan 2008-10-06 11:49:33 UTC
This seems to be a duplicate of this bug:
https://bugs.kde.org/show_bug.cgi?id=162846
Comment 5 Brad Hards 2008-10-24 11:02:12 UTC
*** Bug 162846 has been marked as a duplicate of this bug. ***
Comment 6 Urs Wolfer 2009-01-02 00:11:49 UTC
*** Bug 179314 has been marked as a duplicate of this bug. ***
Comment 7 Dorian Raymer 2009-01-10 21:04:02 UTC
This happened to me while running Kubuntu 8.04 in a VirtualBox Machine on Mac OSX 10.5. 
I was able to avoid a crash and continue working by moving the ksnapshot bin file, causing whatever was spawning it to fail: 
# mv /usr/bin/ksnapshot ~/STOPksnapshot 

Hope this helps anyone else who experiences this problem. 
-Dorian 
Comment 8 Umut Yildiz 2009-02-11 10:10:21 UTC
It also happened to me when I pressed the Print Screen button a few times successively. It printed the screenshot infinitely. I had another linux computer nearby and I logged in to my computer from that computer and used all the commands that I know to kill ksnapshot, but it did not work. 
Comment 9 Danna 2009-05-01 00:09:42 UTC
I fresh installed Kubuntu 9.04 yesterday. Got Dragon player running and attempted to take a screen shot of a DVD playing from the optical drive to test the application (I need to take screenshots for work).

Pressed PrtSc once, and KSnapshot went mad taking repeated screenshots, opening a new window each time. I could not stop the application. I closed Dragon Player, no joy, the screenshots, firing off several per second, reflected the changes on the screen but kept going. I could not shutdown the laptop (IBM Thinkpad Z61t) using the KDE menu, and it took some time holding down the power-off switch to get the the machine to stop.

Not touching KSnapshot again, have to find some other screen capture application.
Comment 10 Ismael Barros 2009-05-22 23:19:57 UTC
Happened time ago in KDE 3.5, and just happened again pressing PrintScreen 3 times in KDE 4.2.3 with a fresh KDE configuration, in Archlinux.

Couldn't manage to switch to a TTY or log in on SSH, memory was lost in seconds.
Comment 11 Christopher Dawkins 2009-06-18 16:50:59 UTC
It's hit me twice in the past week (in both cases starting with an accidental touch on Print Screen), forking continuously. In both cases I spent some time logged in from an adjacent machine through SSH running 'killall -9 ksnapshot' (which worked, but didn't stop the spawning). In both cases killing the PPID worked, but that killed KDE. I have now removed ksnapshot from my /usr/local/kde4/bin/ directory (KDE 4.2.2 on FreeBSD).
Comment 12 FiNeX 2009-07-12 20:17:07 UTC
*** Bug 199794 has been marked as a duplicate of this bug. ***
Comment 13 Dario Andres 2009-08-22 15:13:50 UTC
*** Bug 204728 has been marked as a duplicate of this bug. ***
Comment 14 Dario Andres 2009-08-22 15:14:26 UTC
*** Bug 189148 has been marked as a duplicate of this bug. ***
Comment 15 Michał D. (Emdek) 2009-08-22 15:27:50 UTC
Maybe this is related to shortcuts? Maybe command is simply repeated?
It occured two times on my machine, long time ago, now it works like it should (and in time of these failures it was usually working fine).
Comment 16 Josef Müller 2010-06-14 09:48:15 UTC
ksnapshot 0.8.1. unter ubuntu lucid (kde 4.4.2) erlaunt kein direktes Drucken der Seite. Unter kde 3.5 funktionierte das noch.
Comment 17 Malte S. Stretz 2010-07-23 09:33:34 UTC
This is probably not a KSnapshot bug, something similar happens on my machine with the multimedia keys:  Sometimes Firefox and KMail, which I have mapped to these keys, are started ten or so times from a single keypress.

Seems like KHotkeys or whoever manages those keys has to debounce some keys.

Qt: 4.7.0
KDE Development Platform: 4.4.92 (KDE 4.4.92 (KDE 4.5 RC2))
KSnapshot: 0.8.1
Comment 18 Christoph Feck 2010-09-11 15:41:17 UTC
*** Bug 250843 has been marked as a duplicate of this bug. ***
Comment 19 Christoph Feck 2010-09-12 11:57:03 UTC
*** Bug 250947 has been marked as a duplicate of this bug. ***
Comment 20 Christoph Feck 2010-10-02 11:31:08 UTC
*** Bug 252977 has been marked as a duplicate of this bug. ***
Comment 21 Christoph Feck 2011-01-11 00:51:02 UTC
*** Bug 262809 has been marked as a duplicate of this bug. ***
Comment 22 Malte S. Stretz 2011-05-10 13:59:02 UTC
I haven't seen this for a while, might be fixed in 4.6.3.
Comment 23 Shane Sanders 2011-05-16 02:11:27 UTC
This bug is almost three years old.  I'm voting that it should be closed out upon the premise that it's no longer relevant. KDE 3.5 is being inadvertently  maintained (fork?) by:  http://www.trinitydesktop.org

I can no longer assist (basically I never did anyway) with resolving the issues seeing as how I no longer run KDE.  Honestly no sarcasm guys.  Family, friends and mostly work has taken up all my time.  Programming and entertainment is at a standstill.  

My apologies,

Shane

Insight would tell me that there was a buffer overflow or type-casting problem.
That maybe somewhere to look.

Thanks anyway.
Comment 24 Malte S. Stretz 2011-05-16 12:18:24 UTC
This bug happened in KDE 4 as well, but not recently.  It probably wasn't a KSnapshot bug anyway but in KHotKeys or something.  I'll close it as fixed.  If anybody encounters this bug again, please open a new one.