Bug 165413 - No Full Screen with Open GL Screen Savers
Summary: No Full Screen with Open GL Screen Savers
Status: RESOLVED DUPLICATE of bug 66492
Alias: None
Product: kwin
Classification: Plasma
Component: compositing (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 167210 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-06-30 13:04 UTC by Bobby
Modified: 2011-06-02 16:07 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bobby 2008-06-30 13:04:18 UTC
Version:            (using KDE 4.0.83)
Compiler:          GCC 4.3 
OS:                Linux

Open GL screen savers are displayed on a 1/4 of the screen and are slow when the KWin effects are turned on. The screen savers are okay if I turn off the effects.
Comment 1 Mike 2008-07-01 12:58:21 UTC
I also see this but not all the time.  Some times it shows at full screen but about 25% of the time it just appears as 1/4 of the (first) screen.  This happens even within the same session.  I am using a recent svn version.

AMD64 and nvidia 173.14.09.
Comment 2 Bobby 2008-07-03 18:01:29 UTC
Am Dienstag, 1. Juli 2008 schrieb Mike:
> his happens even within the same session.  I am using a recent svn version.
>
> AMD64 and nvidia 173.14.09.


I am using Beta 2 and I also have an nVidia card with the latest driver 
installed. Could it be an nVidia problem since it's the first time I have 
been able to use the openGL screen savers on KDE 4.1?
It's not all the time though, like you pointed out. I had fullscreen one time 
(for the first time) today :)
Comment 3 Michael 2008-07-23 15:35:56 UTC
*** Bug 167210 has been marked as a duplicate of this bug. ***
Comment 4 Michael Krueger 2008-07-23 16:14:17 UTC
I have the same problem. My system is a Dell XPS M1210 with nVidia graphics card
Comment 5 Mark A. Taff 2008-08-18 15:11:03 UTC
This doesn't affect *all* the OpenGL screensavers on my machine.

Working OK:

--Gravity
--KPendulum
--KRotation

Note that both Particle Fountain & Bitmap Flag use same upper left quarter of screen, but the rest of the screen is black, not white.

This machine is an Intel Core 2 Quad Q6600 (x84_64), with an Nvidia 8600 GTS using the nvidia driver 173.14.12.  X.org version 1.4.0.90 (10400090).

Linux 2.6.25.11-0.1-default, KDE 4.1 from Suse rpms.

On a hunch, I took "nvidia-settings -a InitialPixmapPlacement=2 -a GlyphCache=1" out of my ~/.xinitrc, but it didn't have any effect on this bug.

I can confirm that turning off kwin's effects fixes the problem.

After a lot of futzing around, I have determined that this bug is intermittent.  There are some combinations of enabled kwin effects (always different) where the screensavers work OK, sometimes.

For example, with nothing but the cover switcher on, and repeatedly testing the Euphoria screensaver, it fails about 25% of the time.
Comment 6 Jonathan Thomas 2008-08-29 02:02:11 UTC
Seems to be bug 165552, which has a patch.
Comment 7 Jonathan Thomas 2008-08-29 02:05:14 UTC
..but the patch seems to be incorrect, by the author's own admission. So you might as well add it as a dupe of this one.
Comment 8 Alexander Sagen 2008-12-04 23:51:56 UTC
Still seing this on 4.2 Beta 1 running on Kubuntu.. Seems to me that the resource-intensive screensavers are the ones who fail to display properly, and more often then not when the cpu(s) is under load. 
Nvidia 8800 gts here, Intel core 2 duo, running 64bit
Comment 9 Oswald Buddenhagen 2011-06-02 16:07:24 UTC

*** This bug has been marked as a duplicate of bug 66492 ***