Bug 165552 - OpenGL screensaver only occupies 1/4 of the screen
Summary: OpenGL screensaver only occupies 1/4 of the screen
Status: RESOLVED DUPLICATE of bug 66492
Alias: None
Product: kscreensaver
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
: 181234 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-07-02 09:21 UTC by Thilo-Alexander Ginkel
Modified: 2009-03-08 19:53 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Photograph showing the issue (819.06 KB, image/jpeg)
2008-07-02 09:32 UTC, Thilo-Alexander Ginkel
Details
Possible fix (5.37 KB, patch)
2008-07-14 17:49 UTC, John Stamp
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thilo-Alexander Ginkel 2008-07-02 09:21:45 UTC
Version:            (using KDE 4.0.83)
Installed from:    Ubuntu Packages
Compiler:          gcc (GCC) 4.2.3 (Ubuntu 4.2.3-2ubuntu7) 
OS:                Linux

Some OpenGL screensavers (such as Solar Winds, Particle Fountain, Gravity, but not KPendulum) only make use of the upper left quadrant of the screen (see attached photograph for details). I am using the Nvidia driver version 96.43.05.
Comment 1 Thilo-Alexander Ginkel 2008-07-02 09:32:05 UTC
Created attachment 25783 [details]
Photograph showing the issue
Comment 2 Thilo-Alexander Ginkel 2008-07-02 11:00:42 UTC
I forgot to mention that this issue does *not* occur when using KDE 3.5.9 using the same graphics drivers.
Comment 3 John Stamp 2008-07-14 17:44:26 UTC
I had the same problem with another KDE4 OpenGL screensaver.

My guess is that the QGLWidget needs to specify KScreenSaver as its parent, or it sometimes doesn't resize itself when it runs fullscreen.  KPendulum and KRotation didn't have that problem because they were already doing that.
Comment 4 John Stamp 2008-07-14 17:49:14 UTC
Created attachment 26113 [details]
Possible fix
Comment 5 John Stamp 2008-07-26 16:57:56 UTC
Actually, I now doubt that it's the right fix.  kscreensaver.h says:

You cannot create a new widget with this widget as parent, since this
widget may not be owned by your application. ...

which is exactly what that patch did.  I'll see if I can come up with something better.
Comment 6 Harald Sitter 2008-08-01 15:29:33 UTC
Moving but to kscreensaver.
Comment 7 John Stamp 2008-08-23 02:49:16 UTC
I have a little more info.

When the screensaver starts, the embedded QGLWidget gets a single resizeGL() call.  This first call always gets the correct size.  However on occasion the widget will get a second resizeGL() call a few milliseconds after the first.  This tells it to resize to 640x480.

What's odder is that this second call almost always happens when the screensaver is run in demo mode.
Comment 8 Thilo-Alexander Ginkel 2008-10-01 15:50:25 UTC
I finally got kdeartwork-kde4-4.1.1 to compile on my machine including John's patch (from comment #4) and can confirm that it solves the problem for me.
Comment 9 Ronan Arraes Jardim Chagas 2009-01-18 16:56:30 UTC
I'm using kde 4.2 RC with nvidia-drivers 180.22 and I'm having this bug.
Comment 10 Jonathan Thomas 2009-01-19 16:04:00 UTC
*** Bug 181234 has been marked as a duplicate of this bug. ***
Comment 11 DarkElven 2009-02-01 14:55:20 UTC
i use kde-4.2.0 and this problem still isn' solved more i have to add that when i move my cursos login window pops up and screensaver disappear and some wallpaper shows up... what is very strange for me and i'm a little confused...
Comment 12 Martin Walch 2009-03-08 00:46:52 UTC
This bug looks very much like a dup of bug #66492.
Comment 13 Thilo-Alexander Ginkel 2009-03-08 19:53:42 UTC
Indeed, this is a duplicate of bug # 66492, so am changing the status accordingly.

*** This bug has been marked as a duplicate of bug 66492 ***