Bug 164709 - choosing a select box entry in konqueror stops all input boxes from refreshing
Summary: choosing a select box entry in konqueror stops all input boxes from refreshing
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 174064 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-06-23 00:14 UTC by Ambroz Bizjak
Modified: 2008-11-02 02:46 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Non redirected widget (1.19 KB, patch)
2008-06-27 02:07 UTC, Rafael Fernández López
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ambroz Bizjak 2008-06-23 00:14:59 UTC
Version:            (using Devel)
Installed from:    Compiled sources
Compiler:          gcc (GCC) 4.1.2 (Gentoo 4.1.2 p1.1) 
OS:                Linux

On any web page with a select box, clicking on the box and choosing an entry will stop all input boxes from refreshing until the box is 'released' by clicking somewhere else.

Steps to reproduce:
- go to http://en.wikipedia.org/wiki/Special:Search
- when you move the pointer over select boxes and checkboxes, they will get highlighted (light-blue shadow)
- Click on the "MediaWiki Search" select box and choose something else; the content of the box changes
- Move the pointer over one of the checkboxes above; it will not get highlighted
- Choose another entry from the same select box; its content will not change
- Click somewhere on the site; the state is restored to normal

I compiled KDE using kdesvn-build.
Comment 1 FiNeX 2008-06-23 12:26:16 UTC
When an item on the combobox is selected with the mouse, the combo box doesn't release the focus.

Confirmed using r822759.
Comment 2 Rafael Fernández López 2008-06-27 02:07:10 UTC
Created attachment 25638 [details]
Non redirected widget

Removing the widget as redirected makes it avoid this situation. The problem is
showPopup() method, which if you see on console output, will even trigger X
warnings.

Making it non redirected avoids this behavior, as well as not changing parent
widget.
Comment 3 Rafael Fernández López 2008-06-27 10:59:55 UTC
This patch is plain wrong. Obviously, not redirecting the widget makes it impossible to zoom it correctly.

Looking in other way of fixing this issue.
Comment 4 Ivo Anjo 2008-07-24 18:02:15 UTC
I was just about to open a new report related to this: hovering on links stops working, the cursor changes shape and you can click but the target is not shown on the status bar.

I also checked, and on kde3 it worked fine.
Comment 5 Germain Garand 2008-10-30 15:48:11 UTC
fixed by Harri Porten,
revision 868030.
Comment 6 Maksim Orlovich 2008-11-02 02:46:51 UTC
*** Bug 174064 has been marked as a duplicate of this bug. ***