Bug 164296 - Dolphin crash right clicking on a corrupted MPEG file
Summary: Dolphin crash right clicking on a corrupted MPEG file
Status: CLOSED FIXED
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash
Target Milestone: ---
Assignee: Jos van den Oever
URL:
Keywords:
: 163838 164621 164989 165022 165131 165145 165149 165360 165369 165385 165433 165642 165765 165818 165964 165992 166008 166026 166311 166746 166777 166856 166893 167023 167199 167258 167272 167709 167716 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-06-17 15:27 UTC by FiNeX
Modified: 2008-09-18 03:38 UTC (History)
29 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments
corrupted (?) MPEG file (351.90 KB, video/mpeg)
2008-06-17 15:29 UTC, FiNeX
Details
Make resetting BufferedStream to 0 always succeed. (517 bytes, patch)
2008-06-29 14:28 UTC, Jakub Stachowski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FiNeX 2008-06-17 15:27:29 UTC
Version:           Revision 821398 (using Devel)
Installed from:    Compiled sources
OS:                Linux

When I right click on a corrupted MPEG file, dolphin crash.

This is the shell output:



dolphin(13437) KFileMetaInfoPrivate::init: KUrl("file:///home/test/record.mpeg")
dolphin: /media/progetti/KDE4/kdesvn/kdesupport/strigi/src/streams/dataeventinputstream.cpp:30: Strigi::DataEventInputStream::DataEventInputStream(Strigi::InputStream*, Strigi::DataEventHandler&): Assertion `input->position() == 0' failed.
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = dolphin path = <unknown> pid = 13437
sock_file=/home/test/.kde4/socket-DevilBlue/kdeinit4__0
kdeinit4: Got EXEC_NEW '/home/test/KDE4/kde/lib/kde4/libexec/drkonqi' from socket.
kdeinit4: preparing to launch /home/test/KDE4/kde/lib/kde4/libexec/drkonqi



And this is the backtrace:



Application: Dolphin (dolphin), signal SIGABRT
 [?1034h[Thread debugging using libthread_db enabled]
[New Thread 0xb62076d0 (LWP 13437)]
[KCrash handler]
#6  0xb8038424 in __kernel_vsyscall ()
#7  0xb65aa740 in raise () from /lib/libc.so.6
#8  0xb65ac078 in abort () from /lib/libc.so.6
#9  0xb65a368e in __assert_fail () from /lib/libc.so.6
#10 0xb694c1d8 in DataEventInputStream (this=0x347d, i=0x6, h=@0x859cdec)
    at /home/test/KDE4/kdesvn/kdesupport/strigi/src/streams/dataeventinputstream.cpp:30
#11 0xb69861e0 in Strigi::EventThroughAnalyzer::connectInputStream (
    this=0x859cde8, in=0xbfe52088)
    at /home/test/KDE4/kdesvn/kdesupport/strigi/src/streamanalyzer/eventthroughanalyzer.cpp:52
#12 0xb69ac016 in Strigi::StreamAnalyzerPrivate::analyze (this=0x8573a08, 
    idx=@0xbfe520d4, input=0xbfe52088)
    at /home/test/KDE4/kdesvn/kdesupport/strigi/src/streamanalyzer/streamanalyzer.cpp:392
#13 0xb775aa29 in KFileMetaInfoPrivate::init (this=0x8586ec0, 
    stream=@0xbfe52138, url=@0xbfe52130, mtime=1213439303)
    at /home/test/KDE4/kdesvn/kdelibs/kio/kio/kfilemetainfo.cpp:201
#14 0xb775c625 in KFileMetaInfo (this=0xbfe52200, path=@0xbfe52204)
    at /home/test/KDE4/kdesvn/kdelibs/kio/kio/kfilemetainfo.cpp:224
#15 0x08083772 in InfoSidebarPage::showMetaInfo (this=0x833d430)
    at /home/test/KDE4/kdesvn/kdebase/apps/dolphin/src/infosidebarpage.cpp:369
#16 0x08083b46 in InfoSidebarPage::showItemInfo (this=0x833d430)
    at /home/test/KDE4/kdesvn/kdebase/apps/dolphin/src/infosidebarpage.cpp:225
#17 0x080844cb in InfoSidebarPage::qt_metacall (this=0x833d430, 
    _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbfe52388)
    at /home/test/KDE4/kdesvn/build/kdebase/apps/dolphin/src/infosidebarpage.moc:92
#18 0xb7fa88fb in QMetaObject::activate (sender=0x83fc990, 
    from_signal_index=<value optimized out>, to_signal_index=4, argv=0x0)
    at /home/test/KDE4/kdesvn/qt-copy/src/corelib/kernel/qobject.cpp:3007
#19 0xb7fa8e52 in QMetaObject::activate (sender=0x83fc990, m=0xb8033e04, 
    local_signal_index=0, argv=0x0)
    at /home/test/KDE4/kdesvn/qt-copy/src/corelib/kernel/qobject.cpp:3080
#20 0xb7fdf657 in QTimer::timeout (this=0x83fc990)
    at .moc/release-shared/moc_qtimer.cpp:126
#21 0xb7fafeee in QTimer::timerEvent (this=0x83fc990, e=0xbfe5282c)
    at /home/test/KDE4/kdesvn/qt-copy/src/corelib/kernel/qtimer.cpp:263
#22 0xb7fa521f in QObject::event (this=0x83fc990, e=0xbfe5282c)
    at /home/test/KDE4/kdesvn/qt-copy/src/corelib/kernel/qobject.cpp:1105
#23 0xb6b5b5dc in QApplicationPrivate::notify_helper (this=0x828f728, 
    receiver=0x83fc990, e=0xbfe5282c)
    at /home/test/KDE4/kdesvn/qt-copy/src/gui/kernel/qapplication.cpp:3772
#24 0xb6b625ce in QApplication::notify (this=0xbfe52ab4, receiver=0x83fc990, 
    e=0xbfe5282c)
    at /home/test/KDE4/kdesvn/qt-copy/src/gui/kernel/qapplication.cpp:3366
#25 0xb7a8823d in KApplication::notify (this=0xbfe52ab4, receiver=0x83fc990, 
    event=0xbfe5282c)
    at /home/test/KDE4/kdesvn/kdelibs/kdeui/kernel/kapplication.cpp:311
#26 0xb7f970a1 in QCoreApplication::notifyInternal (this=0xbfe52ab4, 
    receiver=0x83fc990, event=0xbfe5282c)
    at /home/test/KDE4/kdesvn/qt-copy/src/corelib/kernel/qcoreapplication.cpp:583
#27 0xb7fc0b51 in QTimerInfoList::activateTimers (this=0x82922d4)
    at ../../include/QtCore/../../../../qt-copy/src/corelib/kernel/qcoreapplication.h:215
#28 0xb7fbd720 in timerSourceDispatch (source=0x82922a0)
    at /home/test/KDE4/kdesvn/qt-copy/src/corelib/kernel/qeventdispatcher_glib.cpp:166
#29 0xb64f7f88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#30 0xb64fb4eb in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#31 0xb64fb668 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#32 0xb7fbd678 in QEventDispatcherGlib::processEvents (this=0x826e7f8, flags=
      {i = -1075500632})
    at /home/test/KDE4/kdesvn/qt-copy/src/corelib/kernel/qeventdispatcher_glib.cpp:325
#33 0xb6be42a5 in QGuiEventDispatcherGlib::processEvents (this=0x826e7f8, 
    flags={i = -1075500584})
    at /home/test/KDE4/kdesvn/qt-copy/src/gui/kernel/qguieventdispatcher_glib.cpp:204
#34 0xb7f9582a in QEventLoop::processEvents (this=0xbfe52a40, flags=
      {i = -1075500520})
    at /home/test/KDE4/kdesvn/qt-copy/src/corelib/kernel/qeventloop.cpp:149
#35 0xb7f959ea in QEventLoop::exec (this=0xbfe52a40, flags={i = -1075500472})
    at /home/test/KDE4/kdesvn/qt-copy/src/corelib/kernel/qeventloop.cpp:196
#36 0xb7f97c4d in QCoreApplication::exec ()
    at /home/test/KDE4/kdesvn/qt-copy/src/corelib/kernel/qcoreapplication.cpp:845
#37 0xb6b5b457 in QApplication::exec ()
    at /home/test/KDE4/kdesvn/qt-copy/src/gui/kernel/qapplication.cpp:3304
#38 0x08085edf in main (argc=1, argv=0xbfe52c64)
    at /home/test/KDE4/kdesvn/kdebase/apps/dolphin/src/main.cpp:94
#0  0xb8038424 in __kernel_vsyscall ()
Comment 1 FiNeX 2008-06-17 15:29:11 UTC
Created attachment 25405 [details]
corrupted (?) MPEG file

This is the file which make dolphin crash.
btw, I'm using strigi from trunk too.
Comment 2 Peter Penz 2008-06-17 15:47:32 UTC
Reassigned to kdelibs (KFileMetaInfo - a 'strigi' entry would be nice as product) and added Jos to CC...
Comment 3 FiNeX 2008-06-22 11:09:33 UTC
It happens even simply moving the mouse over the file.
Comment 4 FiNeX 2008-06-22 11:10:47 UTC
*** Bug 164621 has been marked as a duplicate of this bug. ***
Comment 5 Tommi Tervo 2008-06-26 11:12:20 UTC
*** Bug 164989 has been marked as a duplicate of this bug. ***
Comment 6 Christophe Marin 2008-06-27 23:51:16 UTC
*** Bug 165022 has been marked as a duplicate of this bug. ***
Comment 7 Valentin Rusu 2008-06-28 09:24:06 UTC
Here is the stack trace from the sources I compiled last night.
It crashed when hovering over a AVI file.

Application: Dolphin (dolphin), signal SIGABRT
[Thread debugging using libthread_db enabled]
[New Thread 0xb6093720 (LWP 14254)]
[KCrash handler]
#6  0xb7f0a410 in __kernel_vsyscall ()
#7  0xb642d085 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0xb642ea01 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0xb642610e in __assert_fail () from /lib/tls/i686/cmov/libc.so.6
#10 0xb7710399 in Strigi::DataEventInputStream::DataEventInputStream ()
   from /home/valentin/kde/inst/4/lib/libstreams.so.0
#11 0xb77b0350 in Strigi::EventThroughAnalyzer::connectInputStream ()
   from /home/valentin/kde/inst/4/lib/libstreamanalyzer.so.0
#12 0xb77deef4 in Strigi::StreamAnalyzerPrivate::analyze ()
   from /home/valentin/kde/inst/4/lib/libstreamanalyzer.so.0
#13 0xb77df9b3 in Strigi::StreamAnalyzer::analyze ()
   from /home/valentin/kde/inst/4/lib/libstreamanalyzer.so.0
#14 0xb7cbf4b4 in KFileMetaInfoPrivate::init (this=0x8530540, 
    stream=@0xbf9272ec, url=@0xbf9272e4, mtime=1214079351)
    at /home/valentin/kde/src/4/KDE/kdelibs/kio/kio/kfilemetainfo.cpp:201
#15 0xb7cbf89d in KFileMetaInfo (this=0xbf9273a4, path=@0xbf9273a8)
    at /home/valentin/kde/src/4/KDE/kdelibs/kio/kio/kfilemetainfo.cpp:224
#16 0x080814b9 in InfoSidebarPage::showMetaInfo (this=0x828c838)
    at /home/valentin/kde/src/4/KDE/kdebase/apps/dolphin/src/infosidebarpage.cpp:379
#17 0x08081cd6 in InfoSidebarPage::showItemInfo (this=0x828c838)
    at /home/valentin/kde/src/4/KDE/kdebase/apps/dolphin/src/infosidebarpage.cpp:224
#18 0x08081f7b in InfoSidebarPage::slotTimeout (this=0x828c838)
    at /home/valentin/kde/src/4/KDE/kdebase/apps/dolphin/src/infosidebarpage.cpp:230
#19 0x080825fe in InfoSidebarPage::qt_metacall (this=0x828c838, 
    _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbf927518)
    at /home/valentin/kde/build/4/KDE/kdebase/apps/dolphin/src/infosidebarpage.moc:92
#20 0xb73fa31a in QMetaObject::activate ()
   from /home/valentin/kde/inst/4/lib/libQtCore.so.4
#21 0xb73fa762 in QMetaObject::activate ()
   from /home/valentin/kde/inst/4/lib/libQtCore.so.4
#22 0xb74330f7 in QTimer::timeout ()
   from /home/valentin/kde/inst/4/lib/libQtCore.so.4
#23 0xb7402cde in QTimer::timerEvent ()
   from /home/valentin/kde/inst/4/lib/libQtCore.so.4
#24 0xb73f8874 in QObject::event ()
   from /home/valentin/kde/inst/4/lib/libQtCore.so.4
#25 0xb6925c0c in QApplicationPrivate::notify_helper ()
   from /home/valentin/kde/inst/4/lib/libQtGui.so.4
#26 0xb692c669 in QApplication::notify ()
   from /home/valentin/kde/inst/4/lib/libQtGui.so.4
#27 0xb7a2b2e7 in KApplication::notify (this=0xbf927c3c, receiver=0x82fd880, 
    event=0xbf9279e8)
    at /home/valentin/kde/src/4/KDE/kdelibs/kdeui/kernel/kapplication.cpp:311
#28 0xb73e9bf9 in QCoreApplication::notifyInternal ()
   from /home/valentin/kde/inst/4/lib/libQtCore.so.4
#29 0xb7412921 in ?? () from /home/valentin/kde/inst/4/lib/libQtCore.so.4
#30 0xb7410420 in ?? () from /home/valentin/kde/inst/4/lib/libQtCore.so.4
#31 0xb62adbf8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#32 0xb62b0e5e in ?? () from /usr/lib/libglib-2.0.so.0
#33 0xb62b13ac in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#34 0xb7410b58 in QEventDispatcherGlib::processEvents ()
   from /home/valentin/kde/inst/4/lib/libQtCore.so.4
#35 0xb69ab955 in ?? () from /home/valentin/kde/inst/4/lib/libQtGui.so.4
#36 0xb73e8e7d in QEventLoop::processEvents ()
   from /home/valentin/kde/inst/4/lib/libQtCore.so.4
#37 0xb73e9011 in QEventLoop::exec ()
   from /home/valentin/kde/inst/4/lib/libQtCore.so.4
#38 0xb73eb2ba in QCoreApplication::exec ()
   from /home/valentin/kde/inst/4/lib/libQtCore.so.4
#39 0xb6925307 in QApplication::exec ()
   from /home/valentin/kde/inst/4/lib/libQtGui.so.4
#40 0x08084a85 in main (argc=6, argv=0xbf927df4)
    at /home/valentin/kde/src/4/KDE/kdebase/apps/dolphin/src/main.cpp:94
#0  0xb7f0a410 in __kernel_vsyscall ()
Comment 8 Frederik Gladhorn 2008-06-28 15:31:58 UTC
Hi, I can confirm this crash too.
Jos, please have a look :)

If I disable the assert (assert(input->position() == 0);) in dataeventinputstream.cpp in strigi all seems fine.
But since I have no grasp of strigi code I guess it would be better to have a real fix.
Let me know if I can test anything!

Greetings,
Frederik
Comment 9 Pino Toscano 2008-06-29 13:04:17 UTC
*** Bug 165131 has been marked as a duplicate of this bug. ***
Comment 10 Pino Toscano 2008-06-29 13:04:45 UTC
*** Bug 165145 has been marked as a duplicate of this bug. ***
Comment 11 Pino Toscano 2008-06-29 13:04:46 UTC
*** Bug 165149 has been marked as a duplicate of this bug. ***
Comment 12 Pino Toscano 2008-06-29 13:05:09 UTC
*** Bug 163838 has been marked as a duplicate of this bug. ***
Comment 13 Jakub Stachowski 2008-06-29 14:28:26 UTC
Created attachment 25700 [details]
Make resetting BufferedStream to 0 always succeed.

EventThroughAnalyzer requires that stream is positioned at start. This is
usually not a problem because all through analyzers launched before it, call
input->stream(0). The problem is with implementation of BufferedStream - it
does nothing if requested position is before start of the buffer. This usually
happens after AviThroughAnalyzer run - it reads enough of data to move buffer
away from beginning of the stream. Attached patch fixes this by resetting the
buffer in case normal seek did not succeed and new requested position is 0.
Warning: to test this patch first compile and install kdesupport/strigi and
then compile and install kdelibs/kio.
Comment 14 Philip Rodrigues 2008-06-29 14:57:26 UTC
The patch in comment 13 works for me
Comment 15 Christophe Marin 2008-06-29 21:48:49 UTC
*** Bug 165360 has been marked as a duplicate of this bug. ***
Comment 16 Peter Penz 2008-06-30 00:28:34 UTC
*** Bug 165369 has been marked as a duplicate of this bug. ***
Comment 17 Peter Penz 2008-06-30 07:19:00 UTC
*** Bug 165385 has been marked as a duplicate of this bug. ***
Comment 18 Peter Penz 2008-06-30 17:52:13 UTC
*** Bug 165433 has been marked as a duplicate of this bug. ***
Comment 19 Kishore 2008-07-03 13:22:15 UTC
I get this crash too. Only when the navigation bar is visible and on certain files (.avi inn this case). Backtrace follows:

Application: Dolphin (dolphin), signal SIGABRT
[Thread debugging using libthread_db enabled]
[New Thread 0x7fddb8afe780 (LWP 15217)]
[KCrash handler]
#5  0x00007fddb1729095 in raise () from /lib/libc.so.6
#6  0x00007fddb172aaf0 in abort () from /lib/libc.so.6
#7  0x00007fddb17222df in __assert_fail () from /lib/libc.so.6
#8  0x00007fddb729dae6 in DataEventInputStream (this=<value optimized out>, 
    i=<value optimized out>, h=<value optimized out>)
    at /media/ext_drive/devel/KDE/src/4/kdesupport/strigi/src/streams/dataeventinputstream.cpp:30
#9  0x00007fddb74dd7be in Strigi::EventThroughAnalyzer::connectInputStream (
    this=0xa6fe50, in=0x7fffc0b37e20)
    at /media/ext_drive/devel/KDE/src/4/kdesupport/strigi/src/streamanalyzer/eventthroughanalyzer.cpp:52
#10 0x00007fddb7502e4a in Strigi::StreamAnalyzerPrivate::analyze (
    this=0xa2c840, idx=@0x7fffc0b37ee0, input=0x7fffc0b37e20)
    at /media/ext_drive/devel/KDE/src/4/kdesupport/strigi/src/streamanalyzer/streamanalyzer.cpp:392
#11 0x00007fddb750384c in Strigi::StreamAnalyzer::analyze (
    this=<value optimized out>, idx=@0x3b71, input=0x6)
    at /media/ext_drive/devel/KDE/src/4/kdesupport/strigi/src/streamanalyzer/streamanalyzer.cpp:359
#12 0x00007fddb80e1435 in KFileMetaInfoPrivate::init (this=0xa2dee0, 
    stream=<value optimized out>, url=<value optimized out>, mtime=1204649854)
    at /media/ext_drive/devel/KDE/src/4/kdelibs/kio/kio/kfilemetainfo.cpp:201
#13 0x00007fddb80e1b1a in KFileMetaInfo (this=0x7fffc0b38110, 
    path=<value optimized out>)
    at /media/ext_drive/devel/KDE/src/4/kdelibs/kio/kio/kfilemetainfo.cpp:224
#14 0x000000000043c958 in InfoSidebarPage::showMetaInfo (this=0x8599e0)
    at /media/ext_drive/devel/KDE/src/4/kdebase/apps/dolphin/src/infosidebarpage.cpp:379
#15 0x000000000043cddc in InfoSidebarPage::showItemInfo (this=0x8599e0)
    at /media/ext_drive/devel/KDE/src/4/kdebase/apps/dolphin/src/infosidebarpage.cpp:224
#16 0x000000000043d4ba in InfoSidebarPage::qt_metacall (this=0x8599e0, 
    _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fffc0b38480)
    at /media/ext_drive/devel/KDE/build/4/kdebase/apps/dolphin/src/infosidebarpage.moc:92
#17 0x00007fddb68a2286 in QMetaObject::activate ()
   from /usr/lib/libQtCore.so.4
#18 0x00007fddb689cd35 in QObject::event () from /usr/lib/libQtCore.so.4
#19 0x00007fddb351854f in QApplicationPrivate::notify_helper ()
   from /usr/lib/libQtGui.so.4
#20 0x00007fddb351d125 in QApplication::notify () from /usr/lib/libQtGui.so.4
#21 0x00007fddb7bb2c7b in KApplication::notify (this=0x7fffc0b38dd0, 
    receiver=0x97ab80, event=0x7fffc0b38ab0)
    at /media/ext_drive/devel/KDE/src/4/kdelibs/kdeui/kernel/kapplication.cpp:311
#22 0x00007fddb688e109 in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#23 0x00007fddb68b93dc in ?? () from /usr/lib/libQtCore.so.4
#24 0x00007fddb68b6f4d in ?? () from /usr/lib/libQtCore.so.4
#25 0x00007fddb0b16262 in g_main_context_dispatch ()
   from /usr/lib/libglib-2.0.so.0
#26 0x00007fddb0b19516 in ?? () from /usr/lib/libglib-2.0.so.0
#27 0x00007fddb0b199af in g_main_context_iteration ()
   from /usr/lib/libglib-2.0.so.0
#28 0x00007fddb68b73af in QEventDispatcherGlib::processEvents ()
   from /usr/lib/libQtCore.so.4
#29 0x00007fddb35a172f in ?? () from /usr/lib/libQtGui.so.4
#30 0x00007fddb688d585 in QEventLoop::processEvents ()
   from /usr/lib/libQtCore.so.4
#31 0x00007fddb688d6db in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#32 0x00007fddb688f729 in QCoreApplication::exec ()
   from /usr/lib/libQtCore.so.4
#33 0x000000000043eb49 in main (argc=6, argv=0x7fffc0b392c8)
    at /media/ext_drive/devel/KDE/src/4/kdebase/apps/dolphin/src/main.cpp:94
#0  0x00007fddb1794b50 in nanosleep () from /lib/libc.so.6
Comment 20 Peter Penz 2008-07-03 17:30:29 UTC
*** Bug 165642 has been marked as a duplicate of this bug. ***
Comment 21 Bráulio Barros de Oliveira 2008-07-03 17:40:05 UTC
another crash, another backtrace:

Application: Dolphin (dolphin), signal SIGABRT
[Thread debugging using libthread_db enabled]
[New Thread 0x7f6238488700 (LWP 3694)]
[KCrash handler]
#5  0x00007f62313b40c5 in raise () from /lib/libc.so.6
#6  0x00007f62313b55e3 in abort () from /lib/libc.so.6
#7  0x00007f62313acf89 in __assert_fail () from /lib/libc.so.6
#8  0x00007f623422d741 in Strigi::DataEventInputStream::DataEventInputStream
    () from /home/kde/kde/lib/libstreams.so.0
#9  0x00007f62344e9063 in Strigi::EventThroughAnalyzer::connectInputStream ()
   from /home/kde/kde/lib/libstreamanalyzer.so.0
#10 0x00007f6234517f20 in Strigi::StreamAnalyzerPrivate::analyze ()
   from /home/kde/kde/lib/libstreamanalyzer.so.0
#11 0x00007f62345189be in Strigi::StreamAnalyzer::analyze ()
   from /home/kde/kde/lib/libstreamanalyzer.so.0
#12 0x00007f6236f62fab in KFileMetaInfoPrivate::init (this=0x2100ff0, 
    stream=@0x7fff405cc510, url=@0x7fff405cc500, mtime=1204225918)
    at /home/kde/kde/svn/kdelibs/kio/kio/kfilemetainfo.cpp:201
#13 0x00007f6236f632b7 in KFileMetaInfo (this=0x7fff405cc5f0, 
    path=@0x7fff405cc600)
    at /home/kde/kde/svn/kdelibs/kio/kio/kfilemetainfo.cpp:224
#14 0x000000000043ef28 in InfoSidebarPage::showMetaInfo (this=0x1d8ccd0)
    at /home/kde/kde/svn/kdebase/apps/dolphin/src/infosidebarpage.cpp:388
#15 0x000000000043f72e in InfoSidebarPage::showItemInfo (this=0x1d8ccd0)
    at /home/kde/kde/svn/kdebase/apps/dolphin/src/infosidebarpage.cpp:223
#16 0x000000000043f9a4 in InfoSidebarPage::slotInfoTimeout (this=0x1d8ccd0)
    at /home/kde/kde/svn/kdebase/apps/dolphin/src/infosidebarpage.cpp:229
#17 0x000000000043ff68 in InfoSidebarPage::qt_metacall (this=0x1d8ccd0, 
    _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0x7fff405cc9d0)
    at /home/kde/kde/build/kdebase/apps/dolphin/src/infosidebarpage.moc:93
#18 0x00007f62380df6f4 in QMetaObject::activate (sender=0x1a446d0, 
    from_signal_index=<value optimized out>, to_signal_index=4, 
    argv=0xffffffffffffffff) at kernel/qobject.cpp:3010
#19 0x00007f62380da003 in QObject::event (this=0x1a446d0, e=0xe6e)
    at kernel/qobject.cpp:1105
#20 0x00007f6234d4e76d in QApplicationPrivate::notify_helper (this=0x19c0ba0, 
    receiver=0x1a446d0, e=0x7fff405cd0c0) at kernel/qapplication.cpp:3772
#21 0x00007f6234d5643a in QApplication::notify (this=0x7fff405cd410, 
    receiver=0x1a446d0, e=0x7fff405cd0c0) at kernel/qapplication.cpp:3739
#22 0x00007f623750186a in KApplication::notify (this=0x7fff405cd410, 
    receiver=0x1a446d0, event=0x7fff405cd0c0)
    at /home/kde/kde/svn/kdelibs/kdeui/kernel/kapplication.cpp:311
#23 0x00007f62380cb3a1 in QCoreApplication::notifyInternal (
    this=0x7fff405cd410, receiver=0x1a446d0, event=0x7fff405cd0c0)
    at kernel/qcoreapplication.cpp:587
#24 0x00007f62380f7346 in QTimerInfoList::activateTimers (this=0x19badd0)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#25 0x00007f62380f386d in timerSourceDispatch (source=<value optimized out>)
    at kernel/qeventdispatcher_glib.cpp:166
#26 0x00007f6230ced6fa in g_main_context_dispatch ()
   from /usr/lib/libglib-2.0.so.0
#27 0x00007f6230cf0df0 in g_main_context_iterate ()
   from /usr/lib/libglib-2.0.so.0
#28 0x00007f6230cf0f8c in g_main_context_iteration ()
   from /usr/lib/libglib-2.0.so.0
#29 0x00007f62380f37cf in QEventDispatcherGlib::processEvents (
    this=0x19b8310, flags=<value optimized out>)
    at kernel/qeventdispatcher_glib.cpp:325
#30 0x00007f6234dde9cf in QGuiEventDispatcherGlib::processEvents (this=0xe6e, 
    flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#31 0x00007f62380c9cb2 in QEventLoop::processEvents (
    this=<value optimized out>, flags={i = 1079825200})
    at kernel/qeventloop.cpp:149
#32 0x00007f62380c9e3d in QEventLoop::exec (this=0x7fff405cd370, flags=
      {i = 1079825280}) at kernel/qeventloop.cpp:200
#33 0x00007f62380cc30d in QCoreApplication::exec ()
    at kernel/qcoreapplication.cpp:845
#34 0x000000000044240f in main (argc=6, argv=0x7fff405cd8d8)
    at /home/kde/kde/svn/kdebase/apps/dolphin/src/main.cpp:94
#0  0x00007f6231420f40 in __nanosleep_nocancel () from /lib/libc.so.6
Comment 22 Pino Toscano 2008-07-05 09:25:33 UTC
*** Bug 165765 has been marked as a duplicate of this bug. ***
Comment 23 Pino Toscano 2008-07-05 23:47:32 UTC
*** Bug 165818 has been marked as a duplicate of this bug. ***
Comment 24 Peter Penz 2008-07-07 10:26:25 UTC
SVN commit 829008 by ppenz:

Fixed possible crash when getting the meta information from files (thanks to Jakub Stachowski for the patch!).

@Jos: RC1 will be tagged tomorrow. I applied the patch as this is a showstopper for Dolphin (got already 20 bug reports because of this during the last 2 weeks) and I guess you are on vacation currently (no SVN commit since one month) - I hope this is OK for you!

CCMAIL: jos@vandenoever.info
BUG: 164296

 M  +2 -0      bufferedstream.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=829008
Comment 25 Peter Penz 2008-07-07 10:59:05 UTC
reopened bug-report as requested from Jos (reverted previous fix)
Comment 26 Peter Penz 2008-07-07 11:00:34 UTC
SVN commit 829013 by ppenz:

reverted last patch as requested by Jos

CCBUG: 164296

 M  +0 -2      bufferedstream.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=829013
Comment 27 Pino Toscano 2008-07-07 20:29:13 UTC
*** Bug 165964 has been marked as a duplicate of this bug. ***
Comment 28 Peter Penz 2008-07-07 21:44:06 UTC
Update: We've temporary disabled the avithroughanalyzer from Strigi, which needs some rework (Jos is already working on this). If you compile the latest SVN, please assure that you remove manually the file lib/strigi/strigita_avi.so and recompile at least kdesupport. By this approach the crash won't happen anymore. 
Comment 29 Peter Penz 2008-07-07 21:50:05 UTC
*** Bug 165992 has been marked as a duplicate of this bug. ***
Comment 30 Peter Penz 2008-07-08 08:16:35 UTC
*** Bug 166008 has been marked as a duplicate of this bug. ***
Comment 31 Christophe Marin 2008-07-08 12:45:40 UTC
*** Bug 166026 has been marked as a duplicate of this bug. ***
Comment 32 Jos van den Oever 2008-07-09 00:24:27 UTC
Fixed in revision 829713 of Strigi.
WAV and AVI analyzers have been replaced with a RIFF analyzer.
Comment 33 Christophe Marin 2008-07-11 18:02:20 UTC
*** Bug 166311 has been marked as a duplicate of this bug. ***
Comment 34 Pino Toscano 2008-07-16 22:41:37 UTC
*** Bug 166777 has been marked as a duplicate of this bug. ***
Comment 35 Peter Penz 2008-07-16 23:09:37 UTC
*** Bug 166777 has been marked as a duplicate of this bug. ***
Comment 36 Peter Penz 2008-07-16 23:14:17 UTC
*** Bug 166746 has been marked as a duplicate of this bug. ***
Comment 37 Peter Penz 2008-07-17 17:45:17 UTC
*** Bug 166856 has been marked as a duplicate of this bug. ***
Comment 38 Pino Toscano 2008-07-18 10:07:01 UTC
*** Bug 166893 has been marked as a duplicate of this bug. ***
Comment 39 Peter Penz 2008-07-19 20:56:41 UTC
*** Bug 167023 has been marked as a duplicate of this bug. ***
Comment 40 Franco Pellegrini 2008-07-21 03:18:08 UTC
Hi, i'm currently testing KDE 4 RC1 and this is still present...

this is the trace just in case

regards,
Franco

Application: Dolphin (dolphin), signal SIGABRT
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb5ef7a80 (LWP 18511)]
[KCrash handler]
#6  0xb7ef8410 in __kernel_vsyscall ()
#7  0xb674d085 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0xb674ea01 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0xb674610e in __assert_fail () from /lib/tls/i686/cmov/libc.so.6
#10 0xb60e8488 in Strigi::DataEventInputStream::DataEventInputStream ()
   from /usr/lib/libstreams.so.0
#11 0xb658150e in ?? () from /usr/lib/libstreamanalyzer.so.0
#12 0xb65a9a5a in ?? () from /usr/lib/libstreamanalyzer.so.0
#13 0xb65aa191 in Strigi::StreamAnalyzer::analyze ()
   from /usr/lib/libstreamanalyzer.so.0
#14 0xb7d42400 in KFileMetaInfoPrivate::init (this=0x85ec098, 
    stream=@0xbfc79218, url=@0xbfc79210, mtime=1216572464)
    at /build/buildd/kde4libs-4.0.98a/kio/kio/kfilemetainfo.cpp:201
#15 0xb7d427d3 in KFileMetaInfo (this=0xbfc792b8, path=@0xbfc792bc)
    at /build/buildd/kde4libs-4.0.98a/kio/kio/kfilemetainfo.cpp:224
#16 0x0807d774 in ?? ()
#17 0x0807dd4f in ?? ()
#18 0x0807e72d in ?? ()
#19 0xb76504f9 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#20 0xb7650bc2 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#21 0xb768de07 in QTimer::timeout () from /usr/lib/libQtCore.so.4
#22 0xb765767e in QTimer::timerEvent () from /usr/lib/libQtCore.so.4
#23 0xb764bc9a in QObject::event () from /usr/lib/libQtCore.so.4
#24 0xb6bc4c0c in QApplicationPrivate::notify_helper ()
   from /usr/lib/libQtGui.so.4
#25 0xb6bc97a9 in QApplication::notify () from /usr/lib/libQtGui.so.4
#26 0xb7ad5603 in KApplication::notify (this=0xbfc79b9c, receiver=0x83fcea8, 
    event=0xbfc79928)
    at /build/buildd/kde4libs-4.0.98a/kdeui/kernel/kapplication.cpp:311
#27 0xb763b6a9 in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#28 0xb76691a1 in ?? () from /usr/lib/libQtCore.so.4
#29 0xb7666a40 in ?? () from /usr/lib/libQtCore.so.4
#30 0xb6293bf8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#31 0xb6296e5e in ?? () from /usr/lib/libglib-2.0.so.0
#32 0xb62973ac in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#33 0xb7666f98 in QEventDispatcherGlib::processEvents ()
   from /usr/lib/libQtCore.so.4
#34 0xb6c581b5 in ?? () from /usr/lib/libQtGui.so.4
#35 0xb763a92d in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#36 0xb763aabd in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#37 0xb763cd3d in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#38 0xb6bc4567 in QApplication::exec () from /usr/lib/libQtGui.so.4
#39 0x08080749 in ?? ()
#40 0xb6738450 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#41 0x080619e1 in _start ()
#0  0xb7ef8410 in __kernel_vsyscall ()
Comment 41 Peter Penz 2008-07-21 08:50:02 UTC
@Franco: one part of the fix has been done shortly after RC1 has been tagged -> is really solved :-)
Comment 42 Franco Pellegrini 2008-07-21 14:29:11 UTC
Excellent :-D
i'll keep testing other stuff.
Comment 43 Peter Penz 2008-07-22 12:09:45 UTC
*** Bug 167199 has been marked as a duplicate of this bug. ***
Comment 44 Peter Penz 2008-07-23 06:25:49 UTC
*** Bug 167258 has been marked as a duplicate of this bug. ***
Comment 45 Peter Penz 2008-07-23 07:49:34 UTC
*** Bug 167272 has been marked as a duplicate of this bug. ***
Comment 46 Philippe Piquer 2008-07-29 22:12:31 UTC
Just upgraded to KDE 4.1 Release , and the bug is still there , Information panel visible , hover over avi file and Dolphin goes down :

Backtrace :
Application: Dolphin (dolphin), signal SIGABRT
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb5f3e720 (LWP 9278)]
[New Thread 0xb45b6b90 (LWP 9279)]
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0xb7f4e410 in __kernel_vsyscall ()
#7  0xb6796085 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0xb6797a01 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0xb678f10e in __assert_fail () from /lib/tls/i686/cmov/libc.so.6
#10 0xb6130488 in Strigi::DataEventInputStream::DataEventInputStream ()
   from /usr/lib/libstreams.so.0
#11 0xb65cb50e in ?? () from /usr/lib/libstreamanalyzer.so.0
#12 0xb65f3a5a in ?? () from /usr/lib/libstreamanalyzer.so.0
#13 0xb65f4191 in Strigi::StreamAnalyzer::analyze ()
   from /usr/lib/libstreamanalyzer.so.0
#14 0xb7d97400 in ?? () from /usr/lib/kde4/lib/libkio.so.5
#15 0xb7d977d3 in KFileMetaInfo::KFileMetaInfo ()
   from /usr/lib/kde4/lib/libkio.so.5
#16 0x0807da84 in ?? ()
#17 0x0807e05f in ?? ()
#18 0x0807ea3d in ?? ()
#19 0xb769a4f9 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#20 0xb769abc2 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#21 0xb76d7e07 in QTimer::timeout () from /usr/lib/libQtCore.so.4
#22 0xb76a167e in QTimer::timerEvent () from /usr/lib/libQtCore.so.4
#23 0xb7695c9a in QObject::event () from /usr/lib/libQtCore.so.4
#24 0xb6c0dc0c in QApplicationPrivate::notify_helper ()
   from /usr/lib/libQtGui.so.4
#25 0xb6c127a9 in QApplication::notify () from /usr/lib/libQtGui.so.4
#26 0xb7b23ef3 in KApplication::notify () from /usr/lib/kde4/lib/libkdeui.so.5
#27 0xb76856a9 in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#28 0xb76b31a1 in ?? () from /usr/lib/libQtCore.so.4
#29 0xb76b0a40 in ?? () from /usr/lib/libQtCore.so.4
#30 0xb62dcbf8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#31 0xb62dfe5e in ?? () from /usr/lib/libglib-2.0.so.0
#32 0xb62e03ac in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#33 0xb76b0f98 in QEventDispatcherGlib::processEvents ()
   from /usr/lib/libQtCore.so.4
#34 0xb6ca11b5 in ?? () from /usr/lib/libQtGui.so.4
#35 0xb768492d in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#36 0xb7684abd in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#37 0xb7686d3d in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#38 0xb6c0d567 in QApplication::exec () from /usr/lib/libQtGui.so.4
#39 0x08080aa9 in ?? ()
#40 0xb6781450 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#41 0x08061a71 in _start ()
#0  0xb7f4e410 in __kernel_vsyscall ()


btw which dbg package should be installed to have usefull info replacing the 'no debugging symbols...'
Comment 47 Pino Toscano 2008-07-29 23:13:30 UTC
> Just upgraded to KDE 4.1 Release , and the bug is still there [...]

You can update up to KDE 4.5 (exagerating), but it won't change the situation.
The bug was in strigi, so what you need to upgrade is *strigi*, at least the version 0.5.11.
Comment 48 Jay LaCroix 2008-07-30 00:20:34 UTC
How is it possible for the bug to be in Strigi? I always ensure that 
Strigi is disabled because it's never worked for anything, at all, 
whatsoever.

Without Strigi enabled I don't see how it could still effect it.

Pino Toscano wrote:
[bugs.kde.org quoted mail]
Comment 49 Jay LaCroix 2008-07-30 00:22:21 UTC
I also wanted to point out that even if Strigi is causing the problem 
(which I doubt since its disabled on my system) that would still be a 
KDE bug in my opinion, a plugin should not be able to crash Dolphin, it 
should be a separate process.

Pino Toscano wrote:
[bugs.kde.org quoted mail]
Comment 50 Christophe Marin 2008-07-30 00:51:55 UTC
Disabling Strigi indexing won't prevent KDE from using libstreams and libstreamanalyser (which are parts of Strigi).

Once again, this bug was fixed in Strigi. If you still experience it, report it to your distribution. That only means they didn't include the patches in Strigi 0.5.9 or that Strigi wasn't updated to 0.5.11. 
Comment 51 Jay LaCroix 2008-07-30 01:46:23 UTC
In that case, how come this problem didn't manifest itself on the same 
system prior to KDE 4.1-RC1? Also, how come we were promised this would 
be fixed in KDE 4.1? Whether it's Strigi causing this or not, Dolphin 
shouldn't crash if it has a problem with a plugin.

Christophe Giboudeaux wrote:
[bugs.kde.org quoted mail]
Comment 52 Jos van den Oever 2008-07-30 01:52:15 UTC
Dolphin uses libstreamanalyzer to get metadata out of files. libstreamanalyzer is part of strigi. Version 0.5.9 of strigi has a bug that causes a crash when analyzing some avi files. This is fixed in 0.5.11 which was released to be used with KDE 4.1.

A workaround is to delete strigita_avi.so if you have a strigi version older than 0.5.11.

Comment 53 Jay LaCroix 2008-07-30 02:24:44 UTC
The Ubuntu bug report is here:
https://bugs.launchpad.net/ubuntu/+source/kdebase/+bug/249156

If anyone (especially KDE developers) can chime in and urge them to fix it, it would be well appreciated.
Comment 54 Pino Toscano 2008-07-30 11:03:03 UTC
*** Bug 167709 has been marked as a duplicate of this bug. ***
Comment 55 Pino Toscano 2008-07-30 11:09:55 UTC
*** Bug 167716 has been marked as a duplicate of this bug. ***
Comment 56 nicolas fargier 2008-07-30 12:27:28 UTC
I can confirm it crashes for me to on the new kde 4.1 kubuntu package .
Here is the log :

Application: Dolphin (dolphin), signal SIGABRT
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb5f1d720 (LWP 6805)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0xb7f25410 in __kernel_vsyscall ()
#7  0xb6775085 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0xb6776a01 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0xb676e10e in __assert_fail () from /lib/tls/i686/cmov/libc.so.6
#10 0xb610f488 in Strigi::DataEventInputStream::DataEventInputStream ()
   from /usr/lib/libstreams.so.0
#11 0xb65aa50e in ?? () from /usr/lib/libstreamanalyzer.so.0
#12 0xb65d2a5a in ?? () from /usr/lib/libstreamanalyzer.so.0
#13 0xb65d3191 in Strigi::StreamAnalyzer::analyze ()
   from /usr/lib/libstreamanalyzer.so.0
#14 0xb7d6e400 in ?? () from /usr/lib/kde4/lib/libkio.so.5
#15 0xb7d6e7d3 in KFileMetaInfo::KFileMetaInfo ()
   from /usr/lib/kde4/lib/libkio.so.5
#16 0x0807da84 in ?? ()
#17 0x0807e05f in ?? ()
#18 0x0807ea3d in ?? ()
#19 0xb76794f9 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#20 0xb7679bc2 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#21 0xb76b6e07 in QTimer::timeout () from /usr/lib/libQtCore.so.4
#22 0xb768067e in QTimer::timerEvent () from /usr/lib/libQtCore.so.4
#23 0xb7674c9a in QObject::event () from /usr/lib/libQtCore.so.4
#24 0xb6becc0c in QApplicationPrivate::notify_helper ()
   from /usr/lib/libQtGui.so.4
#25 0xb6bf1799 in QApplication::notify () from /usr/lib/libQtGui.so.4
#26 0xb7afaef3 in KApplication::notify () from /usr/lib/kde4/lib/libkdeui.so.5
#27 0xb76646a9 in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#28 0xb76921a1 in ?? () from /usr/lib/libQtCore.so.4
#29 0xb768fa40 in ?? () from /usr/lib/libQtCore.so.4
#30 0xb62bbbf8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#31 0xb62bee5e in ?? () from /usr/lib/libglib-2.0.so.0
#32 0xb62bf3ac in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#33 0xb768ff98 in QEventDispatcherGlib::processEvents ()
   from /usr/lib/libQtCore.so.4
#34 0xb6c80195 in ?? () from /usr/lib/libQtGui.so.4
#35 0xb766392d in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#36 0xb7663abd in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#37 0xb7665d3d in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#38 0xb6bec567 in QApplication::exec () from /usr/lib/libQtGui.so.4
#39 0x08080aa9 in ?? ()
#40 0xb6760450 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#41 0x08061a71 in _start ()
#0  0xb7f25410 in __kernel_vsyscall ()
Comment 57 Jos van den Oever 2008-07-30 15:36:09 UTC
Hi Nicolas and Jeremy, please report the strigi version you have installed with
  apt-cache show libstreamanalyzer0

It should be at least 0.5.11.


Comment 58 Ritesh Raj Sarraf 2008-07-30 17:01:29 UTC
Assuming that the *buntu dudes are using the hardy release, it will be there because hardy has version 0.5.7.
http://packages.ubuntu.com/hardy/libstreamanalyzer0
Comment 59 Ritesh Raj Sarraf 2008-07-30 17:07:06 UTC
Just confirmed, on Debian (which is using version 0.5.11), Dolphin doesn't crash. I tested with avi files.
Comment 60 Jay LaCroix 2008-07-30 19:41:15 UTC
It is version 0.5.11 as of today, as an update was just released in the 
repositories. As of now, this issue stopped occuring.

Jos van den Oever wrote:
[bugs.kde.org quoted mail]
Comment 61 Jos van den Oever 2008-07-30 19:54:08 UTC
Great.