Bug 163838 - dolphin crash on right click in media file avi
Summary: dolphin crash on right click in media file avi
Status: RESOLVED DUPLICATE of bug 164296
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
: 163436 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-06-11 23:18 UTC by miki
Modified: 2008-06-29 13:08 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description miki 2008-06-11 23:18:57 UTC
Version:           1.0.99 (using 4.00.82 (KDE 4.0.82 >= 20080610), compiled sources)
Compiler:          gcc
OS:                Linux (i686) release 2.6.24-19-generic

Application: Dolphin (dolphin), signal SIGABRT
[Thread debugging using libthread_db enabled]
[New Thread 0xb5d8c720 (LWP 6366)]
[KCrash handler]
#6  0xb7f26410 in __kernel_vsyscall ()
#7  0xb618d085 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0xb618ea01 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0xb618610e in __assert_fail () from /lib/tls/i686/cmov/libc.so.6
#10 0xb6591399 in Strigi::DataEventInputStream::DataEventInputStream ()
   from /home/mi/kde/lib/libstreams.so.0
#11 0xb6630270 in Strigi::EventThroughAnalyzer::connectInputStream ()
   from /home/mi/kde/lib/libstreamanalyzer.so.0
#12 0xb665ee14 in Strigi::StreamAnalyzerPrivate::analyze ()
   from /home/mi/kde/lib/libstreamanalyzer.so.0
#13 0xb665f8f1 in Strigi::StreamAnalyzer::analyze ()
   from /home/mi/kde/lib/libstreamanalyzer.so.0
#14 0xb7653ec0 in KFileMetaInfoPrivate::init (this=0x8480648, 
    stream=@0xbffaefec, url=@0xbffaefe4, mtime=1212173554)
    at /home/mi/kde/src/KDE/kdelibs/kio/kio/kfilemetainfo.cpp:201
#15 0xb76542a9 in KFileMetaInfo (this=0xbffaf0c8, path=@0xbffaf0cc)
    at /home/mi/kde/src/KDE/kdelibs/kio/kio/kfilemetainfo.cpp:224
#16 0x08081098 in InfoSidebarPage::showMetaInfo (this=0x82f8838)
    at /home/mi/kde/src/KDE/kdebase/apps/dolphin/src/infosidebarpage.cpp:361
#17 0x08081c14 in InfoSidebarPage::showItemInfo (this=0x82f8838)
    at /home/mi/kde/src/KDE/kdebase/apps/dolphin/src/infosidebarpage.cpp:217
#18 0x08081eb9 in InfoSidebarPage::slotTimeout (this=0x82f8838)
    at /home/mi/kde/src/KDE/kdebase/apps/dolphin/src/infosidebarpage.cpp:223
#19 0x08082506 in InfoSidebarPage::qt_metacall (this=0x82f8838, 
    _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbffaf238)
    at /home/mi/kde/build/KDE/kdebase/apps/dolphin/src/infosidebarpage.moc:92
#20 0xb7e244f9 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#21 0xb7e24bc2 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#22 0xb7e61e07 in QTimer::timeout () from /usr/lib/libQtCore.so.4
#23 0xb7e2b67e in QTimer::timerEvent () from /usr/lib/libQtCore.so.4
#24 0xb7e1fc9a in QObject::event () from /usr/lib/libQtCore.so.4
#25 0xb683cc0c in QApplicationPrivate::notify_helper ()
   from /usr/lib/libQtGui.so.4
#26 0xb68417a9 in QApplication::notify () from /usr/lib/libQtGui.so.4
#27 0xb794b6db in KApplication::notify (this=0xbffaf97c, receiver=0x84553c8, 
    event=0xbffaf708)
    at /home/mi/kde/src/KDE/kdelibs/kdeui/kernel/kapplication.cpp:311
#28 0xb7e0f6a9 in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#29 0xb7e3d1a1 in ?? () from /usr/lib/libQtCore.so.4
#30 0xb7e3aa40 in ?? () from /usr/lib/libQtCore.so.4
#31 0xb60d9bf8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#32 0xb60dce5e in ?? () from /usr/lib/libglib-2.0.so.0
#33 0xb60dd3ac in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#34 0xb7e3af98 in QEventDispatcherGlib::processEvents ()
   from /usr/lib/libQtCore.so.4
#35 0xb68d01b5 in ?? () from /usr/lib/libQtGui.so.4
#36 0xb7e0e92d in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#37 0xb7e0eabd in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#38 0xb7e10d3d in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#39 0xb683c567 in QApplication::exec () from /usr/lib/libQtGui.so.4
#40 0x08084a7d in main (argc=6, argv=0xbffafb34)
    at /home/mi/kde/src/KDE/kdebase/apps/dolphin/src/main.cpp:94
#0  0xb7f26410 in __kernel_vsyscall ()
Comment 1 Peter Penz 2008-06-12 07:35:32 UTC
Seems to be a strigi issue. I'm not sure whether this is related to bug #163050.
Comment 2 Rui G. 2008-06-12 16:38:05 UTC
@Peter, this is exactly the same bug as a bug I reported and you closed as duplicate of that 163050. The problem is in that bug somewhere, I'll mark it as duplicate.

@miki, you can solve the crash by removing the information panel. If it still crashes after you removed it, please reopen the bug.

*** This bug has been marked as a duplicate of 163050 ***
Comment 3 Peter Penz 2008-06-15 10:15:18 UTC
Corresponding to Jos' reply on bug #163050 this is a separate issue.
Comment 4 armin walland 2008-06-20 13:06:22 UTC
i am getting the same crash an thought it might help to add a backtrace, since mine seems to look a little different for whatever reason o.O

the crash happens when hovering a video file:

Application: Dolphin (dolphin), signal SIGABRT
Using host libthread_db library "/lib/i686/cmov/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 0xb5fea720 (LWP 3480)]
[KCrash handler]
#6  0xffffe410 in __kernel_vsyscall ()
#7  0xb633eef5 in raise () from /lib/i686/cmov/libc.so.6
#8  0xb6340871 in abort () from /lib/i686/cmov/libc.so.6
#9  0xb63380ee in __assert_fail () from /lib/i686/cmov/libc.so.6
#10 0xb6631311 in Strigi::DataEventInputStream::DataEventInputStream ()
   from /home/kde-devel/kde/lib/libstreams.so.0
#11 0xb66ce384 in Strigi::EventThroughAnalyzer::connectInputStream ()
   from /home/kde-devel/kde/lib/libstreamanalyzer.so.0
#12 0xb66fd2a1 in Strigi::StreamAnalyzerPrivate::analyze ()
   from /home/kde-devel/kde/lib/libstreamanalyzer.so.0
#13 0xb66fdd7f in Strigi::StreamAnalyzer::analyze ()
   from /home/kde-devel/kde/lib/libstreamanalyzer.so.0
#14 0xb76460dc in KFileMetaInfoPrivate::init (this=0x81af9a8, 
    stream=@0xbfb3c7cc, url=@0xbfb3c7c4, mtime=1099401846)
    at /home/kde-devel/kde/src/KDE/kdelibs/kio/kio/kfilemetainfo.cpp:201
#15 0xb76464c5 in KFileMetaInfo (this=0xbfb3c850, path=@0xbfb3c854)
    at /home/kde-devel/kde/src/KDE/kdelibs/kio/kio/kfilemetainfo.cpp:224
#16 0x0807e6c3 in InfoSidebarPage::showMetaInfo (this=0x81b4f30)
    at /home/kde-devel/kde/src/KDE/kdebase/apps/dolphin/src/infosidebarpage.cpp:369
#17 0x0807f24a in InfoSidebarPage::showItemInfo (this=0x81b4f30)
    at /home/kde-devel/kde/src/KDE/kdebase/apps/dolphin/src/infosidebarpage.cpp:225
#18 0x0807f4ef in InfoSidebarPage::slotTimeout (this=0x81b4f30)
    at /home/kde-devel/kde/src/KDE/kdebase/apps/dolphin/src/infosidebarpage.cpp:231
#19 0x0807fb72 in InfoSidebarPage::qt_metacall (this=0x81b4f30, 
    _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbfb3ca28)
    at /home/kde-devel/kde/build/KDE/kdebase/apps/dolphin/src/infosidebarpage.moc:92
#20 0xb7e3d7e9 in QMetaObject::activate (sender=0x81fe418, 
    from_signal_index=4, to_signal_index=4, argv=0x0)
    at kernel/qobject.cpp:3010
#21 0xb7e3deb2 in QMetaObject::activate (sender=0x81fe418, m=0xb7f0eae4, 
    local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3080
#22 0xb7e7b0d7 in QTimer::timeout (this=0x81fe418)
    at .moc/release-shared/moc_qtimer.cpp:126
#23 0xb7e4496e in QTimer::timerEvent (this=0x81fe418, e=0xbfb3cef8)
    at kernel/qtimer.cpp:263
#24 0xb7e38f8a in QObject::event (this=0x81fe418, e=0xbfb3cef8)
    at kernel/qobject.cpp:1105
#25 0xb68d47ec in QApplicationPrivate::notify_helper (this=0x80a89b8, 
    receiver=0x81fe418, e=0xbfb3cef8) at kernel/qapplication.cpp:3772
#26 0xb68d9379 in QApplication::notify (this=0xbfb3d170, receiver=0x81fe418, 
    e=0xbfb3cef8) at kernel/qapplication.cpp:3366
#27 0xb7940ebf in KApplication::notify (this=0xbfb3d170, receiver=0x81fe418, 
    event=0xbfb3cef8)
    at /home/kde-devel/kde/src/KDE/kdelibs/kdeui/kernel/kapplication.cpp:311
#28 0xb7e28aa9 in QCoreApplication::notifyInternal (this=0xbfb3d170, 
    receiver=0x81fe418, event=0xbfb3cef8) at kernel/qcoreapplication.cpp:587
#29 0xb7e56491 in QTimerInfoList::activateTimers (this=0x80ae374)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#30 0xb7e53d30 in timerSourceDispatch (source=0x80ae340)
    at kernel/qeventdispatcher_glib.cpp:166
#31 0xb628d978 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#32 0xb6290bce in ?? () from /usr/lib/libglib-2.0.so.0
#33 0x080ace98 in ?? ()
#34 0x00000000 in ?? ()
#0  0xffffe410 in __kernel_vsyscall ()


i hope this helps. thanks a lot for all your effort! :)
Comment 5 miki 2008-06-20 13:28:13 UTC
uh still crash here ...backtrance is same as  armin walland  wrote
Comment 6 Christophe Marin 2008-06-22 10:59:36 UTC
*** Bug 164621 has been marked as a duplicate of this bug. ***
Comment 7 Pino Toscano 2008-06-29 13:03:16 UTC
*** Bug 163436 has been marked as a duplicate of this bug. ***
Comment 8 Pino Toscano 2008-06-29 13:05:07 UTC

*** This bug has been marked as a duplicate of 164296 ***
Comment 9 Pino Toscano 2008-06-29 13:08:11 UTC
Forgot to say: voters of this bug, in case you want to move your votes to bug #164296.