Bug 163043 - Right click behavior in "folder view" widget items
Summary: Right click behavior in "folder view" widget items
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-02 09:04 UTC by Rúben Gonçalves
Modified: 2008-06-09 12:04 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rúben Gonçalves 2008-06-02 09:04:12 UTC
Version:            (using Devel)
Installed from:    Compiled sources
OS:                Linux

When right clicking an item (icon) contained in a "folder view" widget,the options about the widget itself are shown. In my opinion the expected behavior should be just the same like when we right click an item in Dolphin: the actions that can be done with the item (file, folder,shortcut,etc) show up. 

Thanks for your work on kde 4.

Rúben
Comment 1 FiNeX 2008-06-02 18:27:02 UTC
I agree with Ruben. Anyway I think this is an already planned feature, isn't it?
Comment 2 Michael Braun 2008-06-06 15:49:32 UTC
This feature should be implemented to get a smooth functionality. It was the first thing I tested after I've added the folder view to my desktop.
Comment 3 Hans Chen 2008-06-07 01:23:50 UTC
Yes, hope this'll be implanted soon. Then I might even consider placing icons on my desktop again.

By the way, duplicate of Bug 155057.
Comment 4 FiNeX 2008-06-07 09:38:46 UTC
Isn't folder view and desktop icons different things?
Comment 5 Hans Chen 2008-06-07 10:46:00 UTC
Yes, I believe so. The recent comments in that bug are about folder view, but looking at the original report, this wish probably shouldn't be marked as a duplicate.
Comment 6 FiNeX 2008-06-07 11:58:49 UTC
I hope that cut/copy/paste will be implemented for 4.1, otherwise a lot of people will skip 4.1 for daily usage and will keep using 3.5, me too.

Actually the folder view without cut/copy/paste is nearly useless.


P.S: a "containment-folder" component should be added here on bugzilla.
Comment 7 Fredrik Höglund 2008-06-09 01:49:56 UTC
SVN commit 818609 by fredrik:

Add the context menu for the icons in the folder view, and add
the "Create New", "Undo" and "Paste" actions to the applet's
context menu.

CCBUG: 155057
BUG: 163043


 M  +1 -1      CMakeLists.txt  
 M  +310 -11   folderview.cpp  
 M  +23 -1     folderview.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=818609
Comment 8 FiNeX 2008-06-09 11:09:54 UTC
Great!!!

The next steps are the DnD, a scrollbar and something which tell the name/path of the directory :-)

I'll open separate wishes.
Comment 9 Beat Wolf 2008-06-09 12:04:57 UTC
I think both have a patch floating around (at least i just saw the one for telling the path on reviewboard http://reviewboard.vidsolbach.de/r/50/ )