Bug 155057 - Icons do not have standard file actions in context-menus
Summary: Icons do not have standard file actions in context-menus
Status: RESOLVED WORKSFORME
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist with 50 votes (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 155586 157014 161245 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-01-04 01:12 UTC by Niels van Mourik
Modified: 2008-06-09 12:22 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot of how it's currently in trunk (65.61 KB, image/png)
2008-05-25 12:02 UTC, Niels van Mourik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Niels van Mourik 2008-01-04 01:12:28 UTC
Version:           Revision 756918 of kdebase (using KDE Devel)
Installed from:    Compiled sources
Compiler:          gcc 4.1.3 
OS:                Linux

Possibly totally stupid to file a bug for this, I'm sure most devs are already known to the lack of context menus on plasma icons.

Just to make sure...
Comment 1 Alex Merry 2008-01-04 01:30:13 UTC
Really?  I get "Icon settings" and "Remove this icon" when I right-click on an icon...
Comment 2 Niels van Mourik 2008-01-04 02:03:50 UTC
Obviously I wasn't clear enough but I meant the normal file operations: cut, copy, rename, open with, move to trash...
Comment 3 Christopher Blauvelt 2008-01-05 16:55:46 UTC
It's on my todo list.
Comment 4 Aaron J. Seigo 2008-01-13 12:23:30 UTC
*** Bug 155586 has been marked as a duplicate of this bug. ***
Comment 5 Sebastian Sauer 2008-02-25 02:40:53 UTC
*** Bug 157014 has been marked as a duplicate of this bug. ***
Comment 6 Jason Stubbs 2008-05-24 16:45:45 UTC
The folder view applet in 4.1 (trunk) rectifies this.
Comment 7 Niels van Mourik 2008-05-25 12:01:39 UTC
Just compiled r812284 of playground's plasma dir. And it doesn't yet provide a list of std file operations (cut, copy, paste, delete, properties, actions). But it is probably on somebodies todo list. See screenshot.
Comment 8 Niels van Mourik 2008-05-25 12:02:25 UTC
Created attachment 24929 [details]
Screenshot of how it's currently in trunk
Comment 9 Alessio Pollero 2008-05-25 12:05:08 UTC
Copy - Cut - Open with ... 

Where are?
Comment 10 Jason Stubbs 2008-05-25 12:24:43 UTC
Apologies, you're (both) right.
Comment 11 Jason Stubbs 2008-05-25 15:49:18 UTC
If I'm not missing something, this might have to wait until have 4.1 unless someone can perform some serious voodoo. Looking at dolphin/src/dolphincontextmenu.cpp, the menu is going to be have to put together manually. Copy/paste would get it done, but that's seriously suboptimal.
Comment 12 Niels van Mourik 2008-05-25 19:58:25 UTC
I don't know at all how the fileview is put together, but it isn't for sure an embedded Kpart on plasma right?

In that case we will probably have to wait until it is in some KFileMenu foo library. I agree that copy/paste is that suboptimal the fix can better wait till 4.2.
Comment 13 Jay LaCroix 2008-05-25 20:06:36 UTC
If it's not too much trouble, I think we should have file management on 
the desktop in KDE 4.1. It's way too much trouble to have to open 
Dolphin just to delete stuff on the desktop. The desktop is used as a 
workspace by a lot of people, including me. In fact, this feature being 
missing is the only thing preventing me from using KDE full time, and if 
it waits until 4.2, that means I'll have to skip yet another KDE release.

Niels van Mourik wrote:
[bugs.kde.org quoted mail]
Comment 14 Niels van Mourik 2008-05-25 20:10:42 UTC
Copying the code over from Dolphin sounds like an ugly hack too me as well, but if it's the only solution (it's feature freeze as well) then that is probably the solution to be considered.

But I'm not the developer here :)
Comment 15 Fredrik Höglund 2008-05-25 22:16:30 UTC
Ideally we'd link in libkonq, and create a KonqPopupMenu, which is what kdesktop does in 3.5. The only problem is that libkonq is in kdebase/apps and we can't create a cross module dependency between workspace and apps, so we'll have to copy this code into the applet. That's what I plan to do in 4.1.
Comment 16 Jason Stubbs 2008-06-01 08:42:07 UTC
*** Bug 161245 has been marked as a duplicate of this bug. ***
Comment 17 Jay LaCroix 2008-06-02 02:54:45 UTC
Hello everyone!

I'm checking out KDE4Daily (Virtualbox Image) now and I'm very impressed with the folder view applet. This applet is much better than the standard "show desktop folder on desktop" way of the past. Very impressive.

Anyway, I think if you guys added file management (cut, copy, paste, delete) to the folderview applet, that would solve this for me. Also, if I download a zip file or similar to my desktop, I would prefer to have the standard "extract here" context menu item as well.

Please consider this.
Comment 18 Fredrik Höglund 2008-06-09 01:49:56 UTC
SVN commit 818609 by fredrik:

Add the context menu for the icons in the folder view, and add
the "Create New", "Undo" and "Paste" actions to the applet's
context menu.

CCBUG: 155057
BUG: 163043


 M  +1 -1      CMakeLists.txt  
 M  +310 -11   folderview.cpp  
 M  +23 -1     folderview.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=818609
Comment 19 mimoune djouallah 2008-06-09 11:45:10 UTC
just thank you FREDRICK,now plasma really kick ass ;) and i was about to fill a wish to add folder path to folder view applet and to my surprise there is already  a patch to do that. you rock plasma developers  
Comment 20 Niels van Mourik 2008-06-09 12:22:28 UTC
This is seriously awesome! It works as a charm!

Thanks Fredrik!!!