Bug 162568 - Task manager hardly usable with a large number of windows open
Summary: Task manager hardly usable with a large number of windows open
Status: RESOLVED DUPLICATE of bug 163935
Alias: None
Product: plasma4
Classification: Plasma
Component: widget-taskbar (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 164912 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-05-24 18:41 UTC by Erik Hahn
Modified: 2008-07-31 21:54 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot showing the problem (59.88 KB, image/png)
2008-05-24 18:45 UTC, Erik Hahn
Details
Re #11 more rows - it seems this work is partially done or there is a chance do it (37.91 KB, image/png)
2008-06-26 09:59 UTC, Ladislav Nesnera
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Hahn 2008-05-24 18:41:20 UTC
Version:            (using Devel)
Installed from:    Compiled sources
Compiler:          gcc 4.2.3 
OS:                Linux

When a large number of windows is open, the task manager becomes hardly usable because the entries are too small.
Comment 1 Erik Hahn 2008-05-24 18:45:25 UTC
Created attachment 24923 [details]
Screenshot showing the problem
Comment 2 FiNeX 2008-06-15 16:58:26 UTC
*** Bug 164136 has been marked as a duplicate of this bug. ***
Comment 3 Maciej Pilichowski 2008-06-15 17:10:38 UTC
My idea from (http://bugs.kde.org/show_bug.cgi?id=163920, dup of this) was to add scrollbars on-fly.

Another idea would (if another wish would be implemented -- dynamic taskbar, which could be bigger than panel) to simply add rows on-fly.
Comment 4 FiNeX 2008-06-25 11:13:38 UTC
*** Bug 164857 has been marked as a duplicate of this bug. ***
Comment 5 FiNeX 2008-06-25 12:29:12 UTC
*** Bug 164912 has been marked as a duplicate of this bug. ***
Comment 6 FiNeX 2008-06-25 12:45:57 UTC
*** Bug 163920 has been marked as a duplicate of this bug. ***
Comment 7 Ladislav Nesnera 2008-06-25 13:27:44 UTC
Next one idea - collect buttons of multiple windows of the same application to one node (button for windows of text processor, browser, file manager etc.)
Comment 8 Maciej Pilichowski 2008-06-25 13:37:43 UTC
ad.#7) yes, but _optionally_
Comment 9 Ladislav Nesnera 2008-06-25 13:40:41 UTC
Re #8 - OK ;?)
Comment 10 Christian Mollekopf 2008-06-25 14:25:15 UTC
Grouping of Tasks in the taskbar is in work...
Comment 11 Beat Wolf 2008-06-25 14:34:15 UTC
simply 2 rows of tasks would already be nice
Comment 12 Ladislav Nesnera 2008-06-26 09:59:20 UTC
Created attachment 25614 [details]
Re #11 more rows - it seems this work is partially done or there is a chance do it
Comment 13 Maciej Pilichowski 2008-06-26 10:32:21 UTC
Ladislav, this is taskbar, not a systray.
Comment 14 zOOm_ER 2008-06-26 20:50:55 UTC
I think problem will be fully resolved if 2 things will be implemented:
1) Multirow task list
2) Grouping of same windows in taskbar

optionaly turning that features on or off in the taskmanager settings will be great.

As i know none of them is implemented for now, am i right?
Comment 15 Maciej Pilichowski 2008-06-26 22:18:21 UTC
Fully resolved? Not really, note that (2) is hardly a solution -- how often you get into problems by running four instances of KDevelop or Kate? Me -- never. Ladislav here presented (#7) very nice idea -- grouping not by program but by category.

Multirows is of course needed but you cannot really fix the problem with no space for entry just by making them smaller (rows have to fit somewhere, right?). 

All those idea given here are important, but all of them, not only 1 or 2 of them -- grouping (by program or by category), multirows and "scrollbars". Of course new ideas are welcome :-)

Btw. MacOSX solution (5th idea) would also could help in solving this (autozoom on hover).
Comment 16 Jarle Thorsen 2008-07-14 21:00:10 UTC
I would suggest adding an option to only have iconified programs show up in the taskbar. This is a *much* missed feature of KDE3 that would keep the taskmanager from being all cluttered up.
Comment 17 Jarle Thorsen 2008-07-14 21:31:15 UTC
When I write "iconified programs", I actually mean programs that are minimized... just to avoid any confusion.
Comment 18 Aaron J. Seigo 2008-07-31 21:54:02 UTC
marking as dupe of multiple rows, though it's really a dupe of a couple bugs; should be broken into more fine-grained issues, thankfully we already have reports that are.

*** This bug has been marked as a duplicate of 163935 ***