Bug 161848 - please enable file previews in the file tooltips for konqueror filemanager/dolphin in KDE4
Summary: please enable file previews in the file tooltips for konqueror filemanager/do...
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Ubuntu Linux
: NOR wishlist with 30 votes (vote)
Target Milestone: ---
Assignee: Simon St James
URL:
Keywords:
: 168092 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-05-09 16:15 UTC by Peter Paulsen
Modified: 2009-02-01 14:55 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Paulsen 2008-05-09 16:15:27 UTC
Version:            (using KDE 4.0.3)
Installed from:    Ubuntu Packages

Because konqueror filemanager in KDE4 actually seems to be dolphin I report this for dolphin. The konq filemanager in KDE 3.5 very comfortably displays a file preview when hovering with the mouse over the file. That's extremely helpful especially for photos even when you have the thumbnails enabled because the tooltip shows the picture in a larger size than the thumbnail does so you can quickly decide what to do with the pictures just by mousing over them. The "simple mode" dolphin filemanager has an information sidebar which shows a bigger preview but the "expert mode" konqueror dolphin does not, no extra previews at all. But even in pure dolphin I'd love to see tooltips with file previews for pictures because the info panel takes up so much space I'd rather don't want to have it open all the time and having the preview just where the mouse cursor is is easier for the eyes, you don't have to switch between file and right panel with the view.
Comment 1 Peter Penz 2008-05-09 20:37:09 UTC
Tooltips will be supported for KDE 4.1 in Dolphin and Konqueror, but currently no previews have been integrated... But for sure will implement this, I just cannot promise that it will be done until KDE 4.1 :-)
Comment 2 Bassio 2008-06-16 21:13:57 UTC
Indeed, not just for images .. but for any filetype

A tooltip popup with basic file info like its complete name (since long filenames are always not completely shown underneath the icons), extension, size etc.
Comment 3 Peter Penz 2008-06-16 21:24:23 UTC
Currently the tooltips for KDE 4.1 show already basic infos like name, type, modified, owner and permissions. If previews are enabled for the tooltips (KDE 4.2 - sorry, it's too late already) then it will work for all kind of filetypes.
Comment 4 Mike Williams 2008-07-22 18:11:56 UTC
I'm running RC1, and I don't see any tooltips. Is this just not going to make it into 4.1, or is this a bug?
Comment 5 Peter Penz 2008-07-22 19:47:59 UTC
@Mike: you have to turn on the tooltips in the settings (they are turned off per default)
Comment 6 Peter Penz 2008-08-02 13:00:12 UTC
*** Bug 168092 has been marked as a duplicate of this bug. ***
Comment 7 Simon St James 2008-08-14 22:46:03 UTC
I have a preliminary patch here.  I've sent it to Fredrik (who wrote the KToolTips portion) and if he gives it the all clear I'll attach it here for Peter to review :)

Still has a few outstanding issues, but appears to work well in general.
Comment 8 Peter Penz 2008-08-15 13:57:32 UTC
> I have a preliminary patch here.  I've sent it to Fredrik
> (who wrote the KToolTips portion) and if he gives it the all
> clear I'll attach it here for Peter to review :) 

Great to hear :-)
Comment 9 Simon St James 2008-08-20 10:07:20 UTC
Looks like my CCBUG didn't work, so here it is again: A very preliminary version has been committed to SVN:

http://websvn.kde.org/?view=rev&revision=848984

As the comment says, there's still a great deal of refinement to be done to it, but it works pretty well for now :)
Comment 10 Laurens Vanhove 2008-09-11 11:03:40 UTC
The tooltip preview is now fully functionnal (in trunk, will be kde4.2), so this bug should be closed ! Could you do that Simon ?
Comment 11 Simon St James 2008-09-11 11:17:39 UTC
Sure, and many thanks for getting it working so smoothly!
Comment 12 Aneurin Price 2009-02-01 14:55:52 UTC
IS there any chance the option to show tooltips could be enabled by default? I didn't notice that option until I read about it here, and it was on by default (possibly not optional) in earlier KDE versions. Or is that entirely up to packagers?