Bug 161427 - Cannot select year in Date Chooser
Summary: Cannot select year in Date Chooser
Status: RESOLVED DUPLICATE of bug 68336
Alias: None
Product: korganizer
Classification: Applications
Component: general (show other bugs)
Version: 3.5
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-30 00:51 UTC by Dotan Cohen
Modified: 2008-08-16 21:38 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
(55.08 KB, image/png)
2008-08-16 21:33 UTC, Dotan Cohen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dotan Cohen 2008-04-30 00:51:40 UTC
Version:           1.2.9 (using KDE 3.5.9)
OS:                Linux

When Korganizer is in Hebrew, no matter where one clicks on the Date Chooser, he can only select the month. The user must then browse to the correct year with the double arrow buttons.
Comment 1 Allen Winter 2008-08-15 02:33:49 UTC
Dotan,

Does this still happen in KDE 4?
Maybe we should assign this to Diego.
Comment 2 Diego Iastrubni 2008-08-15 10:11:24 UTC
Allen, just run korganizer using "korganizer --reverse" and see if you can reproduce. 
IMHO, it will take me too much time to understand the code until if manage to fix this issue, while you will be able to do this in minutes. 

Specially since I don't understand what Dotan is complaining about ;-)
Comment 3 Dotan Cohen 2008-08-16 13:03:40 UTC
Yes, this problem still exists in KDE4. I will start up 4.1 in a few days and make screenshots illustrating the problem.

Thanks.
Comment 4 Dotan Cohen 2008-08-16 21:33:02 UTC
Created attachment 26881 [details]
 


It appears that in English as well as Hebrew, one cannot choose the year.
Clicking anywhere in the red area in the screenshot brings up the Month
Chooser. I would expect that clicking on the date would bring up a Year
Chooser.
Comment 5 Dotan Cohen 2008-08-16 21:36:05 UTC
I am changing this to wishlist and updating the Summary to reflect my new findings.

Wish: The user should be able to select what year he is looking at by clicking on the year in the Date Chooser (see screenshot in previous comment). This would be in a fashion similar to the way that the month is currently selectable.
Comment 6 Allen Winter 2008-08-16 21:38:34 UTC
ah, ok.
I completely misunderstood this bug report.  Once I saw "Hebrew" in the description I immediately thought this was a LTR vs. RTL issue.

yes, this bug is known.

*** This bug has been marked as a duplicate of 68336 ***