Bug 160244 - KMail dies from SIGFPE
Summary: KMail dies from SIGFPE
Status: RESOLVED DUPLICATE of bug 152898
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.9
Platform: unspecified FreeBSD
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-02 07:43 UTC by mi+kde
Modified: 2008-04-02 15:57 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mi+kde 2008-04-02 07:43:59 UTC
Version:           1.9.9 (using 3.5.9, compiled sources)
Compiler:          Target: amd64-undermydesk-freebsd
OS:                FreeBSD (amd64) release 7.0-STABLE

I access the same two mail accounts via IMAP from home and from office. One of the two accounts is configured as "Disconnected IMAP" at home, but as a regular IMAP at the office.

Almost every day, when I come home, I find KMail dead from SIGFPE (Floating Point Error). I presume, this is due to my manipulating of e-mails from the office via regular IMAP, that affects the home KMail's calculations and causes it to divide by 0 or some such...

Here is the stack from drkonqi:

[New Thread 0x6066e0 (LWP 100402)]
[New Thread 0x606570 (LWP 100401)]
[New Thread 0x606400 (LWP 100112)]
[New Thread 0x606290 (LWP 100059)]
[New Thread 0x606120 (LWP 100361)]
[Switching to Thread 0x6066e0 (LWP 100402)]
0x0000000806dd55dc in _umtx_op () from /lib/libc.so.7
#0  0x0000000806dd55dc in _umtx_op () from /lib/libc.so.7
#1  0x0000000806c81019 in pthread_cleanup_push () from /lib/libthr.so.3
#2  0x0000000806c7fa25 in pthread_cond_init () from /lib/libthr.so.3
#3  0x000000080571b826 in QWaitCondition::wait () from /opt/lib/libqt-mt.so.3
#4  0x00000008012a8e22 in KPIM::ThreadWeaver::Weaver::applyForWork ()
   from /opt/lib/libkdepim.so.1
#5  0x00000008012a8130 in KPIM::ThreadWeaver::Thread::run ()
   from /opt/lib/libkdepim.so.1
#6  0x00000008054685c4 in QThreadInstance::start ()
   from /opt/lib/libqt-mt.so.3
#7  0x0000000806c79a96 in pthread_getprio () from /lib/libthr.so.3
#8  0x0000000000000000 in ?? ()
Comment 1 Thomas McGuire 2008-04-02 15:57:29 UTC

*** This bug has been marked as a duplicate of 152898 ***