Bug 152898 - KMail crashes after some time on BSD
Summary: KMail crashes after some time on BSD
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.8
Platform: unspecified FreeBSD
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 160244 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-11-25 22:16 UTC by Al Muckart
Modified: 2012-08-21 07:39 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Al Muckart 2007-11-25 22:16:51 UTC
Version:           1.9.7 (using KDE 3.5.8, compiled sources)
Compiler:          Target: amd64-undermydesk-freebsd
OS:                FreeBSD (amd64) release 7.0-BETA3

Kmail just crashed with a signal 6 when I switched back to the desktop it was on from another desktop.  It happened too fast for me to see if my mouse pointer was over a message when I switched onto the desktop or not.

The backtrace looks different to my untrained eye from the ones that the "check for duplicates" search popped up. 

[New Thread 0x808601f80 (LWP 100122)]
[New Thread 0x808601e10 (LWP 100121)]
[New Thread 0x808601ca0 (LWP 100120)]
[New Thread 0x808601b30 (LWP 100119)]
[New Thread 0x808601120 (LWP 100051)]
[Switching to Thread 0x808601f80 (LWP 100122)]
0x000000080739bbfc in _umtx_op () from /lib/libc.so.7
#0  0x000000080739bbfc in _umtx_op () from /lib/libc.so.7
#1  0x000000080723b769 in pthread_cleanup_push () from /lib/libthr.so.3
#2  0x000000080723a148 in pthread_cond_init () from /lib/libthr.so.3
#3  0x0000000805bda187 in QWaitCondition::wait (this=0x8088ce5d0, 
    time=18446744073709551615) at tools/qwaitcondition_unix.cpp:242
#4  0x00000008013339c4 in KPIM::ThreadWeaver::Weaver::applyForWork (
    this=0x8088ce500, th=0x8094c9d20, previous=) at weaver.cpp:519
#5  0x0000000801333c10 in KPIM::ThreadWeaver::Thread::run (this=0x8094c9d20)
    at weaver.cpp:215
#6  0x000000080587f8b6 in QThreadInstance::start (_arg=0x808ba7688)
    at kernel/qthread_unix.cpp:119
#7  0x0000000807233a66 in pthread_getprio () from /lib/libthr.so.3
#8  0x0000000000000000 in ?? ()
Comment 1 Thomas McGuire 2007-11-25 22:30:40 UTC
This backtrace looks like one of the threads in bug 147358 (which is also BSD, by the way).
Did KMail crash or just hang?
The backtrace seems to be only of one thread unfortunately, I guess the real crash happens in another thread. Could you get a backtrace of that too?
Comment 2 Al Muckart 2007-11-25 22:39:02 UTC
Kmail crashed. All the windows (including an open composer window) dissappeared and the crash handler popped up.

I forgot to mention that this is an SMP box (AMD64 dual-core if that's important).

I'm not sure what caused the crash but I'll have a play running this out of GDB later and see if I can reproduce it.
Comment 3 Mike D 2008-02-17 13:46:20 UTC
Kmail crashes continually with 6 SIGABRT signal when I am trying to read messages from AOL IMAP server.

O/S is OpenSUSE 10.3 fully patched (Running on ASRock K7VT4A Pro M/B with Athlon XP2000+ cpu).
KDE desktop 3.5.7 Release 72.6.

Only major difference from standard install is VLC MediaPlayer.

This is the error trace...



System configuration startup check disabled.

[?1034h(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb5882950 (LWP 3791)]
[New Thread 0xb3b26b90 (LWP 3795)]
[New Thread 0xb4327b90 (LWP 3794)]
[New Thread 0xb4b28b90 (LWP 3793)]
[New Thread 0xb5329b90 (LWP 3792)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0xffffe410 in __kernel_vsyscall ()
#7  0xb6e188f5 in raise () from /lib/libc.so.6
#8  0xb6e1a1e1 in abort () from /lib/libc.so.6
#9  0xb6fde380 in __gnu_cxx::__verbose_terminate_handler ()
   from /usr/lib/libstdc++.so.6
#10 0xb6fdbc25 in ?? () from /usr/lib/libstdc++.so.6
#11 0xb6fdbc62 in std::terminate () from /usr/lib/libstdc++.so.6
#12 0xb6fdc505 in __cxa_pure_virtual () from /usr/lib/libstdc++.so.6
#13 0xb7bcaf6f in KMReaderWin::setMsg () from /opt/kde3/lib/libkmailprivate.so
#14 0xb7d424ee in KMMainWidget::slotMsgSelected ()
   from /opt/kde3/lib/libkmailprivate.so
#15 0xb7d54b11 in KMMainWidget::qt_invoke ()
   from /opt/kde3/lib/libkmailprivate.so
#16 0xb72ab90d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#17 0xb7b744ce in KMHeaders::selected () from /opt/kde3/lib/libkmailprivate.so
#18 0xb7b7c5eb in KMHeaders::highlightMessage ()
   from /opt/kde3/lib/libkmailprivate.so
#19 0xb7b7c9dc in KMHeaders::highlightMessage ()
   from /opt/kde3/lib/libkmailprivate.so
#20 0xb7b856e7 in KMHeaders::qt_invoke () from /opt/kde3/lib/libkmailprivate.so
#21 0xb72ab90d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#22 0xb75f2c71 in QListView::currentChanged ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#23 0xb738b8de in QListView::setCurrentItem ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#24 0xb738e866 in QListView::contentsMousePressEventEx ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#25 0xb738f214 in QListView::contentsMousePressEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#26 0xb5f9b05d in KListView::contentsMousePressEvent ()
   from /opt/kde3/lib/libkdeui.so.4
#27 0xb7b7cb05 in KMHeaders::contentsMousePressEvent ()
   from /opt/kde3/lib/libkmailprivate.so
#28 0xb73c0771 in QScrollView::viewportMousePressEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#29 0xb73bdb06 in QScrollView::eventFilter ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#30 0xb738c6b6 in QListView::eventFilter () from /usr/lib/qt3/lib/libqt-mt.so.3
#31 0xb7b76889 in KMHeaders::eventFilter ()
   from /opt/kde3/lib/libkmailprivate.so
#32 0xb72ab12c in QObject::activate_filters ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#33 0xb72ab19b in QObject::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#34 0xb72e462c in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#35 0xb724d10c in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#36 0xb724e033 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#37 0xb78f6ee2 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#38 0xb71ec4fa in QETWidget::translateMouseEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#39 0xb71eb2c6 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#40 0xb71fc0d0 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#41 0xb7263c90 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#42 0xb7263b26 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#43 0xb724cc7f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#44 0x0804a31c in QObject::checkConnectArgs ()
#45 0xbfce3454 in ?? ()
#46 0xbfce344c in ?? ()
#47 0x00000000 in ?? ()
Comment 4 Ronny Standtke 2008-03-22 11:07:36 UTC
I use Kubuntu 7.10 with all available updates. KMail just crashed while I was reading my mails on an IMAP account. My stacktrace looks similar like the above one:

(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1242802496 (LWP 5614)]
[New Thread -1287795824 (LWP 5678)]
[New Thread -1279403120 (LWP 5677)]
[New Thread -1271010416 (LWP 5676)]
[New Thread -1262617712 (LWP 5675)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0xb4f9f34e in KMReaderWin::setMsg () from /usr/lib/libkmailprivate.so
#7  0xb510a2a2 in KMMainWidget::slotMsgSelected ()
   from /usr/lib/libkmailprivate.so
#8  0xb511d330 in KMMainWidget::qt_invoke () from /usr/lib/libkmailprivate.so
#9  0xb6766893 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#10 0xb4f42a81 in KMHeaders::selected () from /usr/lib/libkmailprivate.so
#11 0xb4f4a5c3 in KMHeaders::highlightMessage ()
   from /usr/lib/libkmailprivate.so
#12 0xb4f4a9ac in KMHeaders::highlightMessage ()
   from /usr/lib/libkmailprivate.so
#13 0xb4f53336 in KMHeaders::qt_invoke () from /usr/lib/libkmailprivate.so
#14 0xb6766893 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#15 0xb6b0a7cd in QListView::currentChanged () from /usr/lib/libqt-mt.so.3
#16 0xb6860e9f in QListView::setCurrentItem () from /usr/lib/libqt-mt.so.3
#17 0xb6864c93 in QListView::contentsMousePressEventEx ()
   from /usr/lib/libqt-mt.so.3
#18 0xb6865398 in QListView::contentsMousePressEvent ()
   from /usr/lib/libqt-mt.so.3
#19 0xb70ca11c in KListView::contentsMousePressEvent ()
   from /usr/lib/libkdeui.so.4
#20 0xb4f4aae9 in KMHeaders::contentsMousePressEvent ()
   from /usr/lib/libkmailprivate.so
#21 0xb689c0b9 in QScrollView::viewportMousePressEvent ()
   from /usr/lib/libqt-mt.so.3
#22 0xb689d52c in QScrollView::eventFilter () from /usr/lib/libqt-mt.so.3
#23 0xb6865806 in QListView::eventFilter () from /usr/lib/libqt-mt.so.3
#24 0xb4f44839 in KMHeaders::eventFilter () from /usr/lib/libkmailprivate.so
#25 0xb6765e40 in QObject::activate_filters () from /usr/lib/libqt-mt.so.3
#26 0xb6765ebe in QObject::event () from /usr/lib/libqt-mt.so.3
#27 0xb679d5b3 in QWidget::event () from /usr/lib/libqt-mt.so.3
#28 0xb66fdaf0 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#29 0xb66ffcae in QApplication::notify () from /usr/lib/libqt-mt.so.3
#30 0xb6ec3cd2 in KApplication::notify () from /usr/lib/libkdecore.so.4
#31 0xb669027d in QApplication::sendSpontaneousEvent ()
   from /usr/lib/libqt-mt.so.3
#32 0xb668eee2 in QETWidget::translateMouseEvent ()
   from /usr/lib/libqt-mt.so.3
#33 0xb668cfcc in QApplication::x11ProcessEvent () from /usr/lib/libqt-mt.so.3
#34 0xb66a41a4 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#35 0xb67181ce in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#36 0xb6717fde in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#37 0xb66ff699 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#38 0x0805bfe5 in ?? ()
#39 0xbfd9b11c in ?? ()
#40 0x00000001 in ?? ()
#41 0x00000001 in ?? ()
#42 0x00000000 in ?? ()
Comment 5 Thomas McGuire 2008-04-02 15:57:38 UTC
*** Bug 160244 has been marked as a duplicate of this bug. ***
Comment 6 Thomas McGuire 2008-04-02 16:01:34 UTC
The backtraces from comment #3 and comment #4 are not related to this bug.
Comment 7 Thomas McGuire 2008-04-02 16:50:46 UTC
BTW, if you google for pthread_cleanup_push and _umtx_op, you'll see that this problem exists in several other applications as well.
I don't know if it is the fault of KMail or BSD.
Comment 8 Björn Ruberg 2010-01-13 11:12:48 UTC
Can you still confirm this issue with a recent kmail version?
Comment 9 mi+kde 2010-01-13 18:17:51 UTC
(In reply to comment #8)
> Can you still confirm this issue with a recent kmail version?

*I*, for one, can not. Because until there is a way to _automatically_ transfer all (or, at least, _most_) settings from KDE3 to KDE4, I'm not switching...
Comment 10 Myriam Schweingruber 2012-08-21 07:39:53 UTC
Closing based on comment #9