Bug 160068 - Panels on other screens interfere with window movement and maximization
Summary: Panels on other screens interfere with window movement and maximization
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Unclassified
Component: xinerama (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal with 2 votes (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 137811 140530 163912 164882 166377 167369 168392 170747 172029 176017 180161 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-03-29 19:26 UTC by Henrik Hudson
Modified: 2009-02-17 16:50 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Henrik Hudson 2008-03-29 19:26:32 UTC
Version:            (using KDE 4.0.2)
Installed from:    Ubuntu Packages
OS:                Linux

Running Kubuntu Hardy Heron Beta on x86.
I've got a multi-monitor setup using the nvidia twinview setup and drivers.
Screen1 has got a panel at the top and bottom.
Screen0 has no panels on it.

If I open an aterm and click maximize on Screen0 it will take up the full screen as expected. If I do the same on Screen1 it keeps the panels visible as expected.

The problem is that on Screen0 when I "restore" it to the original size I am unable to drag the window all the way to the top of the screen. The hand stops where the taskbar is on Screen1. Now, when I first open the aterm it positions it correctly all the way at the top of Screen0. So, it seems to be an issue with just the moving of a window and seeing a "ghost" panel.

Sorry, I didn't know if this should be a kicker bug or a kdesktop bug.
Comment 1 Pino Toscano 2008-03-29 19:49:34 UTC
> Sorry, I didn't know if this should be a kicker bug or a kdesktop bug. 

Neither of the two, as they do not exist in KDE 4.
Comment 2 Aaron J. Seigo 2008-06-16 04:31:58 UTC
this isn't even a plasma bug. we're doing the right thing in plasma. this is a kwin and extended wm hints issue.
Comment 3 Aaron J. Seigo 2008-06-16 05:05:06 UTC
*** Bug 163912 has been marked as a duplicate of this bug. ***
Comment 4 Chani 2008-07-12 20:00:55 UTC
*** Bug 166377 has been marked as a duplicate of this bug. ***
Comment 5 lucas 2008-07-24 11:21:06 UTC
*** Bug 164882 has been marked as a duplicate of this bug. ***
Comment 6 lucas 2008-07-24 18:51:58 UTC
*** Bug 167369 has been marked as a duplicate of this bug. ***
Comment 7 lucas 2008-08-05 14:48:06 UTC
*** Bug 168392 has been marked as a duplicate of this bug. ***
Comment 8 lucas 2008-10-02 13:10:17 UTC
*** Bug 172029 has been marked as a duplicate of this bug. ***
Comment 9 Richard Brinkman 2008-10-02 13:16:01 UTC
*** This bug has been confirmed by popular vote. ***
Comment 10 lucas 2008-11-25 16:22:46 UTC
*** Bug 176017 has been marked as a duplicate of this bug. ***
Comment 11 lucas 2008-12-14 12:32:42 UTC
*** Bug 170747 has been marked as a duplicate of this bug. ***
Comment 12 lucas 2008-12-14 12:33:15 UTC
*** Bug 140530 has been marked as a duplicate of this bug. ***
Comment 13 lucas 2008-12-14 12:36:49 UTC
*** Bug 137811 has been marked as a duplicate of this bug. ***
Comment 14 lucas 2009-01-10 17:34:07 UTC
*** Bug 180161 has been marked as a duplicate of this bug. ***
Comment 15 lucas 2009-02-17 16:50:02 UTC
SVN commit 927466 by lmurray:

Improved window movement around struts. Windows can be moved anywhere
where the titlebar is still clickable even if it is outside the normal
work area. When struts are added or removed only move the windows that
cover the same area, leave all others untouched. If a strut is removed
on a xinerama screen that is not on the edge of the full desktop area
prevent the windows from being moved offscreen. Prevent struts/panels
from interfering with the movement of windows on other xinerama screens.
BUG: 74559
BUG: 90833
BUG: 160068

 M  +0 -8      client.cpp  
 M  +2 -3      client.h  
 M  +301 -142  geometry.cpp  
 M  +0 -2      manage.cpp  
 M  +20 -0     utils.cpp  
 M  +26 -0     utils.h  
 M  +4 -0      workspace.cpp  
 M  +7 -0      workspace.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=927466